Download it now!
Bug 99911 - "Tools > Bibliography Database" should show error message, if Base package is not installed
Summary: "Tools > Bibliography Database" should show error message, if Base package is...
Status: RESOLVED DUPLICATE of bug 54479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2016-05-17 14:19 UTC by Dmytro Kyrychuk
Modified: 2016-08-02 14:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmytro Kyrychuk 2016-05-17 14:19:27 UTC
Click on "Tools - Bibliography Database" does nothing. The bibliography window does not appear. No error messages are shown.

I did ask about this in the #libreoffice channel of Freenode. The user @cloph_away suggested that the Base package was not installed, which actually was the reason. I only installed the Writer package (apt install libreoffice-writer) initially. Adding the Base package (apt install libreoffice-base) fixed the issue.

I was thinking that maybe it would be useful to add a notification message telling that Base is not installed in case when it is not installed. 

Libreoffice was installed from https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-5-1

Info from "About" view:
Version: 5.1.3.2
Build ID: 1:5.1.3~rc2-0ubuntu1~trusty1
CPU Threads: 4; OS Version: Linux 3.19; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 1 Buovjaga 2016-05-18 09:56:15 UTC
OK.
Comment 2 Björn Michaelsen 2016-05-23 10:54:04 UTC
It does something -- it call for installing the package via dbus/packagekit. However, IIRC Rene wanted it to fall back on just popping a messagebox.

FWIW, before asking for the package to be install via packagekit, it just crashed ...
Comment 3 Dmytro Kyrychuk 2016-05-23 10:59:50 UTC
> It does something -- it call for installing the package via dbus/packagekit

Well, I did not notice any activity, at least with Writer 5.1.3.2.
Comment 4 Heiko Tietze 2016-08-02 14:50:53 UTC

*** This bug has been marked as a duplicate of bug 54479 ***