Bug 100243 - System freezes when attempting to print while OpenGL is enabled
Summary: System freezes when attempting to print while OpenGL is enabled
Status: RESOLVED DUPLICATE of bug 99919
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.0.5
Keywords:
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-06-06 20:14 UTC by Hans-Dieter.Dreier
Modified: 2018-05-18 07:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
opengl_device.log (322 bytes, text/plain)
2016-06-11 14:21 UTC, Hans-Dieter.Dreier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Dieter.Dreier 2016-06-06 20:14:58 UTC
Open a new or existing document, select "print..." from the menu.
A faint transparent window frame titled "Ausdruck" (print result in German) displays, system immediately completely FREEZES (not even mouse can't be moved), fan gets louder.
And that's it. I need to switch off the PC pressing the power button for 5 sec. (not even normal shutdown possible).
Print preview works as expected (as long as not attempting to actually print).
Normal Libre Office install without any specials:

Version: 5.1.2.2 (x64)
Build-ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU-Threats: 4; BS-Version: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE)

Using a normal user account (no admin).
Hardware: Medion Akoya E6424 notebook
OS: Windows 10 Home 1511 (German), Build 10586.318, no printer attached (Microsoft XPS Document writer is standard printer).
Event log does not show any entries related to the freeze (nothing concerning Libre Office or Java).
Printing using Notepad works as expected, so it's unlikely to be a printer driver problem imo.

Expired version of McAffee virus scanner and active version of Avira free anti-virus installed on PC.

I'm surprised: How can an application completely freeze the OS like this?
IMO the problem must be closely related to my hard-/software (otherwise it should have shown more often),
so if I can help finding the bug, please let me know (I'm a programmer myself).
Comment 1 Buovjaga 2016-06-09 15:25:00 UTC
What happens, if you disable Tools - Options - LibreOffice - View - Use OpenGL for all rendering?
Could you also try with 5.1.3 or a pre-release of 5.1.4 to see, if it works even with OGL on?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists with 5.1.3/.4 and OGL on. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 Mike 2016-06-10 13:54:05 UTC
I experienced exactly the same problem as described in this report. Sending any document, text, spreadsheet, etc. caused the entire laptop to hang with no mechanism for escaping the hang other than extended push of the off switch.

Using Windows 10 Home Build 1511 and LibreOffice 5.1.3.2 (x64).

Disabling openGL as suggested below resolved the problem and I was able to print.
Comment 3 Buovjaga 2016-06-10 13:56:58 UTC
Mike, Hans-Dieter: could you copy and paste the contents of your: C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log
Comment 4 Hans-Dieter.Dreier 2016-06-11 14:21:18 UTC
Created attachment 125606 [details]
opengl_device.log

Attached my opengl_device.log. Next I'll try your suggestions... Additional info: This laptop has Intel Iris graphics (Iris-550 GPU in Core i5-6267U) and the device driver isn't exactly stable... crashing w/Firefox approx. once per week, usually while scrolling a document.
Comment 5 Hans-Dieter.Dreier 2016-06-11 14:46:41 UTC
Disabling OpenGL solved the problem. Thank you very much!
Comment 6 Buovjaga 2016-06-11 14:54:21 UTC
Nice to hear :)

Let's keep this open, because this is still a problem that needs to be fixed.

I found a similar one, bug 99516, but it is for Linux, so I will keep this as separate.

Mike: would be great to also get your opengl log file :)
Comment 7 Tor Lillqvist 2016-06-21 15:49:30 UTC
If the system freezes completely, I think that is a good reason to blacklist the particular OpenGL vendor/driver/device combination.
Comment 8 Tor Lillqvist 2016-06-21 15:51:37 UTC
(because such a freeze would be the driver's fault, not LibreOffice's. Even if LibreOffice would call OpenGL APIs with incorrect parameters, the system should not freeze completely.)

Hans-Dieter, are you a "gamer"? Have you tweaked any potentially risky display driver settings to get faster performance from games? Just a thought...
Comment 9 Hans-Dieter.Dreier 2016-06-22 21:31:26 UTC
No, I'm not a gamer. This laptop isn't particularly good at gaming. I haven't changed the graphics card settings from their factory default.
Graphics driver details: Date 15.12.2015, Version 20.9.15.4352.

The laptop also crashed during actual printing. I've disabled OpenCL in LibreOffice's setting, that helped.

Also the graphics driver accasionally crashed with the current firefox version until I disabled graphics acceleration in fiefox's settings.

It seems this driver version really is not very good. Blacklisting it might be a good idea.

P.S.: I just chose "update driver from the internet" in the driver properties dialog and it is downloading a newer version right now. I'm curious whether that version will be better...
Comment 10 Aron Budea 2016-06-22 22:01:26 UTC
The latest driver for your platform seems to be 15.40.25.4463 available here:
https://downloadcenter.intel.com/download/26078/Intel-Graphics-Driver-for-Windows-10-and-Windows-7-8-1-15-40-

Just as an alternative option if LO is still acting up after the previous driver update. I'm not sure why the numbering is so much different (15.40.25.4463 vs 20.9.15.4352), but this is 100% the latest graphics driver from a couple of days ago.
Comment 11 Tor Lillqvist 2016-06-23 10:41:54 UTC
Are you sure you disabled OpenCL? That is not the same as OpenGL. (Yes, confusingly similar names, even if they are used for different things. But sure, they are related in the sense that both are (nowadays) implemented on the GPU.)
Comment 12 Hans-Dieter.Dreier 2016-07-07 18:16:57 UTC
Yes, I disabled OpenCL. The reason was that the system froze / or crashed during actual printing. That went away after disabling OpenCL. Some time after this the meantime I updated the graphics driver (to driver version 20.19.15.4444), but haven't so far re-enabled OpenGL or OpenCL in Libre Office.
Comment 13 Michael Meeks 2016-10-31 21:04:32 UTC
Looks related to what you're working on Tomaz =)
Comment 14 QA Administrators 2017-11-01 22:12:39 UTC Comment hidden (obsolete)
Comment 15 Mike 2017-11-02 10:49:53 UTC
Unable to retest to confirm if bug is still present in latest version of LibreOffice. 
Enabling OpenGL for all rendering, restarting it, and ultimately rebooting the laptop resulted in many menu options disappearing from LibreOffice, mouse clicks were offset by several cm from expected location. 
I have disabled OpenGL rendering once more and everything works, menus, mouse clicks and printing. 
With OpenGL disabled there is no issue.
Comment 16 Buovjaga 2017-11-02 11:06:58 UTC
Mike: I think the developers would still be interested in this (just paste it in a comment):

(In reply to Buovjaga from comment #3)
> Mike, Hans-Dieter: could you copy and paste the contents of your:
> C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log
Comment 17 Mike 2017-11-02 11:23:54 UTC
Contents of opengl_device.log as requested.

DriverVersion: 21.20.16.4664
DriverDate: 4-21-2017
DeviceID: PCI\VEN_8086&DEV_591B&SUBSYS_07BE1028&REV_04
AdapterVendorID: 0x8086
AdapterDeviceID: 0x591b
AdapterSubsysID: 0x07be1028
DeviceKey: System\CurrentControlSet\Control\Video\{BF58BB50-B418-493E-8EA1-B0BF7ABCE5F8}\0000
DeviceString: Intel(R) HD Graphics 630
Comment 18 Julien Nabet 2018-01-29 16:26:29 UTC
The Hans-Dieter's opengl_device.log has the same content as https://bugs.documentfoundation.org/attachment.cgi?id=125151 from tdf#99919

Mike: I submitted a patch to review here:
https://gerrit.libreoffice.org/#/c/48844/
the goal is just to exclude by default your driver version.

Hans-Dieter/Mike: you can try to upgrade your graphic driver and give a try to last stable LO version 5.4.4 + rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows)

*** This bug has been marked as a duplicate of bug 99919 ***
Comment 19 Noel Grandin 2018-02-01 14:31:58 UTC
Mike, does updating your driver to the latest version fix the problem?

https://downloadcenter.intel.com/download/27412/Graphics-Intel-Graphics-Driver-for-Windows-15-60-?product=98909
Comment 20 Commit Notification 2018-02-02 14:15:35 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ecaabbf527f6f6207ce1ca8924708d23e6db45f5

Related tdf#100243: blacklist Intel HD Graphics 630 for non minimal version

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2018-05-18 07:11:02 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=adbb363120ec68eeb342b3472bb6ad5e8a9ac9c8&h=libreoffice-6-0

tdf#117477/tdf#100243: blacklist Intel HD Graphics 630 for Lenovo...

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.