Bug Hunting Session
Bug 117477 - Make new entry to OpenGL blacklist
Summary: Make new entry to OpenGL blacklist
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:6.1.0 target:6.0.5
Keywords:
Depends on:
Blocks: 96546
  Show dependency treegraph
 
Reported: 2018-05-07 13:46 UTC by urs.obernolte
Modified: 2018-05-18 07:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description urs.obernolte 2018-05-07 13:46:35 UTC
Description:
I found an not working OpenGL Card with wrong scaling, how can i report it correctly to get it on the blacklist so that other people dont have that annoying problem.

Steps to Reproduce:
1. Start the program
2. Interface is to big, menu bar is missing
3. Press Alt+F12, navigate to view, deactivate OpenGL
4. Everything is fine after automatic restart

Actual Results:  
Bad UI scaling

Expected Results:
Right UI scaling / automatic deactivation of OpenGL


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.0.3.2 (x64)
Build-ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: CL

If you could point me where to get additional information to get my graphics card blacklisted right, i would prive you with that information. I use a popular business notebook - Lenovo T570, so this should affect other people. 


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
Comment 1 Julien Nabet 2018-05-07 14:10:55 UTC
Thank you for your report.
This page https://wiki.documentfoundation.org/QA/FirstSteps may help you.
It has a paragraph about OpenGL part and a file to retrieve and attach here.
Comment 2 V Stuart Foote 2018-05-07 16:03:48 UTC
Lenovo offers this product with multiple CPU/GPU configurations--i5 7200U w/Intel HD 620, i7 7500U w/nVidia GTX950, i7 6600U w/Intel HD 520

And, issues are compounded by Lenovo's slow delivery of OpenGL driver support for its Intel GPUs. Reference GPU drivers from Intel have often performed well but are not delivered by Lenovo's update/support services.

Before we'd consider black listing the GPU we'd need to know the model T570 and the on board CPU provided GPU, or the discrete GPU--but more significant the GPU driver details you'd tested and found non-functional.
Comment 3 urs.obernolte 2018-05-07 16:41:53 UTC
Ok, i will get the infos tomorrow.
Comment 4 urs.obernolte 2018-05-08 08:19:35 UTC
DriverVersion: 21.20.16.4664
DriverDate: 4-21-2017
DeviceID: PCI\VEN_8086&DEV_5916&SUBSYS_224817AA&REV_02
AdapterVendorID: 0x8086
AdapterDeviceID: 0x5916
AdapterSubsysID: 0x224817aa
DeviceKey: System\CurrentControlSet\Control\Video\{3E6AF098-2710-11E8-BE1D-54EE75F53574}\0000
DeviceString: Intel(R) HD Graphics 620
Comment 5 Julien Nabet 2018-05-08 08:21:23 UTC
Did you check if there was an update available? The version is 1 year old
Comment 6 urs.obernolte 2018-05-08 08:32:47 UTC
It is our corporate version, i cant update myself - several hundred notebooks are in our company on that version. So this is a problem for many people.
Comment 7 Xisco Faulí 2018-05-08 09:56:13 UTC
@Julien, should we add the version anyway ?
Comment 8 Julien Nabet 2018-05-08 10:05:03 UTC
(In reply to Xisco Faulí from comment #7)
> @Julien, should we add the version anyway ?

Yes I think it should be useful. Do you want to take care of it or do you prefer i do it?
Comment 9 Xisco Faulí 2018-05-08 10:12:12 UTC
(In reply to Julien Nabet from comment #8)
> (In reply to Xisco Faulí from comment #7)
> > @Julien, should we add the version anyway ?
> 
> Yes I think it should be useful. Do you want to take care of it or do you
> prefer i do it?

Please, go ahead!
Comment 10 V Stuart Foote 2018-05-08 15:00:55 UTC
(In reply to urs.obernolte from comment #6)
> It is our corporate version, i cant update myself - several hundred
> notebooks are in our company on that version. So this is a problem for many
> people.

Agree we need to blacklist this defunct driver/hardware mix, already in place for the 16.4664 driver against the 0x591b HWID [1].

You might ask your IT folks to file an issue with Lenovo to fix their drivers.

Meanwhile Intel has now restructured its driver notations [2]. Believe the last for the 15.65 notated release was Driver Version 23.20.16.4982 (win64_15.65.5.4982.zip 2018-03-29), the new notations starting at 24.20.100.6000--current is 24.20.100.6025 (2018-04-27) and we'll need to tweak the blacklist code.

[1] https://opengrok.libreoffice.org/xref/core/vcl/opengl/opengl_blacklist_windows.xml#32
[2] https://www.intel.com/content/www/us/en/support/articles/000005654/graphics-drivers.html
Comment 11 Julien Nabet 2018-05-09 05:36:07 UTC
I submitted a patch to review here:
https://gerrit.libreoffice.org/#/c/54015/
Comment 12 Commit Notification 2018-05-09 09:55:53 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7aeff452bfd308d122c319ed5135bd98e90590f8

tdf#117477: blacklist Intel HD Graphics 630 for Lenovo

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Julien Nabet 2018-05-09 09:59:15 UTC
Urs: before backporting the patch, would it be possible you give a try with a master daily build as soon as there’s a build available which includes the patch ?
Comment 14 Julien Nabet 2018-05-14 20:22:27 UTC
Urs: any update? the Win x86-64 build located in https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/ should contain the patch since the modified date of the build is 14/05/2018
Comment 15 urs.obernolte 2018-05-17 16:46:35 UTC
Works for me!
Comment 16 Julien Nabet 2018-05-17 17:12:06 UTC
Thank you Urs for your feedback.

I submitted the patch to review here for 6.0 branch:
https://gerrit.libreoffice.org/#/c/54501/
Comment 17 Commit Notification 2018-05-18 07:10:55 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=adbb363120ec68eeb342b3472bb6ad5e8a9ac9c8&h=libreoffice-6-0

tdf#117477/tdf#100243: blacklist Intel HD Graphics 630 for Lenovo...

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.