Bug 100300 - Crash upon start (LibreOffice recovers, but there's an (empty) Document Recovery dialog ..)
Summary: Crash upon start (LibreOffice recovers, but there's an (empty) Document Recov...
Status: RESOLVED DUPLICATE of bug 102295
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.0.beta2
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, regression
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-06-09 23:23 UTC by Aron Budea
Modified: 2016-09-27 00:18 UTC (History)
6 users (show)

See Also:
Crash report or crash signature: ["ImplImage::~ImplImage()"]


Attachments
WinDbg stacktrace of 5.2.0b2 crash report (16.86 KB, text/plain)
2016-06-10 15:43 UTC, V Stuart Foote
Details
WinDbg stackTrace crash in LO5.2.0b2+ launching Writer (22.99 KB, text/plain)
2016-06-14 22:28 UTC, V Stuart Foote
Details
OpenGL device log Win8.1 Ent with LO5.2.0beta2+ 20160614 build (310 bytes, text/x-log)
2016-06-21 14:00 UTC, V Stuart Foote
Details
OpenGL device log Win10 Pro with LO5.2.0beta2+ 20160614 build (315 bytes, text/x-log)
2016-06-21 14:38 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-06-09 23:23:35 UTC
With the second half of bug 100184 resolved, only the first crash remains. It's a "hidden" crash, LibreOffice recovers, but there's an (empty) Document Recovery dialog, and the crash reporter also activates.

Steps:
-delete user profile
-start Writer

=> possible result 1: Writer starts fine, UI render is default => rinse and repeat from start (this happens very rarely for me, usually on the second try I get the crash)

=> possible result 2: after splash screen, an empty LibreOfficeDev Document Recovery dialog is shown

-press OK
-Crash Report dialog appears, press Send Crash Report ( http://crashreport.libreoffice.org/stats/crash_details/b9ee7997-479b-47fa-8cea-c725dcc28f72 ), then Close
-LibreOfficeDev main application appears, UI render is GL


This one doesn't seem to be directly related to OpenGL, maybe to the sidebar instead. There's no crash if the main application is run, only when Writer/Calc/etc. is started.

However, if there's no crash, UI render is always default, and if there is a crash, it's always GL. So it might still be connected to GL somehow.

OS: Windows 7, x64
LO version: 5.2.0.0.beta2, x86
Comment 1 V Stuart Foote 2016-06-10 13:24:17 UTC
Stuart -> Aron, 

When you are starting Writer, is that from command window swriter.exe--or via a shortcut?  

And for clarity, do you have different behavior if you open soffice.exe from command line or its shortcut?  

Is there a difference in what is launched (without an existing profile), or was it just your STR was with a Writer launch?
Comment 2 Aron Budea 2016-06-10 14:19:35 UTC
I'm generally starting it from Start menu.
However, I tried with 'soffice.exe --writer' just now, and the result was the same (for some reason again the first run was fine, but after I did it again - after deleting the profile both times - I got the crash).

I'm not sure I understand the last question correctly. Does this answer your question? "There's no crash if the main application is run, only when Writer/Calc/etc. is started."
So, I tried with different applications, but if you meant something else, please clarify.
Comment 3 V Stuart Foote 2016-06-10 15:43:34 UTC
Created attachment 125589 [details]
WinDbg stacktrace of 5.2.0b2 crash report

Confirming.

On Windows 10 Pro 64-bit en-US with nVidia GTX-750i GPU
Version: 5.2.0.0.beta2 (x64)
Build ID: ae12e6f168ba39f137fc110174a37c482ce68fa4
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: en-US (en_US)

Using swriter.exe, with install directory on path (sorry for not being clear, was the launch via soffice.exe & StartCenter or direct with swriter.exe) have the issue.

Launching with no profile into simpress.exe, scalc.exe, sdraw.exe--close without fully opening the GUI--and the user profile is partial.

While smath.exe and soffice.exe seem to come up cleanly, and profile has OpenGL enabled. 

If launched from StartCenter, a launch of Writer closes, and on relaunch see the error report dialog, and after that Writer opens with default rendering.

So kind of seems like this is OpenGL test related as well.
Comment 4 Aron Budea 2016-06-10 23:37:50 UTC
Adding regression-related tags, since this was working in 5.1.
Comment 5 Julien Nabet 2016-06-11 07:21:15 UTC
Tomaz: noticing vcl/opengl/texture.cxx in bt, thought you might be interested in this one.
Comment 6 Tomaz Vajngerl 2016-06-11 07:47:46 UTC
Seems like the same problem as with 100184. The whole fix didn't get into LO 5.2 beta2, so please check the LO 5.2 daily build after beta2 (if there is one available).
Comment 7 V Stuart Foote 2016-06-14 22:26:51 UTC
So, with todays beta2+ build on Windows 8.1 Ent 64-bit
Version: 5.2.0.0.beta2+ (x64)
Build ID: 32ecf73b9f26e74f72086bf43a72244c165a391c
CPU Threads: 8; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-2, Time: 2016-06-14_11:55:59
Locale: en-US (en_US)

Still getting crash on initial launch and a truncated registrymodifications.xcu. Attaching WinDbg stack trace of hang launching swriter.exe (Task Manager -> dump soffice.bin process).

If I launch into smath.exe first, I get a full registry .xcu, where I can disable OpenGL rendering. And then get clean launch of other modules.
Comment 8 V Stuart Foote 2016-06-14 22:28:29 UTC
Created attachment 125656 [details]
WinDbg stackTrace crash in LO5.2.0b2+ launching Writer
Comment 9 Tor Lillqvist 2016-06-21 13:01:22 UTC
Could you attach the opengl_device.log produced?
Comment 10 V Stuart Foote 2016-06-21 14:00:09 UTC
Created attachment 125800 [details]
OpenGL device log Win8.1 Ent with LO5.2.0beta2+ 20160614 build

the requested opengl_device.log
Comment 11 V Stuart Foote 2016-06-21 14:38:35 UTC
Created attachment 125801 [details]
OpenGL device log Win10 Pro with LO5.2.0beta2+ 20160614 build

same findings on a Windows 10 Pro 64-bit install, OpenGL log attached.

Restating STR

1. /a administrative install of libreoffice-5-2~2016-06-14_11.55.59_LibreOfficeDev_5.2.0.0.beta2_Win_x64_helppack_en-US.msi and help
2. configure UserInstallation from program/bootstrap.ini to $ORIGIN/../Data/settings
3. navigate to program
4. launch swriter.exe (command line or Explorer)

Expected:
new profile with fully formed registrymodifications.xcu, and a session of Writer open.

Result:
profile is truncated, Writer closes

5. launch swriter.exe again

Expected:
   crash on launch

Result:
Writer opens, about dialog shows OpenGL renderer, profile is more complete including Recovery/RecoveryList and RecoveryInfo, but--*there are no common/VCL UseOpenGL or ForceOpenGL stanzas*-- which seems wrong (or has it been changed to not write the stanzas to registry).

6. disable OpenGL rendering (Tools -> Options -> View)

7. close Writer  --UseOpenGL and ForceOpenGL stanzas set FALSE *are* written to registry--

8. launch Writer, verify rendering is Default

9. enable OpenGL (Tools -> Options -> View)

10. close Writer --the registry UseOpenGL stanza shows TRUE

11. no subsequent crashes.
Comment 12 Aron Budea 2016-07-08 02:48:50 UTC
First impressions with 5.2.0.2.

There's a clear-cut crash now upon first start, or if it's been in GL mode, and hasn't been started in a while (not very exact, but that's how it is). After crash the program has to be started again, and it starts with default rendering. Crash reporter isn't triggered.

This seems to be the same as bug 100487, except that is observed with a dbgutil master build. See my comments there for some observations.
Comment 13 Markus Mohrhard 2016-07-14 16:56:29 UTC
(In reply to Aron Budea from comment #12)
> First impressions with 5.2.0.2.
> 
> There's a clear-cut crash now upon first start, or if it's been in GL mode,
> and hasn't been started in a while (not very exact, but that's how it is).
> After crash the program has to be started again, and it starts with default
> rendering. Crash reporter isn't triggered.
> 
> This seems to be the same as bug 100487, except that is observed with a
> dbgutil master build. See my comments there for some observations.

You mention 5.2.0.2 and master here and it is not obvious which parts are related to master and what is related to the RC.
Comment 14 Aron Budea 2016-07-14 17:06:55 UTC
(In reply to Markus Mohrhard from comment #13)
> You mention 5.2.0.2 and master here and it is not obvious which parts are
> related to master and what is related to the RC.

Sorry, this bug report is entirely for 5.2. The other one (bug 100487) is for master. My hunch is they are at least partially the same issue.
Comment 15 Aron Budea 2016-07-21 02:44:24 UTC
Still occurs in 5.2.0.3.
Comment 16 Cor Nouws 2016-08-18 20:24:04 UTC
Hi Aron,

Can we set this to component LibreOffice?

Ciao  Cor
Comment 17 Aron Budea 2016-08-18 22:29:06 UTC
Sure. Can't remember why I used framework there, must've been a mistake.
Comment 18 fjf.vanleeuwen 2016-09-05 16:53:56 UTC
Two days ago, I had the same experience. sWriter crashes. I've made a new userprofile and the problem is gone. But then I made one change, I pinned the Navigator. And yes, on the next start, LO crashes. I then released the Navigator and the problem is gone.
Comment 19 fjf.vanleeuwen 2016-09-05 16:56:03 UTC
Sorry, I forgot to tell you that I did it with LO 5.2.0.4 on Windows7.
Comment 20 Xisco Faulí 2016-09-13 10:12:18 UTC
I guess this regression can be bibisected now with the latest win repositories. More info: https://wiki.documentfoundation.org/QA/Bibisect/Windows#Versions
Adding keyword 'bibisectRequest'
Comment 21 Xisco Faulí 2016-09-26 20:49:42 UTC
Hi raal, one for you?
Comment 22 Aron Budea 2016-09-27 00:18:47 UTC
No crash in 5.2.2.2 anymore. Not sure if it's completely fixed, but this bug is still very likely a duplicate of bug 102295.

*** This bug has been marked as a duplicate of bug 102295 ***