Bug 100487 - "abort() has been called" upon start in debug build
Summary: "abort() has been called" upon start in debug build
Status: RESOLVED DUPLICATE of bug 102295
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
(earliest affected)
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
Reported: 2016-06-20 04:03 UTC by Aron Budea
Modified: 2016-09-19 22:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

abort() dialog (9.31 KB, image/png)
2016-06-20 04:03 UTC, Aron Budea
assertion failed (16.62 KB, image/png)
2016-07-07 02:16 UTC, Aron Budea
OpenGL device log (317 bytes, text/plain)
2016-09-19 21:56 UTC, Aron Budea

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-06-20 04:03:57 UTC
Created attachment 125738 [details]
abort() dialog

The issue manifests as the attached dialog, from Visual C++ Runtime Library that reads: "abort() has been called".
It pops up during start (of let's say, Writer), stays there for a few seconds, and disappears, then Writer comes up normally (in "UI Render: default", though, otherwise it starts in GL mode).

This does happen rarely, usually after a long time of not starting LibreOffice (maybe for hours), and with empty user profile. My hunch is that this is "possible result 1" from bug 100300, but that's a release build, there's no dialog.

I know this is a bit vague, and difficult to reproduce. I'd look or debug into it further, but have no idea what to look for, and the dialog disappears before I could do anything. Any clues?

Build ID: 909d87cc6187ecffa2704e67ffbe372fd2d90e49
CPU Threads: 4; OS Version: Windows 6.1; UI Render: GL; 
Locale: hu-HU (hu_HU)
Comment 1 Aron Budea 2016-06-20 04:20:17 UTC
I wonder if bug 98365 is related. It's a 32-bit build, and not a crash, but the crash might've become something more graceful since then, and the 32-bitnes doesn't matter much, I think I encountered sporadic first-time crashes with 32-bit builds of as well.
Comment 2 Aron Budea 2016-06-23 04:50:10 UTC
Very first start, crash in MSVCR120.DLL, starts in 'UI Render: default' mode on 2nd try.
Cleared user profile, no crash upon start, starts in 'UI Render: GL' mode.

Could be the same issue...
Comment 3 Aron Budea 2016-07-07 02:11:44 UTC
I managed to debug into it, and if it worked correctly, this is where tha abort() is called:

pSVData->mpApp->Exception( nVCLException );

This is the actual abort() call inside Desktop::Exception(ExceptionCategory nCategory):
Application::Abort( OUString() );
Comment 4 Aron Budea 2016-07-07 02:16:29 UTC
Created attachment 126096 [details]
assertion failed

Currently there's also an assertion failed afterwards:


Build ID: 9fee132c18b658c9ea9fb1114c1fefa56b57532a
Comment 5 Aron Budea 2016-07-07 13:45:49 UTC
Empty profile not needed.
I ran Writer just fine with default rendering, then switched to GL, and upon restart got abort() + assertion failed. Upon next start Writer started with default rendering, switching to GL again worked, there were no further errors.
Comment 6 Aron Budea 2016-09-19 21:56:31 UTC
Created attachment 127441 [details]
OpenGL device log

Attaching device log. CPU/GPU is an AMD 10-7800 APU.
Comment 7 Jan Holesovsky 2016-09-19 22:22:11 UTC
Resolving as a duplicate, seems to be the same thing :-)

*** This bug has been marked as a duplicate of bug 102295 ***