Bug Hunting Session
Bug 102295 - Some OpenGL drivers need more time to start up
Summary: Some OpenGL drivers need more time to start up
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.3 target:5.2.2
Keywords:
: 100300 100487 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-09-19 19:12 UTC by Jan Holesovsky
Modified: 2016-10-31 21:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Holesovsky 2016-09-19 19:12:56 UTC
Turns out that some of the OpenGL drivers need longer time for the 1st start up after a driver update, or when the kernels need to be re-compiled.  This leads to the OpenGL watchdog firing before the initialization completes, causing an unnecessary restart of LibreOffice.

Similarly to the blacklisting, we need to extend the watchdog timeout in the "known good, but taking more time" situations, to fix this issue.
Comment 1 Commit Notification 2016-09-19 21:31:25 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e5c3c69423c0f32bf4bee147936e58ba4d3be181

tdf#102295: relax timeout timings for the GL watchdog

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Jan Holesovsky 2016-09-19 22:19:18 UTC
Bug 100487 is I believe a duplicate of this; though the Windows version there looks like Vista I think (?)
Comment 3 Jan Holesovsky 2016-09-19 22:20:57 UTC
Nope, it's the same thing:

https://msdn.microsoft.com/en-us/library/windows/desktop/ms724832(v=vs.85).aspx

6.1 == Windows 7 :-)
Comment 4 Jan Holesovsky 2016-09-19 22:22:11 UTC
*** Bug 100487 has been marked as a duplicate of this bug. ***
Comment 5 Aron Budea 2016-09-19 22:42:49 UTC
I added a bunch of likely duplicates to see also field.
Comment 6 Commit Notification 2016-09-20 07:43:44 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cd98a0fd6c15069a5e1e5dfccedac13da686083b

tdf#102295: The relaxed values were actually too pessimistic.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-09-20 07:53:22 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=81b9c4e20a1749d143715eb4367be104da7c872f

tdf#102295: AMD actually has two vendor id's.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2016-09-20 09:47:57 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e826f8897170caee4b8a51a8346c71cb767984d

tdf#102295: remove mutex - use atomic for watchdog timings

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-09-20 10:32:20 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=33cce7003da859fa88fd770f98fefeb8717996c2&h=libreoffice-5-2

tdf#102295: relax timeout timings for the GL watchdog

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-09-20 15:27:24 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-2-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=21c806828154449fb002f75a8235482eb8a77272&h=libreoffice-5-2-2

tdf#102295: relax timeout timings for the GL watchdog

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-09-20 16:44:06 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7dfe0da0d9852c1f5bb1b71257e914435f75a44b&h=libreoffice-5-2

tdf#102295: remove mutex - use atomic for watchdog timings

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Aron Budea 2016-09-27 00:18:47 UTC
*** Bug 100300 has been marked as a duplicate of this bug. ***
Comment 13 Michael Meeks 2016-10-31 21:02:07 UTC
I believe this is fixed but un-closed; so closing ...