Download it now!
Bug 100436 - Keyboard <ctrl>+<shift>+0 shortcut for "Default style" does not work
Summary: Keyboard <ctrl>+<shift>+0 shortcut for "Default style" does not work
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-Windows Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2016-06-16 16:48 UTC by am_dxer
Modified: 2017-03-26 19:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screen clips of switch keyboard dialog on Windows 10 (59.37 KB, image/png)
2016-06-17 14:19 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2016-06-16 16:48:23 UTC
Both NVDA and Orca list the default style shortcut as Control+Shift+0. In my testing, this keyboard shortcut does nothing.
Comment 1 V Stuart Foote 2016-06-17 06:17:55 UTC
Confirming the broken shortcut on Windows 10 Pro 64-bit en-US with 
Version: 5.1.4.2 (x64)
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US)

The localized accelerator "p" as assigned to the Styles -> Default _Paragraph correctly functions from the menu. And the Styles -> Default Paragraph button does correctly apply the .uno:StyleApply action.

Verified that Tools -> Customize -> Keyboard: Writer
Shortcut <Ctrl>+<Shift>+0 key is assigned:

Category: Styles -> Paragraph 
Function: Default Style
Keys: Ctrl+Shift+0

However, in a Writer document the <Ctrl>+<Shift>+0 shortcut does not change the style of the active paragraph to the "Default style" as defined for the document. The shortcut does not function from the document canvas, nor as a shortcut when the Styles menu is active and focused. 


Otherwise, the shortcuts assigning Paragraph styles seem correct.

Ctrl+0 - correctly assigns Text Body style
Ctrl+1 - correctly assigns Heading 1 style
Ctrl+2 - correctly assigns Heading 2 style
Ctrl+3 - correctly assigns Heading 3 style
Ctrl+4 - correctly assigns Heading 4 style
Ctrl+5 - correctly assigns Heading 5 style


=-refs-=

http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu#2672

https://help.libreoffice.org/Writer/Shortcut_Keys_for_Writer#Shortcut_Keys_for_LibreOffice_Writer

Note: an error in documentation here that the Ctrl+0 is listed
"Ctrl+0 (zero) 	Apply Default paragraph style"
http://opengrok.libreoffice.org/xref/help/source/text/swriter/04/01020000.xhp#380  reported as bug 10445

https://help.libreoffice.org/Writer/Using_Shortcut_Keys_Writer_Accessibility

https://help.libreoffice.org/Common/Shortcuts_Accessibility
Comment 2 V Stuart Foote 2016-06-17 07:22:30 UTC
Checked <Ctrl>+<Shift>+0 as a shortcut back to
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

So, seems it has never functioned as a valid shortcut, while <Ctrl>+0 - 5 were all intact.

@Jay, with implementation of the Style menu--any thoughts on why the .uno:StyleApply -> Standard Paragraph Style works from menu, but not when assigned as a shortcut?

On the new Styles menu as:
http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu#2672

Versus a half dozen <Ctrl>+<Shift>+0 "shorcuts" defined in http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/Accelerators.xcu


=-correction-=
s/bug 10445/bug 100445/ for documentation in the note to comment#1
Comment 3 Maxim Monastirsky 2016-06-17 07:44:02 UTC
<ctrl>+<shift>+0 works perfectly for me under Fedora 24.
Comment 4 V Stuart Foote 2016-06-17 07:56:57 UTC
@Maxim,

Hmmm, Windows only then? But OP mentioned issue with Orca so was likely on a GNOME DE.

I'll check other Windows OS and some Linux VM to see if this ends up Windows 10 only for me.
Comment 5 V Stuart Foote 2016-06-17 08:13:23 UTC
(In reply to V Stuart Foote from comment #4)
> @Maxim,
> 
> Hmmm, Windows only then? But OP mentioned issue with Orca so was likely on a
> GNOME DE.
> 
> I'll check other Windows OS and some Linux VM to see if this ends up Windows
> 10 only for me.

Just checked on LXDE LUnbutu with 5.0.2.2 installed--the <Ctrl>+<Shift>+0 shortcut works correctly. Also correct on Centos 6.7 with 4.3.0.2.

But on a Windows 7 VM with 5.1.3.2 installed--the <Ctrl>+<Shift>+0 does not work. And had the same result on the Windows 7 VM with 4.4.6.3.

So yes, it looks to be Windows only.
Comment 6 Yousuf Philips (jay) (retired) 2016-06-17 10:54:37 UTC
Shift+Ctrl+0 is preassigned in Vista (and above) to the input method editor (IME) : http://support.microsoft.com/kb/967893

http://stackoverflow.com/questions/1464738/shiftctrl0-key-combination-not-seen-by-application-on-windows-vista

I tested XP and it worked fine there.
Comment 7 am_dxer 2016-06-17 12:34:26 UTC
I can actually confirm that this keyboard shortcut works on my Linux machine with Orca. For some reason, Orca does not report formatting changes  when navigating with the arrow keys unless it is restarted. Basically what occurrs is that when Orca opens, there seems to be some cache created of formatting that is applied to the document. If formatting changes are applied to the document, this cache seems to not be updated until Orca is restarted so it announces outdated formatting info. This originally led me to believe that the formatting was not being applied. Does anyone know if needing to restart orca to have it notice the formatting changes would be a bug that should be reported against LibreOffice or Orca?
Comment 8 V Stuart Foote 2016-06-17 14:18:35 UTC
@Joanmarie, any comment for the OP on the issue with Orca's handling of style shortcuts?

@Jay, thatnks for the hint--on Windows 10 the "Switch Keyboard Layout" is assigned to <Ctrl>+<Shift> and I guess the "0" is for default, or maybe just toggles through any defined.

Windows 10 Control Panel -> Language -> Advanced settings -> Change Language bar hot keys -> Change Key sequence.

Setting to "Not Assigned" releases the <Ctrl>+<Shift>+0 shortcut for program control as in LibreOffice.

Screen clip of the dialog attached.

Since this is under OS control, and can be worked around--resolving NOTABUG

Sorry for the noise!
Comment 9 V Stuart Foote 2016-06-17 14:19:58 UTC
Created attachment 125706 [details]
screen clips of switch keyboard dialog on Windows 10

The dialog can be a ittle hard to find, including a screen clip
Comment 10 Joanmarie Diggs 2016-06-17 14:27:48 UTC
(In reply to V Stuart Foote from comment #8)
> @Joanmarie, any comment for the OP on the issue with Orca's handling of
> style shortcuts?

I'll take a look.
Comment 11 V Stuart Foote 2016-06-17 17:04:00 UTC
To wrap this up. Checked on a Windows 8.1 Ent 64-bit en-US system

The control panel dialog is the same as in Windows 10 as in comment 8 and the attached screen clip, that is navigate to:

Control Panel -> Language -> Advanced settings -> Switching input methods -> Change language bar hot keys and in the Text Services and Input Languages dialog on the "Advanced Key Settings" tab click the "Change Key Sequence" and in that dialog for the "Switch Keyboard Layout" value, reset the radio button selection from "Ctrl + Shift" to "Not Assigned" and OK out of the dialogs.