Bug 100540 - Transition sounds are not embedded, thus missing at presentation
Summary: Transition sounds are not embedded, thus missing at presentation
Status: RESOLVED DUPLICATE of bug 67544
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss
Depends on:
Blocks: 100543
  Show dependency treegraph
 
Reported: 2016-06-22 09:07 UTC by Mike A. Fargo
Modified: 2016-06-30 10:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike A. Fargo 2016-06-22 09:07:19 UTC
I am preparing a major presentation, and repeatedly met this problem.
In the first place, I ascribed it to different branches of LO, as the
computer in the theatre runs LO on Windows as opposed to my private where 
Linux (Ubuntu) is run.

Now, this is how to reproduce:
1. Get yourself some audio samples (mp3 in this case) and store them on your
   local hard disk drive.
2. Prepare some slides using LO Impress 5.0.5. on linux.
3. Select any slide and for sounds click "other sounds".
4. Now chose any locally stored mp3 file.
5. Check the presentation (it will run fine if you have all the codecs at least).
6. Save the presentation ODP to a USB pen drive.
7. Take this pen drive to any other computer and open it with LO 5.

Expected Behaviour: Sounds should play
Experienced Behaviour: Sounds are gone.

I found out, that thus added sounds are not embedded but saved as links.
When I rename the local folder, the sounds won't play either. In this
case, the file/sound names are still displayed. 
When the path is not present at all, without any complaints while opening (!),
the entry reads "No Sound" for slide transition.

(PPT Exports cause at least some corruption warning when being opend with PP).

If possible, the user should be asked if sounds should be embedded (especially for small files < 1MiB).

It should also be transparent, which files are just linked. I suggest to have a view of all media displayed in a tree structure, possibly with toc.

There is already the compression tool that can replace OLE links by static instances. But sound/media is not handled separately, here, I think.

It is really quite frustrating if you designed you own transition sounds and during presentation there is nothing but silence...

The only solution (workaround) that comes into my mind here, is to copy all sounds to the USB pen drive, and re-assign sounds. Apropos: When adding several sounds from the same folder, it would be handy, if the last folder used was set to be the default folder for the next sound.

Thank you for reading,
MF
Comment 1 Mike A. Fargo 2016-06-22 11:14:56 UTC
confirmed for most recent version.

At least, audio file locations seem to be stored with relative paths,
so I could open my presentation on another linux PC with sounds,
when the audio files were added from the usb where the odp
file is located.

Not testet with windows (drive letters instead of mount points).
Comment 2 Samuel Mehrbrodt (CIB) 2016-06-30 10:04:55 UTC

*** This bug has been marked as a duplicate of bug 67544 ***