Bug 100853 - HiDPI: Check marks in Windows menus are drawn pixellated
Summary: HiDPI: Check marks in Windows menus are drawn pixellated
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2016-07-11 16:52 UTC by Roman Kuznetsov
Modified: 2019-07-24 17:51 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Example of bad quality checkboxes in menu LO (55.42 KB, image/png)
2016-07-11 16:52 UTC, Roman Kuznetsov
Details
new_checkbox_for_menu_LO (1.91 KB, application/octet-stream)
2016-07-11 17:04 UTC, Roman Kuznetsov
Details
new-new-checkbox-fjr-menu-LO (2.08 KB, application/octet-stream)
2016-07-11 17:17 UTC, Roman Kuznetsov
Details
LO 6.2.5 on Windows 10 1803 (78.05 KB, image/png)
2019-07-24 17:51 UTC, Damian Hofmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2016-07-11 16:52:34 UTC
Created attachment 126168 [details]
Example of bad quality checkboxes in menu LO

see screenshot in attach. Checkboxes is very bad quality in GUI LO on Windows.

I propose to change the look of these checkboxes to a higher quality. probably only need to replace one image file
Comment 1 Roman Kuznetsov 2016-07-11 17:04:04 UTC
Created attachment 126169 [details]
new_checkbox_for_menu_LO

in attach new checkbox for menu in LO. format of file is .svg
Comment 2 Roman Kuznetsov 2016-07-11 17:17:42 UTC
Created attachment 126170 [details]
new-new-checkbox-fjr-menu-LO

2 example of checkbox is normal size
Comment 3 Adolfo Jayme 2016-07-12 19:45:59 UTC
Those check marks come from the Windows visual style in use (in your case: Aero), not from custom images.
Comment 4 Roman Kuznetsov 2016-07-12 20:00:52 UTC
(In reply to Adolfo Jayme from comment #3)
> Those check marks come from the Windows visual style in use (in your case:
> Aero), not from custom images.

hmm...whether it is possible to replace them with markers supplied LO?
Comment 5 Adolfo Jayme 2016-07-13 00:29:48 UTC
That wouldn’t be a good solution, because you would have to provide images to match each and every OS LibreOffice runs on.
Comment 6 andreas_k 2017-03-10 07:51:45 UTC
I already want to report this bug. Is there any solution?

On Linux there is no problem but I have it on windows 7 and it look really out of place. maybe a windows solution only could help.

In general I'm not really happy with the windows theme (I know it comes from the os maybe that's the reason MS Office has a custom style.
Comment 7 QA Administrators 2018-03-11 03:41:34 UTC Comment hidden (obsolete, spam)
Comment 8 Roman Kuznetsov 2018-03-11 05:41:37 UTC
Still repro in 6.0.2.1
Comment 9 Roman Kuznetsov 2018-05-27 08:04:40 UTC
Still repro in 6.1 beta 1
Comment 10 andreas_k 2018-06-10 18:43:49 UTC
I think it's a windows issue and windows has to solve it.
Comment 11 QA Administrators 2019-06-11 03:01:12 UTC Comment hidden (obsolete)
Comment 12 Damian Hofmann 2019-07-24 17:50:48 UTC
Still looks bad.

Retested with LO 6.2.5 on Windows 10 1803. See attached screenshot.
Comment 13 Damian Hofmann 2019-07-24 17:51:55 UTC
Created attachment 152969 [details]
LO 6.2.5 on Windows 10 1803