Bug 101127 - Crash when clicking/double clicking on the title/text of an empty presentation (a11y)
Summary: Crash when clicking/double clicking on the title/text of an empty presentatio...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.3 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: backportRequest:5.2
Keywords: accessibility, bibisectRequest, haveBacktrace, regression
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2016-07-26 08:12 UTC by Aron Budea
Modified: 2016-09-01 15:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace of crash (14.05 KB, text/plain)
2016-07-26 08:12 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-07-26 08:12:35 UTC
Created attachment 126410 [details]
Backtrace of crash

In LibreOffice 5.2.0.3/Ubuntu 15.10, after having assistive tools enabled (I started Orca), I encounter a crash after the following steps:

1. Start Impress.
2. Click, maybe double click in the title or text area of the empty slide.

Sometimes if I wait a bit, I can click/double click there without a crash, but if I start spamming them clicks as soon as possible, I always get the crash.

No crash in 5.1.4.2, and no crash without Orca enabled.
I came across this when I tried to reproduce bug 101113, but it seems to be a different crash.
Comment 1 Aron Budea 2016-07-26 18:03:50 UTC
Now I can't reproduce the crash... very strange.

I'm getting warnings like this on the console:
** (soffice:2080): WARNING **: Unknown event notification 36
** (soffice:2080): WARNING **: Unknown event notification 36
** (soffice:2080): WARNING **: Exception in get_text_at_offset()
** (soffice:2080): WARNING **: Exception in wrapper_ref_state_set
** (soffice:2080): WARNING **: Exception in wrapper_ref_state_set
** (soffice:2080): WARNING **: Exception in wrapper_ref_state_set
** (soffice:2080): WARNING **: Exception in wrapper_ref_state_set
** (soffice:2080): WARNING **: Exception in wrapper_ref_state_set
** (soffice:2080): WARNING **: Exception in wrapper_ref_state_set
** (soffice:2080): WARNING **: Exception in wrapper_ref_state_set
** (soffice:2080): WARNING **: Exception in getAccessibleName()
** (soffice:2080): WARNING **: Exception in getAccessibleDescription()
** (soffice:2080): WARNING **: Exception in wrapper_ref_state_set
** (soffice:2080): WARNING **: Exception in getAccessibleName()
** (soffice:2080): WARNING **: Exception in getAccessibleDescription()
** (soffice:2080): WARNING **: Exception in wrapper_ref_state_set
** (soffice:2080): WARNING **: Exception in getAccessibleName()
** (soffice:2080): WARNING **: Exception in getAccessibleDescription()

I'd close this as WORKSFORME, but these clues might be worth investigating upon.
Resetting severity to normal for now.
Comment 2 Aron Budea 2016-08-14 06:24:40 UTC
Still reproducible, including with current master build:

Version: 5.3.0.0.alpha0+
Build ID: f8b734a4e2b235c12e86d84c7691e39d05786032
CPU Threads: 1; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-08-13_10:26:01
Locale: en-US (en_US.UTF-8); Calc: group
Comment 3 Xisco Faulí 2016-09-01 11:14:03 UTC
I can't reproduce it with

Version: 5.3.0.0.alpha0+
Build ID: 71f4b596bd2225a1a8df8bedd37725abceb31a66
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: grou

and Orca activated, thus close it as RESOLVED WORKSFORME
Comment 4 Aron Budea 2016-09-01 15:03:08 UTC
While I get no crash in 5.3 daily build (details at the end), my console output is still peppered with exceptions as shown in comment 1, which doesn't seem normal.

Also, I still get the crash with v5.2.1.2.

Adding backportRequest and bibisectRequest tags for now.

Version: 5.3.0.0.alpha0+
Build ID: 4a63c145dcce8411c5707f6b99877cc87a4f6c5d
CPU Threads: 1; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-08-31_19:54:16
Locale: en-US (en_US.UTF-8); Calc: group