Download it now!
Bug 101519 - draw:fit-to-size set by default breaking layout
Summary: draw:fit-to-size set by default breaking layout
Status: RESOLVED DUPLICATE of bug 97630
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-14 12:36 UTC by Dave Gilbert
Modified: 2017-02-23 00:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document created on 5.1.5.2/Fedora (12.84 KB, application/vnd.oasis.opendocument.presentation)
2016-08-14 12:36 UTC, Dave Gilbert
Details
test documented created on 5.1.4/ubuntu (12.74 KB, application/vnd.oasis.opendocument.presentation)
2016-08-14 12:37 UTC, Dave Gilbert
Details
screenshot of the 5.1.5 test file (98.82 KB, image/png)
2016-08-14 12:46 UTC, Dave Gilbert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Gilbert 2016-08-14 12:36:54 UTC
Created attachment 126828 [details]
Test document created on 5.1.5.2/Fedora

I'm seeing lo set draw:fit-to-size="true" on new presentations and that's causing a very broken slide layout.

This happens for me in 5.1.5.2-2 on Fedora but not 5.1.4-0 on Ubuntu

Symptom:
  A long line of text in a presentation is put on a single line with no wrapping; the text is squashed horizontally for the whole slide to make the line fit.

How to reproduce:
  1) Create new presentation
  2) On 1st slide fill in title and front page text
  3) Create a new slide
  4) Fill in a dummy title
  5) Create a line '1st line text' and hit return
  6) Now hit tab and type; 'The length of this line is long enough to cause it to wrap and what we are interested in is what happens after loading.'
  7) Save it
  8) Load it back

Observed behaviour:
  Before saving the text from step 6 is properly wrapped across 3 lines, but after reloading it's all squashed onto one line.

Looking at the XML I see the difference between my 5.1.4/Ubuntu and 5.1.5/Fedora systems is that the Fedora system set the draw:fit-to-size flag to 'true'; if I manually edit the XML back to false it looks fine.
Comment 1 Dave Gilbert 2016-08-14 12:37:29 UTC
Created attachment 126829 [details]
test documented created on 5.1.4/ubuntu
Comment 2 Dave Gilbert 2016-08-14 12:46:34 UTC
Created attachment 126830 [details]
screenshot of the 5.1.5 test file
Comment 3 Caolán McNamara 2016-08-17 11:14:31 UTC
I have 5.1.5.2-2.fc24 but when I save my example that I create from scratch I get draw:fit-to-size="shrink-to-fit" not draw:fit-to-size="true"
Comment 4 Caolán McNamara 2016-08-17 11:23:31 UTC
Any chance you set a non-default template or anything like that ?

Perhaps close libreoffice,
mv ~/.config/libreoffice ~/libreoffice-config-backup
and restart to generate a new config and see does it still behave the same way when creating a new document and reloading it
Comment 5 Regina Henschel 2016-08-18 00:07:12 UTC
Please notice bug 34467 and bug 97630.
Comment 6 Caolán McNamara 2016-08-18 13:17:28 UTC
I'm sure they are related, and bug 93135 is tangential as well, but I'd like to know what setting/configuration of Dave's differs from mine so I can get what he gets.
Comment 7 Dave Gilbert 2016-08-18 14:51:51 UTC
OK, I can confirm if I move the config out of the way it behaves sensibly; so that leaves two questions:
  1) Whatever it is that's set in the config displays differently before and after savings, so you don't notice it's screwed up until you reload it all.
  2) How the heck did it get set? Does it correspond to some UI button somewhere?

The files I have in my libreoffice config directory are as follows; I'd rather not send the lot since I can see it does have some document history in;


[dg@major libreoffice-off]$ find -type f -ls 
   809312    920 -rw-------   1  dg       dg         940585 Aug 18 15:38 ./4/user/registrymodifications.xcu
   787995      8 -rw-r--r--   1  dg       dg           3759 Oct  7  2013 ./4/user/database/evolocal.odb
   788476    416 -rw-r--r--   1  dg       dg         418450 Oct  7  2013 ./4/user/database/biblio/biblio.dbf
   788477    604 -rw-r--r--   1  dg       dg         610825 Oct  7  2013 ./4/user/database/biblio/biblio.dbt
   788478      8 -rw-r--r--   1  dg       dg           2687 Oct  7  2013 ./4/user/database/biblio.odb
   930136      8 -rw-rw-r--   1  dg       dg             75 Nov 28  2013 ./4/user/wordbook/standard.dic
   787975     12 -rw-rw-r--   1  dg       dg          10162 Aug 14 01:23 ./4/user/store/.templdir.cache
   786558      4 -rw-rw-r--   1  dg       dg            135 May 24 23:54 ./4/user/uno_packages/cache/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/backenddb.xml
   786567      4 -rw-rw-r--   1  dg       dg            117 May 24 23:54 ./4/user/uno_packages/cache/registry/com.sun.star.comp.deployment.help.PackageRegistryBackend/backenddb.xml
   789064     12 -rw-rw-r--   1  dg       dg           8089 Aug 18 15:38 ./4/user/uno_packages/cache/log.txt
   788481     16 -rw-r--r--   1  dg       dg          10766 Oct  7  2013 ./4/user/config/html.soc
   788482      8 -rw-r--r--   1  dg       dg           2334 Oct  7  2013 ./4/user/config/libreoffice.soc
   788483     12 -rw-r--r--   1  dg       dg           4972 Oct  7  2013 ./4/user/config/standard.soe
   788321      8 -rw-rw-r--   1  dg       dg             41 Aug 18 15:38 ./4/user/config/fontnameboxmruentries
   788484     12 -rw-r--r--   1  dg       dg           6840 Oct  7  2013 ./4/user/config/modern.sog
   788485      8 -rw-r--r--   1  dg       dg           2171 Oct  7  2013 ./4/user/config/standard.soh
   788486      8 -rw-r--r--   1  dg       dg           2331 Oct  7  2013 ./4/user/config/tango.soc
   788488     12 -rw-r--r--   1  dg       dg           5238 Oct  7  2013 ./4/user/config/hatching.soh
   788933      8 -rw-r--r--   1  dg       dg           2426 Oct  7  2013 ./4/user/config/standard.sod
   789025     20 -rw-r--r--   1  dg       dg          14420 Oct  7  2013 ./4/user/config/web.soc
   789026     12 -rw-r--r--   1  dg       dg           4408 Oct  7  2013 ./4/user/config/gallery.soc
   789030     12 -rw-r--r--   1  dg       dg           4308 Oct  7  2013 ./4/user/config/arrowhd.soe
   789038     16 -rw-r--r--   1  dg       dg           8838 Oct  7  2013 ./4/user/config/standard.sog
   789039      8 -rw-r--r--   1  dg       dg           1708 Oct  7  2013 ./4/user/config/styles.sod
   789041     52 -rw-r--r--   1  dg       dg          48408 Oct  7  2013 ./4/user/config/autotbl.fmt
   789042     12 -rw-r--r--   1  dg       dg           5271 Oct  7  2013 ./4/user/config/palette.soc
   789044    160 -rw-r--r--   1  dg       dg         155895 Oct  7  2013 ./4/user/config/standard.sob
   789045     36 -rw-r--r--   1  dg       dg          30852 Oct  7  2013 ./4/user/config/classic.sog
   789046     20 -rw-r--r--   1  dg       dg          13132 Oct  7  2013 ./4/user/config/cmyk.soc
   787920      8 -rw-rw-r--   1  dg       dg           2351 Aug 14 01:22 ./4/user/config/javasettings_Linux_X86_64.xml
   789047     16 -rw-r--r--   1  dg       dg          10946 Oct  7  2013 ./4/user/config/standard.soc
   789048     36 -rw-r--r--   1  dg       dg          31320 Oct  7  2013 ./4/user/config/scribus.soc
   789050      8 -rw-r--r--   1  dg       dg            567 Oct  7  2013 ./4/user/autotext/mytexts.bau
   789113     52 -rw-rw-r--   1  dg       dg          49003 Aug 14 01:22 ./4/user/psprint/pspfontcache
   789053      8 -rw-rw-r--   1  dg       dg            406 Mar  7  2015 ./4/user/basic/dialog.xlc
   789055      8 -rw-r--r--   1  dg       dg            288 Oct  7  2013 ./4/user/basic/Standard/dialog.xlb
   789056      8 -rw-r--r--   1  dg       dg            349 Oct  7  2013 ./4/user/basic/Standard/script.xlb
   789057      8 -rw-r--r--   1  dg       dg           1124 Oct  7  2013 ./4/user/basic/Standard/Module1.xba
   789058      8 -rw-rw-r--   1  dg       dg            406 Mar  7  2015 ./4/user/basic/script.xlc
   811011      4 -rw-rw-r--   1  dg       dg            367 May  1 15:11 ./4/user/gallery/sg30.sdg
   789060      4 -rw-rw-r--   1  dg       dg            626 May  1 15:11 ./4/user/gallery/sg30.thm
   811012    512 -rw-rw-r--   1  dg       dg         523952 May  1 15:11 ./4/user/gallery/27Sep2004File087.wav
   811010    236 -rw-rw-r--   1  dg       dg         240168 May  1 15:11 ./4/user/gallery/He4QuantumWhistle.wav
   789061      8 -rw-r--r--   1  dg       dg           2048 Aug 14 12:19 ./4/user/gallery/sg30.sdv
   786602      4 -rw-rw-r--   1  dg       dg              1 Aug 14 01:22 ./4/user/extensions/bundled/lastsynchronized
   786593      4 -rw-rw-r--   1  dg       dg            135 May 24 23:54 ./4/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/backenddb.xml
   786597      4 -rw-rw-r--   1  dg       dg            117 May 24 23:54 ./4/user/extensions/bundled/registry/com.sun.star.comp.deployment.help.PackageRegistryBackend/backenddb.xml
   786604      4 -rw-rw-r--   1  dg       dg              1 Aug 14 01:22 ./4/user/extensions/shared/lastsynchronized
   786585      4 -rw-rw-r--   1  dg       dg            135 May 24 23:54 ./4/user/extensions/shared/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/backenddb.xml
   786589      4 -rw-rw-r--   1  dg       dg            117 May 24 23:54 ./4/user/extensions/shared/registry/com.sun.star.comp.deployment.help.PackageRegistryBackend/backenddb.xml
   786520      4 -rw-rw-r--   1  dg       dg             11 May 24 23:54 ./4/user/extensions/buildid
   786598      4 -rw-rw-r--   1  dg       dg            135 May 24 23:54 ./4/user/extensions/tmp/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/backenddb.xml
   786601      4 -rw-rw-r--   1  dg       dg            117 May 24 23:54 ./4/user/extensions/tmp/registry/com.sun.star.comp.deployment.help.PackageRegistryBackend/backenddb.xml
Comment 8 Caolán McNamara 2016-08-19 07:16:27 UTC
Perhaps tools->options->load/save->general->ODF Format Generation: is not set to its default "1.2 Extended (recommended)" ? If that's not it, can you tar up the old config and send it to me privately and I'll figure it out from there.
Comment 9 Dave Gilbert 2016-08-21 01:49:56 UTC
(In reply to Caolán McNamara from comment #8)
> Perhaps tools->options->load/save->general->ODF Format Generation: is not
> set to its default "1.2 Extended (recommended)" ? If that's not it, can you
> tar up the old config and send it to me privately and I'll figure it out
> from there.

OK, that is it - it was set to 1.0/1.1, and putting the old config back in place but flipping that to 1.2 Extended (recommended) makes it behave.
Comment 10 Buovjaga 2016-09-18 18:42:54 UTC
I guess this can be closed as WFM.
Comment 11 Dave Gilbert 2016-09-18 19:53:43 UTC
(In reply to Buovjaga from comment #10)
> I guess this can be closed as WFM.

Well, I guess so - but that does mean that saving/loading older formats is inconsistent/broken.
Comment 12 Buovjaga 2016-09-19 09:39:29 UTC
Sorry for my mistake.
Comment 13 Aron Budea 2017-02-22 23:57:28 UTC

*** This bug has been marked as a duplicate of bug 85062 ***
Comment 14 Aron Budea 2017-02-23 00:03:06 UTC
Actually, bug 97630 is a better candidate.

*** This bug has been marked as a duplicate of bug 97630 ***