Bug 85062 - FILESAVE: Font size of text with "fit to frame" become very large if ODF Version set to 1.0/1.1 or 1.2
Summary: FILESAVE: Font size of text with "fit to frame" become very large if ODF Vers...
Status: RESOLVED DUPLICATE of bug 97630
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: odf
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-15 14:36 UTC by Brad Woosley
Modified: 2017-02-23 00:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Woosley 2014-10-15 14:36:39 UTC
Ubuntu 12.04.05 LTS
Using LibreOffice version in the default repository.

When I save a presentation in Impress using ODF formats 1.0/1.1 or 1.2, when I open the file again, the text on the slides have been enlarged or stretched so that the longest line is as wide as the slide.  I can open the saved file in Microsoft Powerpoint and the text is the correct size.  It works correctly if I save using ODF format 1.2 extended.  

Steps to re-create:
1) Create a blank Impress document
2) Create a Title, Content slide
3) Add a bullet point of short text (ie: "first")
4) Under Tools->Options->Load/Save->General have ODF Version set to 1.0/1.1 or 1.2
5) Save file in odp format
6) Quit Impress
7) Open Impress and open the saved file

Instead of the text being the same size as when the file was saved, it is stretched to fill the slide.
Comment 1 ign_christian 2014-10-16 03:05:18 UTC
Hi Brad, new bug report should have UNCONFIRMED status. Someone else will mark NEW if same problem confirmed.

Not sure why you had ODF Version set to 1.0/1.1 or 1.2, while the default is 1.2 Extended (recommended) ?

You're using an old and unsupported release (3.5 branch). Please try again using latest stable release from Ubuntu PPA:
- 4.3 branch: https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-4-3
- 4.2 branch: https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-4-2

Then please change status back to UNCONFIRMED after posting result
Comment 2 Brad Woosley 2014-10-16 16:19:19 UTC
Sorry, didn't see the UNCONFIRMED option when I submitted the bug.  I'll make sure of that from now on. 


I set the ODF Version to 1.0/1.1 because, from my understanding, that's the only ODF version that is compatable with Microsoft Office.  


I've updated to version 4.2.6.3 and the same issue occurs, if I set the ODF version to 1.0/1.1 and save a presentation, the text becomes stretched when it is opened again.  Same thing happens if I set the format to version 1.2, but does not happen if the format is set to either of the two version 1.2 Extended options.
Comment 3 ign_christian 2014-10-17 02:41:33 UTC
(In reply to Brad Woosley from comment #2)
> Sorry, didn't see the UNCONFIRMED option when I submitted the bug.  I'll
> make sure of that from now on.  
Em..not your fault I think, not all people know about that. The option to verify UNCONFIRMED status can only seen while "Show Advanced Fields" clicked while filing new bug report.

> I set the ODF Version to 1.0/1.1 because, from my understanding, that's the
> only ODF version that is compatable with Microsoft Office.  
Yup..I remember about that with old MSO version. But I don't know with MSO 2013 ?
 
> I've updated to version 4.2.6.3 and the same issue occurs, if I set the ODF
> version to 1.0/1.1 and save a presentation, the text becomes stretched when
> it is opened again.  Same thing happens if I set the format to version 1.2,
> but does not happen if the format is set to either of the two version 1.2
> Extended options.
Confirming with LO 4.3.2.2 portable - Win7 x86. With ODF version 1.0/1.1 and 1.2, the font size become 133,5 pt
Comment 4 Michael Stahl (CIB) 2014-12-09 20:27:16 UTC
have to change the properties of the text frame to check the
"Fit to frame" checkbox.

this commit seems relevant:

commit 6c15b856242127ddca766da700002489ba287e21
Author:     Michael Stahl <mstahl@redhat.com>
AuthorDate: Thu Feb 2 12:44:03 2012 +0100

    fdo#45534: ODF export: fix draw:fit-to-size
    
    In ODF 1.1 and 1.2 this attribute is of type boolean, so only write the
    new values if the extended format is selected.


... is there a better fallback than mapping ALLLINES and AUTOFIT to true?
Comment 5 QA Administrators 2015-12-20 16:06:39 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-01-03 19:46:16 UTC Comment hidden (obsolete)
Comment 7 Aron Budea 2017-02-22 23:57:28 UTC
*** Bug 101519 has been marked as a duplicate of this bug. ***
Comment 8 Aron Budea 2017-02-23 00:08:48 UTC

*** This bug has been marked as a duplicate of bug 97630 ***