Bug Hunting Session
Bug 101535 - After exiting read-only mode, non-Properties decks show Navigator deck
Summary: After exiting read-only mode, non-Properties decks show Navigator deck
Status: RESOLVED DUPLICATE of bug 104229
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, implementationError, regression
Depends on:
Blocks: Sidebar Navigator Read-Only
  Show dependency treegraph
 
Reported: 2016-08-15 08:12 UTC by Maarten
Modified: 2017-10-31 17:52 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the messed up sidebar in LO 5.2.0.4 (253.49 KB, image/jpeg)
2016-08-16 08:52 UTC, Maarten
Details
Please open this file, allow editing and select some cells -> sidebar scrambled (12.29 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-09-06 08:48 UTC, Dirk De Muynck
Details
Simple document to reproduce sidebar scrambled error (10.13 KB, application/vnd.oasis.opendocument.text)
2017-05-12 08:51 UTC, Dirk De Muynck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten 2016-08-15 08:12:48 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Build Identifier: LibreOffice 5.2.0.4

I get a mail with a document in attachment or download a file which is on the internetpage of my university. After opening the file in writer or calc, the side bar looks like a mess. Even if i sasve a .docx or .xlsx file as open documtent file (.odt or .ods), the sidebar layout stays in the same state. Only after closing the file and opening again, the sidebar is diplayed correct. I use windows 10, x64, latest update. The problem with the sidebar excists since LO 5.0. 

Reproducible: Always

Steps to Reproduce:
1. open a mail or download a file form internet
2. file opens correctly. Sidebar layout looks like a mess in writer and calc (see screenshot in attachment)
3. problem keeps happening every time i open file thorugh mail or internet, even if i sent odf-file sto myself or othher person.
4. only by closing file and opening again, sidebar is shown in normal layout
Actual Results:  
see above 

Expected Results:  
after saving and opening file again, sidebar is shown normally

[Information automatically included from LibreOffice]
Locale: nl
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?yes,several times,did not work!
Comment 1 Jean-Baptiste Faure 2016-08-15 16:44:46 UTC
Please attach your screenshot.

What do you mean by "the sidebar looks like a mess" ?

Best regards. JBF
Comment 2 Maarten 2016-08-16 08:52:11 UTC
Created attachment 126853 [details]
Screenshot of the messed up sidebar in LO 5.2.0.4

Hi Jean-Baptiste, 

Thank you for the swift reply! 

I forgot to add the screenshot. Now it is here! 

Regards, 

Maarten
Comment 3 Jean-Baptiste Faure 2016-08-21 17:00:55 UTC
Thank you for the screenshot. Not reproducible for me under Linux.
Set status back to unconfirmed.

Best regards. JBF
Comment 4 Dirk De Muynck 2016-09-06 08:46:32 UTC
You can reproduce it as follows :
- open a lo spreadsheetfile from internet (or for example the one I attached)
- start editing
- select some adjacent cells
Result : sidebar scrambled.

I can reproduce it in LO 5.1.5 on both windows 7 and Ubuntu Linux.
The bug is very annoying since I'm using libreoffice in school for my pupils and with this bug the 5.1 version is unusable.
It does not occur in 4.4.
I adding a screenshot and a calc file you can open in order to reproduce the error
Comment 5 Dirk De Muynck 2016-09-06 08:48:22 UTC
Created attachment 127168 [details]
Please open this file, allow editing and select some cells -> sidebar scrambled
Comment 6 Jean-Baptiste Faure 2016-09-11 07:29:54 UTC
(In reply to Dirk De Muynck from comment #5)
> Created attachment 127168 [details]
> Please open this file, allow editing and select some cells -> sidebar
> scrambled

Ok, I reproduce with LO 5.2.3.0+ when editing a read-only file in Calc.
Setting as NEW.

Best regards. JBF
Comment 7 Dirk De Muynck 2016-10-03 14:35:05 UTC
I did some testing and this bug was introduced in lo 5.1.0.1. All later versions have it. All the previous versions including 5.0.*  do not have this bug.

Because people often open files from the internet, this bug is very annoying.
If you save the file first to the hard disc and open it afterwards, the error does not occur.
Comment 8 Maarten 2016-12-24 10:39:16 UTC
The proplem of the scrambled sidebar is stll there.. also in lo version 5.2.4.2/ Suggestion was to turn on/off Open GL support. This does not solve the problem, sidebar layout keeps gettin scrambled when saving an .docx-file as an .odt-file!
Comment 9 Maarten 2017-02-27 13:54:52 UTC
The sidebar mee still continues, also in %.3, in writer, calc and impress
Comment 10 Yousuf Philips (jay) (retired) 2017-05-10 12:47:54 UTC
(In reply to Jean-Baptiste Faure from comment #6)
> Ok, I reproduce with LO 5.2.3.0+ when editing a read-only file in Calc.
> Setting as NEW.

Can you provide some clear steps as simply opening the file as read-only wont produce attachment 126853 [details], as the properties tab of the sidebar is disabled unless you go into document editing mode, and even with that, i'm unable to repo.

Version: 5.4.0.0.alpha0+
Build ID: 74ccd02eda2d6325a27266fd935aba29b3d75020
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-04-27_23:51:14
Locale: en-US (en_US.UTF-8); Calc: group

@Maarten: Can you reproduce this with 5.2.7 or 5.3.3? And if so, please copy and paste the version information found in the Help > About LibreOffice dialog, similar to the above. Also with the mess, do the controls still function correctly?
Comment 11 Dirk De Muynck 2017-05-12 08:51:24 UTC
Created attachment 133259 [details]
Simple document to reproduce sidebar scrambled error

In order to reproduce the sidebar scrambled error, do the following :

1. Open this file from internet
2. Enable editing
3. In the sidebar click on the styles icon => it will show you the navigator iso styles
4. In the sidebar click on the page styles icon > sidebar scrambled

VERSION INFO :
Versie: 5.3.3.2
Comment 12 Yousuf Philips (jay) (retired) 2017-05-12 11:11:46 UTC
Confirmed that its a regression introduce in 5.1 as its not available in 5.0.6.

Version: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: en-US (en_US.UTF-8)

The workaround is to click the Navigator deck and then the other decks work correctly again.
Comment 13 bureautiquelibre 2017-08-22 09:36:36 UTC
Bug still present in Version 5.4.

Also present in Impress.
Comment 14 V Stuart Foote 2017-08-22 13:02:27 UTC
Confirming, with simple STR of setting OS "read-only" on an ODF document being opened first time to profile. Infobar will show with only Navigator tab "enabled"

Clicking the "Edit document" button will toggle the Inforbar off and enable the other Sidebar tabs--but clicking on any only displays just the "Navigator" deck's content panels. 

The Properties deck may or maynot show on initial toggle, but other Tab buttons display the Navigator deck. 

Advancing down and back through the Tab bar eventually picks up rendering of all the other decks.

suggests the UNO toggle (button click on the InfoBar) into SID_EDITDOC does not seem to fully clear/reset the SID_DOC_READONLY temporary handling on the initial reload.

=-ref-= 

https://opengrok.libreoffice.org/xref/core/sfx2/source/view/viewfrm.cxx?a=true&h=1164#1266

https://opengrok.libreoffice.org/xref/core/sfx2/source/doc/docfile.cxx?a=true&h=3783#3784

On Windows 10 Home 64-bit en-US with
Version: 5.4.1.1 (x64)
Build ID: a5be49f0c45fe24a575c7f41559aa8fc79a781a2
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: group

Version: 6.0.0.0.alpha0+ (x64)
Build ID: ddf0d439d36686008b6de16d59c9a9068622f26c
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-08-19_00:44:50
Locale: en-US (en_US); Calc: CL
Comment 15 Xisco Faulí 2017-10-31 17:52:54 UTC

*** This bug has been marked as a duplicate of bug 104229 ***