Bug 104229 - Sidebar decks bleed into each other after changing read only document to edit mode
Summary: Sidebar decks bleed into each other after changing read only document to edit...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Aron Budea
URL:
Whiteboard: target:6.1.0 target:6.0.0.2 target:5.4.5
Keywords: bibisected, bisected, regression
: 101535 103057 104355 105807 113264 114938 (view as bug list)
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2016-11-28 16:24 UTC by Telesto
Modified: 2018-01-10 19:56 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (25.13 KB, image/png)
2016-11-28 16:26 UTC, Telesto
Details
Screencast (388.50 KB, video/x-msvideo)
2016-12-02 09:59 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-11-28 16:24:37 UTC
Description:
Bleeding of the navigator deck into the formatting deck (or the other way around)

Steps to Reproduce:
1. Delete profile
2. Start LO Calc
3. Goto the sidebar and activate Navigator deck
4. Close LibreOffice
5. Open attachment 129060 [details]
6. Click edit document
7. Select Column A, Row 8537
8. Move the mouse over the properties deck

Actual Results:  
Properties deck is bleeding to the Navigator deck (or the other way around)

Expected Results:
The properties deck should be shown


Reproducible: Always

User Profile Reset: YES

Additional Info:
Version: 5.4.0.0.alpha0+ (x64)
Build ID: 7aa2b5a041df8e71a435cccbc79ee13799ec9138
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-11-24_11:40:27
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-11-28 16:26:15 UTC
Created attachment 129079 [details]
Screenshot
Comment 2 Buovjaga 2016-12-02 09:01:29 UTC
No repro.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 142618ecae472e535c582c0fb357d2a9a76655f1
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-28_00:46:57
Locale: fi-FI (fi_FI); Calc: group
Comment 3 Telesto 2016-12-02 09:59:22 UTC
Created attachment 129233 [details]
Screencast
Comment 4 Buovjaga 2016-12-02 15:49:54 UTC
*** Bug 104355 has been marked as a duplicate of this bug. ***
Comment 5 Buovjaga 2016-12-02 15:51:05 UTC
Confirmed.
Note the need to deal with a read only document.

Version: 5.4.0.0.alpha0+
Build ID: babf6d5e53516e80e8e3f2485796ebfaeb20e9c1
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-02_00:57:58
Locale: fi-FI (fi_FI); Calc: group
Comment 6 Xisco Faulí 2017-10-22 22:21:01 UTC
*** Bug 113264 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2017-10-22 22:25:57 UTC
Reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.10; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

but not in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)
Comment 8 raal 2017-10-23 15:04:52 UTC
This seems to have begun at the below commit.
Adding Cc: to Laurent Godard ; Could you possibly take a look at this one?
Thanks

9ec94ea7b9b294ef4ab1ea91610c6dfca0dc377f is the first bad commit
commit 9ec94ea7b9b294ef4ab1ea91610c6dfca0dc377f
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sun Jul 19 11:36:47 2015 -0700

    source sha:a64999511ae654131d997eec9a3d78478cfc1c75

    author    Laurent Godard <lgodard.libre@laposte.net>    2015-04-30 14:56:14 (GMT)
committer    Tomaž Vajngerl <quikee@gmail.com>    2015-06-22 04:59:07 (GMT)
commit    a64999511ae654131d997eec9a3d78478cfc1c75 (patch)
tree    e2a06cde98747c7f8b1eb409f9c7b1918582c897
parent    d16e154c627ecc0cb21aaf4b28f7f5ae48ebbde1 (diff)
new uno sidebar api tdf#91806
the entry point is SfxBaseController::getSidebar()
Comment 9 Xisco Faulí 2017-10-23 15:23:32 UTC
@Caolán, I thought you might be interested in this bug...
Comment 10 Xisco Faulí 2017-10-31 17:52:54 UTC
*** Bug 101535 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2017-10-31 17:53:16 UTC
*** Bug 103057 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2017-12-20 17:41:50 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f2f5ebcee462472b27b610f53abc7f9a6378462b

tdf#104229: properly switch to def sidebar deck on status change

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2017-12-21 11:04:38 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8bc50d17eb5aaeaaa81255eb5cee6fb60f99c7bc&h=libreoffice-6-0

tdf#104229: properly switch to def sidebar deck on status change

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2017-12-21 11:06:09 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6054c390d136cea5d79b429447e262f61e4a3f19&h=libreoffice-5-4

tdf#104229: properly switch to def sidebar deck on status change

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Aron Budea 2017-12-21 11:43:15 UTC
*** Bug 105807 has been marked as a duplicate of this bug. ***
Comment 16 Aron Budea 2017-12-21 11:46:25 UTC
Let's hope it's fixed now.
Thanks for all the details in the bug report, it was very helpful!
Comment 17 Xisco Faulí 2017-12-28 00:06:39 UTC
Verified in

Version: 6.1.0.0.alpha0+
Build ID: 2bf1cc7372088ec31ac5f0fb60de57feda59d3b7
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 18 Aron Budea 2018-01-10 19:56:23 UTC
*** Bug 114938 has been marked as a duplicate of this bug. ***