Download it now!
Bug 103136 - Elements of frames properties sidebar appear in chart sidebar
Summary: Elements of frames properties sidebar appear in chart sidebar
Status: RESOLVED DUPLICATE of bug 116838
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-11 21:56 UTC by Francisco
Modified: 2018-09-24 06:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (102.23 KB, image/png)
2016-10-11 21:56 UTC, Francisco
Details
elements of cell styles in chart sidebar (153.10 KB, image/png)
2018-09-23 19:22 UTC, Francisco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2016-10-11 21:56:57 UTC
Created attachment 127956 [details]
Screenshot

Steps to reproduce

1) Open Writer and insert a chart. 
1b) Look at the sidebar: it's showing the properties for OLE-objects: Area, Wrap, and Position and size. This is bug 101402.

2) Click on one of the elements of the chart. OLE-objects sidebar is still there. Still, bug 101402. 
2b) Click on another element in the chart. Now, the properties of the chart should appear in the sidebar

3) Move the cursor over the chart sidebar without any click.

Result: the buttons of the OLE-object sidebar appears there.

Expected: no buttons appear while hovering the mouse.

Aditional comments: this happens only with the just inserted chart. Exiting edit mode and entering again.

4) Try to click on any visible chart format item on the sidebar

Result: the item isn't clickeable. This happens always, not only with the just inserted chart.


I have tested this with

Versión: 5.2.2.2
Id. de compilación: 1:5.2.2-0ubuntu1~trusty0
Subprocesos de CPU: 4; Versión de SO: Linux 3.13; Renderizado de IU: predeterminado; 
Configuración regional: en-US (es_AR.UTF-8); Calc: group

and 

Version: 5.3.0.0.alpha0+
Build ID: e2f6c7f0d0cc14f851d7028ff846c5dc658a81c6
CPU Threads: 4; OS Version: Linux 3.13; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-11_00:37:49
Locale: en-US (es_AR.UTF-8); Calc: group

This last in a clean environment.

Possible related to bug 96451, bug 101402, and bug 103057. Yes, this last is from Impress, not Chart. But they look pretty similar: buttons from other deck appears suddenly.

Last, I'm attaching a screenshot.
Comment 1 Buovjaga 2016-10-24 12:33:28 UTC
I only repro 1b, but not 2 and 3.

4 is an issue of its own.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha1+
Build ID: 02e6c1c95993740e0dbea724b3014348c4b6559d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-10-24_04:01:05
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Jean-Baptiste Faure 2017-09-09 15:53:14 UTC
Please, could you test again with current supported LO versions?

I do not reproduce the problems you described with LO 5.4.1 from PPA Ubuntu under Ubuntu 16.04 x86-64.

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

best regards. JBF
Comment 3 QA Administrators 2018-04-04 13:08:23 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2018-05-02 15:51:15 UTC Comment hidden (obsolete)
Comment 5 Francisco 2018-09-23 19:22:35 UTC
Created attachment 145130 [details]
elements of cell styles in chart sidebar

(In reply to Jean-Baptiste Faure from comment #2)
> Please, could you test again with current supported LO versions?
> 
> I do not reproduce the problems you described with LO 5.4.1 from PPA Ubuntu
> under Ubuntu 16.04 x86-64.
> 
> Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
> informations are provided.
> 
> best regards. JBF

Dear Jean-Baptiste,

Sorry for my delay, I read the notification quite a time ago and then completely forgot about to answer.

I'm not able to try those LibreOffice versions because they are not in the current Ubuntu version (18.04).

But I have tried with versions:
> Versión: 6.0.3.2
> Id. de compilación: 1:6.0.3-0ubuntu1
> Subprocs. CPU: 4; SO: Linux 4.15; Repres. IU: predet.; VCL: gtk2; 
> Configuración regional: en-US (es_AR.UTF-8); Calc: group

and 
Versión: 6.1.1.2
Id. de compilación: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
Subprocs. CPU: 4; SO: Linux 4.15; Repres. IU: predet.; VCL: kde4; 
Configuración regional: en-US (es_AR.UTF-8); Calc: group threaded

With this 2 different versions, the Chart Sidebar is *completely unusable*. I cannot click on any of the chart sidebar elements nor edit any part of the chart.

Moreover, when trying to click, the elements of the document sidebar appears, depending on the last deck one was using.

I'm attaching a screenshot.
Comment 6 Jean-Baptiste Faure 2018-09-23 20:49:09 UTC
(In reply to Francisco from comment #5)
> [...]
> With this 2 different versions, the Chart Sidebar is *completely unusable*.
> I cannot click on any of the chart sidebar elements nor edit any part of the
> chart.
> 
> Moreover, when trying to click, the elements of the document sidebar
> appears, depending on the last deck one was using.

Yes it is bug 116838.

Best regards. JBF
Comment 7 Francisco 2018-09-23 20:56:12 UTC
(In reply to Jean-Baptiste Faure from comment #6)
> (In reply to Francisco from comment #5)
> > [...]
> > With this 2 different versions, the Chart Sidebar is *completely unusable*.
> > I cannot click on any of the chart sidebar elements nor edit any part of the
> > chart.
> > 
> > Moreover, when trying to click, the elements of the document sidebar
> > appears, depending on the last deck one was using.
> 
> Yes it is bug 116838.
> 
> Best regards. JBF

Gee, I searched for "chart sidebar" in the bug list and I think I took a too fast view.

It seems that this bug is the same as 116838. Should I mark this a dup?
Comment 8 Buovjaga 2018-09-24 06:59:49 UTC
Ok, let's dupe to it as it is already confirmed.

*** This bug has been marked as a duplicate of bug 116838 ***