Bug 113264 - Sidebar not correctly painted when making the read-only presentation editable
Summary: Sidebar not correctly painted when making the read-only presentation editable
Status: RESOLVED DUPLICATE of bug 104229
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-19 11:14 UTC by Jan-Marek Glogowski
Modified: 2019-06-03 08:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test file demonstrating the bug (from bug 84703) (27.13 KB, application/vnd.oasis.opendocument.presentation)
2017-10-19 11:14 UTC, Jan-Marek Glogowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan-Marek Glogowski 2017-10-19 11:14:10 UTC
Created attachment 137110 [details]
Test file demonstrating the bug (from bug 84703)

1. Download the attached document
2. Make the document read-only (chmod a-w)
3. Open the read-only document => notice the navigator is open
4. Click "Edit document" in the "info bar"
5. Notice the navigator content is painted over the sidebar

Interacting with the "mixed navi-sidebar" shows it actually is the sidebar. Since the navigator is painted with delay, someone probably doesn't check for the navigators "hidden status" when painting.

The sidebar is first painted and the "navigator content" a bit later with a noticeable (small) delay on Linux and Windows.
Comment 1 Xisco Faulí 2017-10-22 22:21:01 UTC
Hi Jan-Marek,
it seems like a dupe of bug 104229

*** This bug has been marked as a duplicate of bug 104229 ***