Bug 101711 - Background image turns to solid blue for all slides after copy/paste
Summary: Background image turns to solid blue for all slides after copy/paste
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.3.0 target:5.1.6 target:5.2.3
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2016-08-24 21:00 UTC by Bill Kristan
Modified: 2016-11-25 13:35 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
An example of a file saved after the image background turned blue. (336.91 KB, application/vnd.oasis.opendocument.presentation)
2016-08-24 21:00 UTC, Bill Kristan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Kristan 2016-08-24 21:00:50 UTC
Created attachment 127011 [details]
An example of a file saved after the image background turned blue.

When I use a slide template with an image as a background, and then copy and paste between two different presentations, the background turns to solid blue on both of the files (both the one I'm copying from, and the one I'm pasting into). If I go into the master slide and try to re-apply the slide design, it too shows as blue. If I save, the slides will be blue the next time I re-open them. If I don't save, the files open with the correct background.

The attached file shows a slide saved after the background image turned blue. If you need a version with the normal slide background I can provide that too.
Comment 1 marioaieie 2016-08-31 10:06:28 UTC
I confirm that the bug affects also my installation (same version 5.1.4.2). The problem can be reproduced in a new document just by copying a slide after having set the background image of the master slide.

It doesn't affect the background defined for an individual slide.
Comment 2 Buovjaga 2016-09-23 19:15:12 UTC
When I tried to repro from scratch, it turned blue in the source document, but not in the target.

Doesn't happen in v. 3.6.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: cd72269a6a2c85ae9dd4552aa4808ef4fd1f6c0e
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 21st 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 3 Caolán McNamara 2016-09-27 19:52:33 UTC
I suspect this is the same problem as fixed (on 5-1 in last 24 hours) as https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-1&id=19c191a0a92b6ae9ca86aa4ee7afb887fd42a209 if someone can double check this in a 5-1 build after that change
Comment 4 darethehair@gmail.com 2016-09-29 20:51:18 UTC
I noticed this strange behavior myself in my current Linux Mint LMDE version of LibreOffice (5.1.0.3), so I tried upgrading to a Jessie backport (5.1.5.2) but this had the same problem.  So I tried the newest version I could find (5.2.2.2) and the problem was there as well.  

Are there some experimental fixed debs that I can try?
Comment 5 Buovjaga 2016-09-30 06:50:45 UTC
(In reply to darethehair@gmail.com from comment #4)
> I noticed this strange behavior myself in my current Linux Mint LMDE version
> of LibreOffice (5.1.0.3), so I tried upgrading to a Jessie backport
> (5.1.5.2) but this had the same problem.  So I tried the newest version I
> could find (5.2.2.2) and the problem was there as well.  
> 
> Are there some experimental fixed debs that I can try?

This 32-bit build is from a date that should surely have it: http://dev-builds.libreoffice.org/daily/libreoffice-5-1/Linux-rpm_deb-x86@71-TDF/current/
https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 6 darethehair@gmail.com 2016-09-30 17:42:50 UTC
(In reply to Buovjaga from comment #5)
> (In reply to darethehair@gmail.com from comment #4)
> > I noticed this strange behavior myself in my current Linux Mint LMDE version
> > of LibreOffice (5.1.0.3), so I tried upgrading to a Jessie backport
> > (5.1.5.2) but this had the same problem.  So I tried the newest version I
> > could find (5.2.2.2) and the problem was there as well.  
> > 
> > Are there some experimental fixed debs that I can try?
> 
> This 32-bit build is from a date that should surely have it:
> http://dev-builds.libreoffice.org/daily/libreoffice-5-1/Linux-rpm_deb-x86@71-
> TDF/current/
> https://wiki.documentfoundation.org/Installing_in_parallel/Linux

Thanks for this!  I started to install these DEBs, but found out that they are i386-based (?) instead of amd64, so I have a whole bunch of missing libraries.  Unless there are some amd64 ones around, I might have to wait for the fix to show up in the official places.  Advice?
Comment 7 darethehair@gmail.com 2016-09-30 18:05:15 UTC
(In reply to darethehair@gmail.com from comment #6)
> (In reply to Buovjaga from comment #5)
> > (In reply to darethehair@gmail.com from comment #4)
> > > I noticed this strange behavior myself in my current Linux Mint LMDE version
> > > of LibreOffice (5.1.0.3), so I tried upgrading to a Jessie backport
> > > (5.1.5.2) but this had the same problem.  So I tried the newest version I
> > > could find (5.2.2.2) and the problem was there as well.  
> > > 
> > > Are there some experimental fixed debs that I can try?
> > 
> > This 32-bit build is from a date that should surely have it:
> > http://dev-builds.libreoffice.org/daily/libreoffice-5-1/Linux-rpm_deb-x86@71-
> > TDF/current/
> > https://wiki.documentfoundation.org/Installing_in_parallel/Linux
> 
> Thanks for this!  I started to install these DEBs, but found out that they
> are i386-based (?) instead of amd64, so I have a whole bunch of missing
> libraries.  Unless there are some amd64 ones around, I might have to wait
> for the fix to show up in the official places.  Advice?

Actually, I added all the extra stuff (sufficiently to start Impress), and unfortunately found that the bug exists in that version as well :(
Comment 8 Buovjaga 2016-09-30 18:17:57 UTC
Yep I can still repro in 5.3

Again, for testers: you have to use the master slide to set the background image and then copy slide in the normal view.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 8e812b87ff7f8c5bf2c6f8858646c55effd2eea3
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 30th 2016
Comment 9 Buovjaga 2016-10-01 10:18:13 UTC
Caolán: see above comments, the problem still exists in all branches.
Comment 10 Commit Notification 2016-10-03 14:48:36 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1c1d9867b0f789b21730faf76c02d2f86fcee43c

Resolves: tdf#101711 problems with attempt to remove unused bg images

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-10-04 11:31:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8127ac5412b0af8ed7985e07ab11b3241a4e659e&h=libreoffice-5-1

Resolves: tdf#101711 revert attempt to drop unused bg images

It will be available in 5.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-10-05 06:49:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0402ba63551b614c9742b198e48232ac87a2b32b&h=libreoffice-5-2

Resolves: tdf#101711 revert attempt to drop unused bg images

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 darethehair@gmail.com 2016-10-05 19:26:05 UTC
Yes, I downloaded and installed "2016-10-05_06.58.49/ 05-Oct-2016 10:01" and a very brief test seems to show that the bug of losing the master slide background image during a 'copy' operation is now *fixed*.  

Thanks for doing this -- I can now return to my standard 'easier' way of editing my Impress presentations! :)

I await for others to confirm my findings...
Comment 14 Caolán McNamara 2016-10-05 19:50:50 UTC
reverted the suspect code for 5-1 and 5-2, so should be back to normal. And trying something a little different for 5-3
Comment 15 Buovjaga 2016-11-25 13:35:35 UTC
Nothing is turning blue anymore anywhere.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: f1eb0bf75296ee9c59241507a1e03f4de770afa1
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 25th 2016