Download it now!
Bug 101733 - Personalization not working
Summary: Personalization not working
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 114685 (view as bug list)
Depends on:
Blocks: Firefox-Themes
  Show dependency treegraph
 
Reported: 2016-08-26 05:21 UTC by Tim Chambers
Modified: 2018-12-19 09:09 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice: Managing Your In-House Personas (370.41 KB, application/vnd.oasis.opendocument.text)
2016-09-01 15:58 UTC, Peter Maunder
Details
Sample personas folder (509.33 KB, application/zip)
2018-09-14 07:02 UTC, Muhammet Kara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Chambers 2016-08-26 05:21:13 UTC
After updating to version 5.2, the previously installed persona remained in place. However, attempting to select "own theme" in Tools - Options - LibreOffice - Personalization is unsuccessful. The select theme does not find any themes.

There is no access to personas already present in the user profile.
Comment 1 Tim Chambers 2016-08-26 05:57:10 UTC
Also, selecting "no theme" works as expected, but it is not possible to return to the previous (or any other) theme.
Comment 2 Peter Maunder 2016-09-01 15:58:54 UTC
Created attachment 127112 [details]
LibreOffice:  Managing Your In-House Personas
Comment 3 Peter Maunder 2016-09-01 16:02:01 UTC
I have attached a file documenting the problem on my previous comment. This provides a bypass and further documentation to the problem. I do not know where to send this so have attached it to the bug. Sorry if it is the wrong place..Peter
Comment 4 Peter Maunder 2017-05-01 16:06:30 UTC
To confirm that the situation is the same with 5.4.
Comment 5 Xisco Faulí 2017-11-04 18:02:45 UTC
Thank you for reporting the bug. To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 6 Peter Maunder 2017-11-05 15:48:41 UTC
Reset the profiles in 5.4  (EN-GB with Linux-Mint Mate) and also LibreOfficedev 6.0 (EN-US). The problem is still there.
Comment 7 jonathon 2017-11-10 01:49:36 UTC
Persona works for me in LibO 5.4.2.2 

Persona does not work for me in LibO 5.4.3.1
Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
CPU threads: 2; OS: Linux 4.7; UI render: default; VCL: gtk2;
Locale: en-ZA (en_US.UTF-8); Calc: group

Unfortunately, Peter Maunder's paper didn't provide a workaround. :(
Comment 8 Tim Chambers 2017-11-10 03:34:57 UTC
In 5.4.2.2 (x64, Windows 10 and on Linux Mint 18.2)the search for firefox themes does not work - no themes are found, even in the "LibreOffice" category. It did for a while. May be related to the firefox changes?
Comment 9 David Melik 2017-11-25 13:33:22 UTC
I have same problem with Libre Office 5.4.3.2 on Slackware64 14.2 up-to-date stable.
Comment 10 Buovjaga 2017-11-26 18:51:49 UTC
Looks like the problem described from comment 7 on is a new one, related to changes in the Mozilla Addons website structure.

However, the status for the original problem should be NEW per the confirmation by Peter.
Comment 11 Buovjaga 2017-12-26 19:18:03 UTC
*** Bug 114685 has been marked as a duplicate of this bug. ***
Comment 12 David Melik 2017-12-26 23:48:14 UTC
>Looks like the problem described from comment 7 on is a new one, related to >changes in the Mozilla Addons website structure.

No! I was commenter referred to by 'on' (the comment after #7) but am replying to the original bug report!  It's not like I'm a Millennial using Thunderbird for Android, Windows Phone, or even any portable PC... my situation was slightly different but will just go to show this is a wider bug than you knew, because the difference is I've mostly used Thunderbird on workstations with Unix or the most Unix-like (oldest surviving) GNU/Linux, and I have the exact same problem as the original bug report (I now see was for Windows.)
Comment 13 Buovjaga 2017-12-27 10:00:31 UTC
(In reply to David Melik from comment #12)
> >Looks like the problem described from comment 7 on is a new one, related to >changes in the Mozilla Addons website structure.
> 
> No! I was commenter referred to by 'on' (the comment after #7) but am

No. See how it worked in 5.4.2 for jonathon, but not in 5.4.2 for Tim? Tim said "it worked for a while".
Comment 14 Martin Srebotnjak 2018-01-22 08:01:04 UTC
I opened a separate bug report for problems finding any theme on Firefox add-on repository:
https://bugs.documentfoundation.org/show_bug.cgi?id=115143
Comment 15 jonathon 2018-02-14 23:58:22 UTC
I'm doubly confused now.

LibreOffice 6.0.1.1 on one of my laptops displays my theme, without me doing anything.
Literally, all I had to do was toss header.png, footer.png, and preview.png into ~/users/gallery/Persona/ .

LibreOffice 6.0.1.1 on my other laptop, will only display a theme from firefox's repository. NO amount of fiddling with exerpt configuration menu, xcus, etc. will persuade it display local persona.

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 2; OS: Linux 4.7; UI render: default; VCL: gtk2; 
Locale: en-ZA (en_US.UTF-8); Calc: group
Both laptops are using the same build #, etc.  

I'm running the same version of the same Linux distro (^1) on both laptops. As far as I can tell, the only difference between the laptops is that one is configured for South Africa, and the other is configured for the United States. (They both should be configured for South Africa.)





^1: I'm using either AntiX or MKLinux with an Xfce desktop.
Comment 16 Tim Chambers 2018-02-15 00:14:26 UTC
I'm finding the same thing is still happening as per jonathon's second computer. I have this on both a windows 10 machine and a linux (mint) machine configured for Australia. Both machines are completely up to date.

AT no stage have I ever been able to access any of the many personalisation folders in the user profile through the LO personalization interface. Whilst it doesn't affect the functionality of the software it gives the appearance of being broken and is very frustrating if you change to a theme which you don't like and want to change back.

6.0.1.1 Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6 on windows 10 and build ID 1:6.0.1~rc1-0ubuntu0.16.04.1~lo1 in Linux Mint 18.3

Both are able to access the firefox themes through the personalisation menu
Comment 17 Buovjaga 2018-02-15 07:31:04 UTC
(In reply to jonathon from comment #15)
> LibreOffice 6.0.1.1 on my other laptop, will only display a theme from
> firefox's repository. NO amount of fiddling with exerpt configuration menu,
> xcus, etc. will persuade it display local persona.

Did you try safe mode or a profile reset with this other laptop? https://wiki.documentfoundation.org/UserProfile
Comment 18 Peter Maunder 2018-02-15 16:05:39 UTC
(In reply to jonathon from comment #15)
> I'm doubly confused now.
> 
> LibreOffice 6.0.1.1 on one of my laptops displays my theme, without me doing
> anything.
> Literally, all I had to do was toss header.png, footer.png, and preview.png
> into ~/users/gallery/Persona/ .
>

Have you placed the Personas into the root ~/users/gallery/Persona/ folder directly? The Personas should be in their specific folder such as ~/users/gallery/Persona/My-Own-Personas. So the entry in the Expert Configuration will contain the folder name, for example My-Own-Personas/header.jpg;My-Own-Personas/footer.jpg;#ff0000;#ff0000

When you download a Firefox Personas each one is placed in a separate folder.

Just a vague thought. In an expert configuration the ; (semi-colon) is critical and not the same in USA and GB keyboards. I assume this is not relevant for US / ZA and AU settings is it?
Comment 19 Muhammet Kara 2018-09-13 16:49:12 UTC
I guess this might get fixed after https://bugs.documentfoundation.org/show_bug.cgi?id=118881

In the meantime, for the curious, how to add/test default themes to LO:

1- Put your theme folders into the 'personas' directory under the shared 'gallery' directory (it was on /usr/lib/libreoffice/share/gallery for my Debian system). (Create the personas directory first if it doesn't exist)
2- Create a file named personas_list.txt inside the personas directory
3- Put persona details in the personas_list.txt file, one persona per line

Sample content of a personas_list.txt file:

Abstract/preview_large.jpg;Abstract/Header2.jpg;Abstract/Footer2.jpg;#ffffff;#000000
Nature/preview_large.jpg;Nature/Arribaengrande.jpg;Nature/abajogrande.jpg;#ffffff;#49a83d
Abstract/preview_large.jpg;Abstract/Header2.jpg;Abstract/Footer2.jpg;#ffffff;#000000
Comment 20 Muhammet Kara 2018-09-14 07:02:35 UTC
Created attachment 144854 [details]
Sample personas folder
Comment 21 Muhammet Kara 2018-09-21 21:44:39 UTC
Should be resolved by https://gerrit.libreoffice.org/#/c/60432/
Comment 22 Jean-Baptiste Faure 2018-12-19 09:09:11 UTC
Verified fixed in LO 6.1.3 from Ubuntu PPA and in LO 6.2.0.0.beta1+ built at home under Ubuntu 18.04 x86-64.

Best regards. JBF