Bug 115143 - LO60rc2: in personalization settings page no personas are found from add-ons site
Summary: LO60rc2: in personalization settings page no personas are found from add-ons ...
Status: RESOLVED DUPLICATE of bug 114731
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.2 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-22 07:58 UTC by Martin Srebotnjak
Modified: 2018-01-22 11:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2018-01-22 07:58:55 UTC
Description:
When trying to set a persona in personalization settings, searching the add-ons Firefox site doesn't return any results, even when the search string is an empty one.

Steps to Reproduce:
1. Open Personalization settings page
2. Press "Choose Theme"

Actual Results:  
No theme is found.

Expected Results:
Many themes should be found.


Reproducible: Always


User Profile Reset: No



Additional Info:
Using "tree" as a search work (like the example in Chapter 2 of Getting Started guide) the search does not return any themes (see Chapter 2 what it should return).


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Martin Srebotnjak 2018-01-22 08:00:15 UTC
There is a general bug report about Personalization not working, but it is very vague; there one comment suggests there might be a problem with a change in Firefox add-ons repository. And similar problem is reported from different OS's.

See: https://bugs.documentfoundation.org/show_bug.cgi?id=101733
Comment 2 Martin Srebotnjak 2018-01-22 08:26:36 UTC
Entering a http address of a theme pops up a message, that the theme currently cannot be opened and the user should try again later.

Here is a sample theme that does not install:
https://addons.mozilla.org/en-US/firefox/addon/snowflake-theme/
Comment 3 Alex Thurgood 2018-01-22 08:55:24 UTC
Possible DUP of bug 114772 ?
Comment 4 Alex Thurgood 2018-01-22 08:56:37 UTC
Or even a DUP of bug 114731
Comment 5 Alex Thurgood 2018-01-22 09:00:09 UTC
Or maybe even bug 101629
Comment 6 Martin Srebotnjak 2018-01-22 09:04:01 UTC
Well, https://bugs.documentfoundation.org/show_bug.cgi?id=114731 was a duplicate of bug #114818 and the #114731 log shows the remaining problem, as described in this bug, is a Mozilla theme/add-on site change/problem.

#114772 reports of the finding theme problem but links it to proxy not working, which might not be the case.

So either close this one or those two, the problem remains - one of UI functions is "dead" for users - themese cannot be found and thus installed at all (the function works only if user already installed a theme before November or December 2017).

So it is a major UI error and maybe fellow Mozilla developers should be asked what changed on their side.
Comment 7 Martin Srebotnjak 2018-01-22 09:04:51 UTC
I do not know if this is relevant at all:
https://www.ghacks.net/2016/11/24/firefox-will-only-support-web-extensions-by-the-end-of-2017/
Comment 8 Xisco Faulí 2018-01-22 11:05:39 UTC
See this comment -> https://bugs.documentfoundation.org/show_bug.cgi?id=114731#c3

*** This bug has been marked as a duplicate of bug 114731 ***