Bug 114818 - Crash when selecting a persona
Summary: Crash when selecting a persona
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.1.0 target:6.0.0.2
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2018-01-03 09:11 UTC by Gabor Kelemen
Modified: 2018-01-08 22:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["D2DWriteTextOutRenderer::operator()(CommonSalLayout const &,SalGraphics &,HDC__ *)","OpenGLContext::AcquireFramebuffer(OpenGLTexture const &)"]


Attachments
Fresh backtrace of the crash (39.40 KB, text/x-log)
2018-01-03 21:21 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-01-03 09:11:08 UTC
On Windows 8.1 when clicking on a button or searching for a string in the persona selector window, nothing happens.

However pasting an exact URL such as 
https://addons.mozilla.org/hu/firefox/addon/colorful-crazy-cats/ 
and clicking the Go button always results in a crash.

Without GL:
http://crashreport.libreoffice.org/stats/crash_details/cda36a8d-b8e7-4a43-8541-100ca0ab38a5

With GL: 
http://crashreport.libreoffice.org/stats/crash_details/03f6535a-314e-48a0-960e-c72481395469

In Safe Mode:
http://crashreport.libreoffice.org/stats/crash_details/5bdb325b-b1da-434a-8f5f-88c9434f786a
Comment 1 m.a.riosv 2018-01-03 10:56:05 UTC
Looks like a dup.

Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 99837 ***
Comment 2 Gabor Kelemen 2018-01-03 21:20:16 UTC
(In reply to m.a.riosv from comment #1)
> Looks like a dup.
> 
> Please if you are not agree, reopen it.
> 

Well, crash-crash, but the crash signature in bug #99837 does not look like the ones here. So let me reopen.
Comment 3 Gabor Kelemen 2018-01-03 21:21:41 UTC
Created attachment 138867 [details]
Fresh backtrace of the crash

Also happens with a ~recent master build:

Version: 6.1.0.0.alpha0+
Build ID: 88f6ffeb9e0c0b942c2b0bc9d60af7bb7a6caaf8
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (hu_HU.UTF-8); Calc: group threaded
Comment 4 Xisco Faulí 2018-01-04 10:21:14 UTC
Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 2bf1cc7372088ec31ac5f0fb60de57feda59d3b7
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

Once I click the 'Go' button, it crashes after 5 seconds...
Comment 5 Xisco Faulí 2018-01-04 10:42:54 UTC
Regression introduced by:

author	Susobhan Ghosh <susobhang70@gmail.com>	2016-05-08 15:33:46 +0530
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2016-05-17 20:51:32 +0000
commit	bdcb496858a7d37e7d24436dcededa8613469df0 (patch)
tree	40c2febcabd683e59275a7f082bba4611cb98599
parent	6c98575877a64ca7afeb98c5d20e27ba47c14485 (diff)
tdf#88502 Added error box to denote connection errors instead of progress bar

Bisected with: bibisect-linux-64-5.2

Adding Cc: to Susobhan Ghosh
Comment 6 Xisco Faulí 2018-01-04 11:47:03 UTC
Submitted a patch to gerrit: https://gerrit.libreoffice.org/#/c/47388/
Comment 7 Gabor Kelemen 2018-01-05 08:07:12 UTC
*** Bug 114772 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2018-01-06 12:41:15 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0ddd15c1134dde249552ebe763c1cd005e8b4591

tdf#114818 hold the mutex before executing the error dialog

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-01-08 18:06:50 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8fb6d980868bc08b1eef4c95bd820131c2b03640&h=libreoffice-6-0

tdf#114818 hold the mutex before executing the error dialog

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.