Bug 101990 - Format → Cells dialog takes a long time to appear
Summary: Format → Cells dialog takes a long time to appear
Status: RESOLVED DUPLICATE of bug 63551
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, perf
Depends on:
Blocks:
 
Reported: 2016-09-08 13:12 UTC by Sam Morris
Modified: 2017-11-09 13:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Morris 2016-09-08 13:12:37 UTC
When I choose Format → Cells, libreoffice freezes for 4 seconds before the dialog appears. Then it stays frozen for another 30 seconds before the dialog gets painted, after which it works normally.

The following backtrace suggests to me that it's taking a long time for LO to create the list of fonts for the dialog.

#0  __memcpy_sse2_unaligned ()
    at ../sysdeps/x86_64/multiarch/memcpy-sse2-unaligned.S:162
#1  0x00007fc92432c43c in rtl_string_newConcat ()
   from /usr/lib/libreoffice/program/libuno_sal.so.3
#2  0x00007fc9272ba498 in psp::PrintFontManager::getFontFile(psp::PrintFontManager::PrintFont*) const () from /usr/lib/libreoffice/program/libmergedlo.so
#3  0x00007fc9272a6773 in CairoTextRender::GetDevFontList(PhysicalFontCollection*) () from /usr/lib/libreoffice/program/libmergedlo.so
#4  0x00007fc9270b3524 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#5  0x00007fc9270b34ad in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#6  0x00007fc9270b34ad in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#7  0x00007fc9270b34ad in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#8  0x00007fc9270b3d19 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#9  0x00007fc9270b3eec in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#10 0x00007fc927028b49 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#11 0x00007fc9272a4f3c in SalGenericDisplay::DispatchInternalEvent() ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#12 0x00007fc910c8751d in ?? ()
   from /usr/lib/libreoffice/program/libvclplug_gtk3lo.so
#13 0x00007fc910c87591 in ?? ()
   from /usr/lib/libreoffice/program/libvclplug_gtk3lo.so
#14 0x00007fc921f3354a in g_main_context_dispatch ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#15 0x00007fc921f33900 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#16 0x00007fc921f339ac in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007fc910c86b43 in ?? ()
   from /usr/lib/libreoffice/program/libvclplug_gtk3lo.so
#18 0x00007fc92720af01 in Application::Yield() ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#19 0x00007fc926f99c95 in Dialog::Execute() ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#20 0x00007fc8dfa15bc2 in ScTabViewShell::ExecuteCellFormatDlg(SfxRequest&, rtl::OString const&) () from /usr/lib/libreoffice/program/../program/libsclo.so
#21 0x00007fc8df95fd51 in ?? ()
   from /usr/lib/libreoffice/program/../program/libsclo.so
#22 0x00007fc926073aec in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#23 0x00007fc92607071c in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#24 0x00007fc9260b562f in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#25 0x00007fc9260b7953 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#26 0x00007fc925ce6573 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#27 0x00007fc926fbb3f7 in Menu::Select() ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#28 0x00007fc9270281bf in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#29 0x00007fc9272a4f3c in SalGenericDisplay::DispatchInternalEvent() ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#30 0x00007fc910c8751d in ?? ()
   from /usr/lib/libreoffice/program/libvclplug_gtk3lo.so
#31 0x00007fc910c87591 in ?? ()
   from /usr/lib/libreoffice/program/libvclplug_gtk3lo.so
#32 0x00007fc921f3354a in g_main_context_dispatch ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007fc921f33900 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007fc921f339ac in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007fc910c86b43 in ?? ()
   from /usr/lib/libreoffice/program/libvclplug_gtk3lo.so
#36 0x00007fc92720af01 in Application::Yield() ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#37 0x00007fc92720d375 in Application::Execute() ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#38 0x00007fc9262ecd7c in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#39 0x00007fc927210c06 in ?? ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#40 0x00007fc927210d02 in SVMain() ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#41 0x00007fc92630e65a in soffice_main ()
   from /usr/lib/libreoffice/program/libmergedlo.so
#42 0x000000000040064b in ?? ()
#43 0x00007fc923f84700 in __libc_start_main (main=0x400640, argc=2, 
    argv=0x7ffd7a9fbef8, init=<optimized out>, fini=<optimized out>, 
    rtld_fini=<optimized out>, stack_end=0x7ffd7a9fbee8)
    at ../csu/libc-start.c:291
#44 0x0000000000400689 in ?? ()

According to fc-list I have 1061 fonts.
Comment 1 Aron Budea 2016-09-12 03:22:17 UTC
Thanks for the bug report and trace.

I remember a very similar bug report from before, but can't find it... Buovjaga, can you recall?
Comment 2 Buovjaga 2016-09-12 19:48:01 UTC

*** This bug has been marked as a duplicate of bug 98132 ***
Comment 3 Xisco Faulí 2017-10-27 10:58:07 UTC

*** This bug has been marked as a duplicate of bug 104312 ***
Comment 4 Kevin Suo 2017-11-09 13:36:42 UTC
This is not a duplicate of bug 104321, but should be a duplicate of bug 63551. Bug 104321 was fixed, but the format dialog delay is still reproducible on master.
See my comments in bug 63551.

*** This bug has been marked as a duplicate of bug 63551 ***