Bug 102200 - [FILEOPEN,FORMATTING,PPTX] text boxes on some slides doubled so content seems blurred
Summary: [FILEOPEN,FORMATTING,PPTX] text boxes on some slides doubled so content seems...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: filter:pptx, implementationError
Depends on:
Blocks: PPTX-Equations
  Show dependency treegraph
Reported: 2016-09-14 20:55 UTC by Chuck
Modified: 2023-01-26 03:23 UTC (History)
0 users

See Also:
Crash report or crash signature:

I did a PDF export from PowerPoint 2013 for comparison purposes. (3.42 MB, application/pdf)
2016-09-14 21:23 UTC, Chuck
The example file (4.24 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2021-01-13 15:03 UTC, NISZ LibreOffice Team

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck 2016-09-14 20:55:54 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build Identifier: 066b007f5ebcc236395c7d282ba488bca6720265

Many slides in PPT and PPTX files don't render correctly in LibreOffice (multiple versions 4.3-5.2).  I've found a good example to pass along, here:
Basically from slide 20 on the majority of them are unreadable due to what appears to be overlapping duplication of text.  It happens in the PDF export as well.  PowerPoint 2013 renders these slides correctly.

Reproducible: Always

Steps to Reproduce:
1.open https://web.archive.org/web/20160721184553/http://www.mmds.org/mmds/v2.1/ch10-graphs1.pptx
2.examine slides 20-22, 25, 29-30
3.note that several similar slides in the document appear fine, like 26-28
Actual Results:  
The aforementioned slides will render horribly.

Expected Results:  
Would like to be able to see the slides more or less as expected :)

I did this on a moderately up to date version of Ubuntu 16.04.  A co-worker tried this on another system (Debian, I think, or an earlier Ubuntu) that had an earlier version of LibreOffice (like 4.3.x I think) and it had very similar issues.

Reset User Profile?No
Comment 1 Chuck 2016-09-14 21:23:03 UTC
Created attachment 127337 [details]
I did a PDF export from PowerPoint 2013 for comparison purposes.
Comment 2 Jean-Baptiste Faure 2016-09-18 06:38:14 UTC
Confirmed with LO under Ubuntu 16.04 x86-64.

I guess there a problem when importing some animation.

Best regards. JBF
Comment 3 Xisco Faulí 2017-09-29 08:49:38 UTC Comment hidden (obsolete)
Comment 4 Chuck 2017-09-29 17:28:08 UTC
I just updated my system (still Ubuntu 16.04) install to using the PPA, and yes this bug still exists (same test case file linked to in my initial report).

And actually, as I click to change between slides, the slide contents appear to swap sometimes???  Yeah, it appears that some of the slides got dragged & dropped as I clicked on them to change between them (the Undo chain says that).  Which is odd, I definitely didn't drag...and as I go through the undo list, it's got a LOT of stuff in there that I didn't do...exiting without saving and reloading to reset things and try again...and sure enough when it reloads there are already "changes" that have been made that can be undone?  And as I simply click on the slide thumbnails, without dragging, they are occasionally rearranging order, claiming to be drag reorded.  Using the keyboard PageUp & PageDown work okay without reordering things though, so I guess that's a temporary workaround for that particular issue. :)

So, I'm thinking this particular PPTX file may be a good test case for a number of bugs still, including this one that I initially reported.

Also, just noticed these messages coming out multiple times at startup:

  X server found. dri2 connection failed! 
  DRM_IOCTL_I915_GEM_APERTURE failed: Invalid argument
  Assuming 131072kB available aperture size.
  May lead to reduced performance or incorrect rendering.
  get chip id failed: -1 [22]
  param: 4, val: 0

There was an OpenCL related message as well, so I went into options and turned all that OpenCL stuff off in Options.  It eliminated those messages appearing when that file is loaded but not the rendering issues.
Comment 5 QA Administrators 2018-09-30 02:49:06 UTC Comment hidden (obsolete)
Comment 6 Chuck 2018-10-01 15:25:01 UTC
Just tried this again w/ the current LibreOffice that comes w/ Ubuntu 18.04 ( and yes, it still is pretty messed up...
Comment 7 Timur 2019-03-29 15:04:01 UTC
Reason is that text boxes on some slides are doubled so content seems blurred. 
If double box is deleted, content seems fine. 
Content preview and doubling started in LO 3.5 so ImplementationError. Repro 6.3+ in Windows so not platform specific.
Comment 8 Timur 2019-12-07 17:24:20 UTC
There's a change, test in 6.5+, so no duplicates but some data missing. 
I hope it's safe to mark as a duplicate.

*** This bug has been marked as a duplicate of bug 105886 ***
Comment 9 Timur 2019-12-07 17:26:56 UTC Comment hidden (obsolete)
Comment 10 Timur 2019-12-07 18:51:20 UTC
Without bibisect, this was changed in bug 117658 and remaining problem is described in bug 129061. 
Could be closed as duplicate, but I won't, now it's connected, let this one stay as a control.
Comment 11 NISZ LibreOffice Team 2021-01-13 15:03:12 UTC
Created attachment 168857 [details]
The example file

Webarchive is slow, let's have this here just in case.
Comment 12 QA Administrators 2023-01-26 03:23:17 UTC
Dear Chuck,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team