Download it now!
Bug 103154 - This .svg file is incorrectly imported in Impress
Summary: This .svg file is incorrectly imported in Impress
Status: RESOLVED DUPLICATE of bug 99115
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:svg, regression
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-10-12 12:57 UTC by Frederic Parrenin
Modified: 2019-09-13 12:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
.svg file to reproduce the problem (572.38 KB, image/svg+xml)
2016-10-12 12:57 UTC, Frederic Parrenin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2016-10-12 12:57:59 UTC
Created attachment 127967 [details]
.svg file to reproduce the problem

Steps to reproduce:
- open Impress
- insert the attached .svg image
=> the image does not correspond to what can viewed in, e.g., inkscape
Note that this figure was produced by Matplotlib
Comment 1 Aron Budea 2016-10-12 13:59:23 UTC
Confirmed with v5.2.2.2 / Windows 7.
It looks bad when inserted in apps like Writer or Impress, but looks okay when opened with Draw.

Looks better in v4.4.0.3 - 5.1.0.3, there only the geographical height levels are missing.
Looks correct in v4.3.0.4 (application is somewhat unstable, though).
Comment 2 Xisco Faulí 2016-10-12 22:28:54 UTC
The reason why its wrongly rendered is because of *{stroke-linecap:butt;stroke-linejoin:round;}.
On the one hand, commit 359f43f8e76c3bd85c3daf35b5a6d925a4c8c64f made everything to look black.
On the other hand, commit e17a730c0076b10678c860ae3285bc8a98282415 made the geographical height levels dissapear which is already reported in 99115
Comment 3 QA Administrators 2017-10-30 08:32:29 UTC Comment hidden (obsolete)
Comment 4 Frederic Parrenin 2017-10-30 08:40:39 UTC
I can still reproduce this issue with LO 5.2.7.2, 5.3.7.2, 5.4.2.2 and 6.0.0.0.alpha0.
Note that the image appears correct in the file chooser preview, but it is not imported correctly.
Comment 5 Roman Kuznetsov 2018-06-20 18:58:19 UTC
still repro in LO 6.1 beta 2
Comment 6 QA Administrators 2019-06-21 02:53:43 UTC Comment hidden (obsolete)
Comment 7 Frederic Parrenin 2019-06-21 08:18:09 UTC
This bug is still present in:

Version: 6.2.4.2
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
Threads CPU : 8; OS : Linux 4.19; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 8 Xisco Faulí 2019-09-13 09:25:54 UTC
I took a look at this issue during the hackest @ Libreoffice Conference in Almeria.
The svg files contains

<style type="text/css">
*{stroke-linecap:butt;stroke-linejoin:round;}
</style>

So https://cgit.freedesktop.org/libreoffice/core/commit/?id=359f43f8e76c3bd85c3daf35b5a6d925a4c8c64f just arose an existing issue ( see bug 100198 )
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 100198 ***
Comment 9 Aron Budea 2019-09-13 12:14:00 UTC

*** This bug has been marked as a duplicate of bug 99115 ***