Download it now!
Bug 99115 - SVG Insert: Styles defined globally (with *) aren't handle correctly
Summary: SVG Insert: Styles defined globally (with *) aren't handle correctly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.4.0 target:6.2.8 target:6.3.4
Keywords: bibisected, bisected, filter:svg, regression
: 100198 103154 108485 116589 118132 125861 (view as bug list)
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-04-06 09:38 UTC by mail
Modified: 2019-10-23 17:39 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
SVG graphic of a stem plot (blue stems, red heads) (74.64 KB, image/svg+xml)
2016-04-06 09:38 UTC, mail
Details
reduced example (600 bytes, image/svg+xml)
2016-05-15 11:22 UTC, Christina Rossmanith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2016-04-06 09:38:05 UTC
Created attachment 124123 [details]
SVG graphic of a stem plot (blue stems, red heads)

The attached SVG stem plot graphic has been created with pythons matplotlib. It should have blue stems and red filled heads. However, when imported in Draw / Impress the heads are displayed filled with black. 

When doing "edit with external tool" ("Mit externem Werkzeug bearbeiten") in Draw / Impress the graphic is displayed in the browser with correct colours.
Comment 1 MM 2016-04-07 22:41:09 UTC
Unconfirmed with v4.3.5.2 under ubuntu 14.04 x64.
Confirmed with v4.4.7.2 under ubuntu 14.04 x64.
Confirmed with v5.1.2.2 under ubuntu 14.04 x64.

Set as regression.
All components are affected, not only draw.
Comment 2 Xisco Faulí 2016-04-08 11:13:52 UTC
Issue introduced by e17a730c0076b10678c860ae3285bc8a98282415
Comment 3 Christina Rossmanith 2016-05-15 11:22:58 UTC
Created attachment 125057 [details]
reduced example

Style (red fill) from <use> element isn't used for rendering. Style from <rect> element (green stroke) is used. Style (fill opacity) from <svg> is used.
Comment 4 Björn Michaelsen 2016-08-24 22:00:30 UTC
Assuming bisected to imply bibisected, thus adding the latter. This is to make queries for "bibisected" not miss out bisected bugs.
Comment 5 Xisco Faulí 2016-08-30 14:55:56 UTC
Adding Armin Le Grand to the loop as this issue was introduced by one of his commits
Comment 6 Xisco Faulí 2016-09-26 15:03:13 UTC
Adding Cc: to Armin Le Grand
Comment 7 Xisco Faulí 2017-06-13 09:03:47 UTC
*** Bug 108485 has been marked as a duplicate of this bug. ***
Comment 8 ymermoud 2017-06-13 09:32:24 UTC
Bug confirmed with 5.3.3.2
Comment 9 Regina Henschel 2017-06-14 11:58:30 UTC
I error looks as if the style attribute of the <use> element is not evaluated.
Comment 10 Xisco Faulí 2018-03-26 20:37:10 UTC
*** Bug 116589 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2018-06-13 01:01:09 UTC
*** Bug 118132 has been marked as a duplicate of this bug. ***
Comment 12 Roman Kuznetsov 2018-06-20 13:40:41 UTC
still repro in 6.1 beta 2
Comment 13 Carlo Ciarrocchi 2019-06-10 08:56:20 UTC
Still reproducible in 6.2.4.

In "<use style=" and "<g style=" using "fill:#[hex value];" or "fill-opacity:[float value];" always results in black solid shapes.

Surprisingly, when style is defined inside a <path> tag both fill and fill-opacity are represented correctly.
Comment 14 Xisco Faulí 2019-06-26 08:17:00 UTC
*** Bug 125861 has been marked as a duplicate of this bug. ***
Comment 15 Xisco Faulí 2019-09-13 10:39:30 UTC
*** Bug 100198 has been marked as a duplicate of this bug. ***
Comment 16 Aron Budea 2019-09-13 12:14:00 UTC
*** Bug 103154 has been marked as a duplicate of this bug. ***
Comment 17 Xisco Faulí 2019-09-16 12:09:39 UTC
Patch in Gerrit: https://gerrit.libreoffice.org/#/c/78997/
Comment 18 Commit Notification 2019-09-16 13:39:14 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4007ced54d611d1397387f7329a47de5efaca32f%5E%21

tdf#99115: add Css selector '*' style only if the element...

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2019-09-25 19:45:56 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/commit/2d9ac03b943d70d94e94319ae903c66ed25dcc9c

tdf#99115: add Css selector '*' style only if the element...

It will be available in 6.2.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2019-10-23 17:39:41 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/5db4db35de77e9f71ef2dd0a7d63db6b993c9182

tdf#99115: add Css selector '*' style only if the element...

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.