Bug 103355 - Notebookbar doesnt disappear during slide show / presentation mode
Summary: Notebookbar doesnt disappear during slide show / presentation mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.5
Keywords:
: 103917 107708 107715 108554 (view as bug list)
Depends on:
Blocks: Notebookbar Slide-Show
  Show dependency treegraph
 
Reported: 2016-10-20 16:42 UTC by Yousuf Philips (jay)
Modified: 2017-07-11 16:29 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2016-10-20 16:42:59 UTC
Steps:
1) Open Impress
2) Switch to notebookbar mode
3) Press F5
4) Notebookbar still present in slide show

Version: 5.3.0.0.alpha0+
Build ID: e64ea98801d20e5024da900a0ac8faaf565f4bf3
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-18_04:29:35
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Aron Budea 2016-10-21 03:50:40 UTC
Confirmed with 2016-10-20_06:56:44 daily build / Windows 7.
Comment 2 Cor Nouws 2016-11-13 21:37:24 UTC
*** Bug 103917 has been marked as a duplicate of this bug. ***
Comment 3 Volga 2016-11-19 15:36:13 UTC
This need to explore how traditional toolbars hide themselves during tbis mode.
Comment 4 Ljiljan 2017-02-01 20:25:39 UTC
Can confirm this bug on Ubuntu 16.04 with LibreOffice 5.3.
Comment 5 fallobst 2017-02-09 15:25:18 UTC
I can confirm this bug on Ubuntu 16.04 with LibreOffice 5.3. too

"Version: 5.3.0.3
Build ID: 1:5.3.0~rc3-0ubuntu1~xenial1.1
CPU Threads: 8; OS Version: Linux 4.4; UI Render: GL; VCL: gtk2; Layout Engine: new;"
Comment 6 Commit Notification 2017-02-19 14:29:30 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f1af784134b17458b4ca24891d27926feabc67e3

tdf#103355 Hide Notebookbar during slide show

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Jordan Maris 2017-02-25 16:15:25 UTC
I can also confirm this issue exists
Comment 8 Szymon Kłos 2017-03-01 17:40:02 UTC
Please verify this again. For me it is fixed on current master.

Version: 5.4.0.0.alpha0+
Build ID: 4d73a7227f4f341aece7ab3376823f70a3e87d71
Comment 9 Yousuf Philips (jay) 2017-03-02 08:49:56 UTC
Verified that it works, but after leaving slide show mode, the libreoffice menu tab no longer works.

Version: 5.4.0.0.alpha0+
Build ID: 472f92421b1b15dc765714a7c657704812859868
CPU threads: 2; OS: Linux 3.19; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-03-01_23:20:29
Locale: en-US (en_US.UTF-8); Calc: group
Comment 10 Szymon Kłos 2017-03-06 20:57:56 UTC
Yes, I can confirm but menu starts working after focusing on the document.

Code pointer (SfxNotebookBar.cxx:353):

IMPL_STATIC_LINK(SfxNotebookBar, OpenNotebookbarPopupMenu, NotebookBar*, pNotebookbar, void)
{
    SfxViewFrame* pViewFrame = SfxViewFrame::Current();
    if (pNotebookbar && pViewFrame)
    {

pViewFrame is nullptr after leaving the slideshow and trying to open menu.

It seems that after closing slideshow the main windows is not completely activated and that is the reason.
Comment 11 Commit Notification 2017-03-16 15:46:59 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c97d78eaa95e9ff0cef7b467ba566af56e3e7c27

tdf#103355 Working menu after closing slideshow

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 V Stuart Foote 2017-05-09 01:13:54 UTC
*** Bug 107708 has been marked as a duplicate of this bug. ***
Comment 13 V Stuart Foote 2017-05-09 14:56:22 UTC
*** Bug 107714 has been marked as a duplicate of this bug. ***
Comment 14 V Stuart Foote 2017-05-09 14:56:30 UTC
*** Bug 107715 has been marked as a duplicate of this bug. ***
Comment 15 Xisco Faulí 2017-06-15 18:04:22 UTC
*** Bug 108554 has been marked as a duplicate of this bug. ***
Comment 16 Xisco Faulí 2017-06-15 18:04:59 UTC
Should it be backported to 5.3 ?
Comment 17 Szymon Kłos 2017-06-16 20:51:53 UTC
As we are receiving duplicate bug reports I will backport this.
Comment 18 Commit Notification 2017-07-11 16:29:00 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4e461f61ac739c6b9ff38c247095ea69b9fb4e21&h=libreoffice-5-3

tdf#103355 Hide Notebookbar during slide show

It will be available in 5.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.