Download it now!
Bug 103767 - Text along Path (old Font Work) is broken for type "rotate"
Summary: Text along Path (old Font Work) is broken for type "rotate"
Status: RESOLVED DUPLICATE of bug 100986
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: VCL-OpenGL HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-11-07 20:50 UTC by Regina Henschel
Modified: 2018-06-11 03:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
examples with text along path from old font work (57.84 KB, application/vnd.oasis.opendocument.graphics)
2016-11-07 20:50 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2016-11-07 20:50:42 UTC
Created attachment 128554 [details]
examples with text along path from old font work

The attached file contains for each type of font work an example, and on its left side a screenshot, how it is rendered in Version: 5.3.0.0.alpha1+
Build ID: 8a796410ec8f440b4163b15b928347c499da7a8f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-20_23:07:21
Locale: de-DE (de_DE); Calc: group

Open attached file in current master. The type "rotate" is broken. It actually renders the same as type "upright". I have used for testing
Version: 5.3.0.0.alpha1+
Build ID: 32bdc5097013e7efd9c85e1b8df697880e66e925
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-04_23:30:30
Locale: de-DE (de_DE); Calc: single
Comment 1 Regina Henschel 2016-11-07 21:21:24 UTC
It seems to be a more general problem. I see a similar problem with rotated labels in a chart. The angle of the base line is correct, but the characters are upright. And the characters in the labels in the vertical ruler are upright too but should be rotated 90° (bug 103741). And rotated text in a Calc table cell shows the same error.
Comment 2 Regina Henschel 2016-11-07 21:26:05 UTC
And text in any shape is affected.
Comment 3 V Stuart Foote 2016-11-08 00:00:02 UTC
confirmed on Widnows 8.1 Pro 64-bit en-US with
Version: 5.3.0.0.alpha1+
Build ID: 63bd9cf4ad268d83677baf99ec509ef67b5de08a
CPU Threads: 8; OS Version: Windows 6.29; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-07_01:55:57
Locale: en-US (en_US); Calc: CL

Adding button for the Fontwork control dialog to the toolbar and selecting text from the arc for the rotate example, the glyphs do orient perpendicular to the base line of the arc.  Glyphs added as a default shadow are rendered seemingly correctly and follow the contour of the arc, but the glyphs for the text string are not rotated, and drift away from their contact with the arc with each successive glyph being clipped further until none of the glyph is visible.

The rotated text follows the arc (with good contact to its shadow and full glyphs) when opened in  Version: 5.3.0.0.alpha0+
Build ID: c2b48a763df113e63e6a27ee05b9a6834e4e49a4
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-10-20_06:56:44
Locale: en-US (en_US); Calc: CL
Comment 4 V Stuart Foote 2016-11-08 00:03:02 UTC
s/glyphs do orient perpendicular/glyphs do not orient perpendicular/
Comment 5 Khaled Hosny 2016-11-08 15:11:51 UTC

*** This bug has been marked as a duplicate of bug 100986 ***
Comment 6 V Stuart Foote 2016-11-16 05:48:01 UTC
Fixed for default rendering only (by reversion to GDI from DirectWrite). OpenGL rendering using DirectWrite remains broken.

On Windows 10 Pro 64-bit (1607) en-US with
Version: 5.3.0.0.alpha1+
Build ID: 84f644eee78106f01486098d446d9163b62927eb
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-15_23:52:44
Locale: en-US (en_US); Calc: CL


=-ref-= 

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d436065bc1c68fc2d90e73253d8c00503c72dfd0
Comment 7 V Stuart Foote 2017-03-09 02:18:12 UTC
Now correct with OpenGL rendering as well.

On Windows 10 Pro 64-bit en-US with
Version: 5.3.2.0.0+
Build ID: a990b46ccc788db45ff4d8f0d47b799782ecb2af
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-3, Time: 2017-03-08_19:18:26
Locale: en-US (en_US); Calc: CL


http://cgit.freedesktop.org/libreoffice/core/commit/?id=4375eefb644d03ab4bafbc091436166a8494dc91&h=libreoffice-5-3

or on master

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a51b7a1c3a7e7cf7b0c733e1dec40288278c1884

Where we've dropped DrirectWrite Direc2D for OpenGL rendering to use GDI calls for scaling and "non-horizontal" glyphs.