Bug 104237 - FILEOPEN: DOCX: Table not imported in Converted1 page style (unable to copy table to next header)
Summary: FILEOPEN: DOCX: Table not imported in Converted1 page style (unable to copy t...
Status: VERIFIED DUPLICATE of bug 112202
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, regression
Depends on: 101665
Blocks: DOC-Tables Writer-Styles-Page-Odd-Even
  Show dependency treegraph
 
Reported: 2016-11-28 20:10 UTC by Xisco Faulí
Modified: 2020-01-07 12:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (37.56 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-11-28 20:10 UTC, Xisco Faulí
Details
bnc519228_odd-breaks.docx: unit test used in the regression commit (14.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-10 09:56 UTC, Justin L
Details
Screenshot of the document in recent 6.5 master (66.05 KB, image/png)
2020-01-02 10:59 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-28 20:10:26 UTC
Created attachment 129094 [details]
sample

Steps:
1. Open attached document

Observed behaviour: Table on top of the document isn't imported
Expected behavour: Table on top of the document should be imported and displayed

Reproduced in

Version: 5.3.0.0.alpha1+
Build ID: 4ebf1ea7cb66fc3e6b94cd38dd233aaead69f3d5
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: old; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-28 20:12:05 UTC
Regression introduced by:

author	Luboš Luňák <l.lunak@collabora.com>	2014-08-17 19:35:48 (GMT)
committer	Luboš Luňák <l.lunak@collabora.com>	2014-08-17 19:39:39 (GMT)
commit	b32881b6723072c8d1a652ea147d12e75766d504 (patch)
tree	f705e8fcb5320201beae7c6bc3031fc81926d54a
parent	eacc9e6bad22525e99e243b3fbb2405a00503bd3 (diff)
fix reading even/odd page breaks from .docx (bnc#519228)

We map Word's even/odd page breaks to Writer's left/right page styles. And we cannot
just set any page style to be left/right, because that could set e.g. the default
page style as such, which would make all normal pages that way. So instead we need
to make a copy of the relevant page style, as the original page style as its follow,
copy all the properties and headers/footers, and use this copy to get the page break.

Adding Cc: to Luboš Luňák
Comment 2 Justin L 2017-03-10 09:56:26 UTC
Created attachment 131792 [details]
bnc519228_odd-breaks.docx: unit test used in the regression commit

The lost paragraph (paragraph 2 on page 1) in this document bibisected to the same commit identified in Comment 1 (https://cgit.freedesktop.org/libreoffice/core/commit/?id=b32881b6723072c8d1a652ea147d12e75766d504).  That is pretty ironic - it is the unit test from that very commit.
Comment 3 Justin L 2017-03-11 06:12:01 UTC
(In reply to Justin L from comment #2)
> The lost paragraph (paragraph 2 on page 1) in this document bibisected to
> the same commit identified in Comment 1
These two problems are unrelated. The problem in the description's "in_ms_word.docx" comes from Writer's inability to copy header tables to a different style. In order to setup even/odd pages, the default's pagestyle was copied/changed to converted1. If you manually change the style back to "default style", then the table will re-appear.

> That is pretty ironic - it is the unit test from that very commit.
This paragraph is bRemoved in DomainMapper since it is considered to be a placeholder. This shouldn't be harmful and necessary under some conditions, so ignore this document for this bug report.
Comment 4 Timur 2018-10-09 10:59:50 UTC
Repro 6.2+. 
If this 2007 DOCX is saved in MSO as DOCX, LO has the same problem with header but it shows SmartArt Organization Chart (still without text) which is another bug.
Comment 5 QA Administrators 2019-10-10 02:39:58 UTC Comment hidden (obsolete)
Comment 6 NISZ LibreOffice Team 2020-01-02 10:59:30 UTC
Created attachment 156898 [details]
Screenshot of the document in recent 6.5 master

The table seems to be imported since:

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 08f13ab85b5c65b5dc8adfa15918fb3e426fcc3c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

https://cgit.freedesktop.org/libreoffice/core/commit/?id=08f13ab85b5c65b5dc8adfa15918fb3e426fcc3c
author		Michael Stahl <Michael.Stahl@cib.de>	2019-12-16 12:58:46 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2019-12-17 10:16:36 +0100

tdf#112202 writerfilter,sw: fix loss of headers
Comment 7 NISZ LibreOffice Team 2020-01-02 11:28:00 UTC

*** This bug has been marked as a duplicate of bug 112202 ***
Comment 8 Xisco Faulí 2020-01-07 12:20:07 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: bf540873f5e258452fed5006f65a403c95e7872a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded