Bug 101665 - FILEOPEN, docx: Table in page header only showing on first page
Summary: FILEOPEN, docx: Table in page header only showing on first page
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 interoper...
Keywords: filter:docx
: 101666 101667 101668 101669 101670 (view as bug list)
Depends on:
Blocks: DOCX-Tables DOCX-Header-Footer 104237
  Show dependency treegraph
 
Reported: 2016-08-22 15:40 UTC by Stanly
Modified: 2019-12-20 10:31 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (27.08 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-08-22 15:40 UTC, Stanly
Details
File in MS Word Viewer (4.28 KB, application/pdf)
2016-11-27 09:47 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stanly 2016-08-22 15:40:11 UTC
Created attachment 126964 [details]
sample

this document only text shows on the second page, while msword shows all
Comment 1 V Stuart Foote 2016-08-22 17:21:54 UTC
*** Bug 101666 has been marked as a duplicate of this bug. ***
Comment 2 V Stuart Foote 2016-08-22 17:22:10 UTC
*** Bug 101667 has been marked as a duplicate of this bug. ***
Comment 3 V Stuart Foote 2016-08-22 17:22:27 UTC
*** Bug 101668 has been marked as a duplicate of this bug. ***
Comment 4 V Stuart Foote 2016-08-22 17:22:35 UTC
*** Bug 101669 has been marked as a duplicate of this bug. ***
Comment 5 V Stuart Foote 2016-08-22 17:25:50 UTC
*** Bug 101670 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2016-08-23 06:20:28 UTC
Reproduced with v5.2.1.1 and v3.6.0.4 / Windows 7 (even buggier in 3.5.0.3, not regression).
Comment 7 Cor Nouws 2016-08-25 12:53:26 UTC
Page break sets page style for the 2nd page to 'Converted 1'. which causes the issue.
The setting for header/footer: checked 'same content on first page' is OK.

Version: 5.3.0.0.alpha0+
Build ID: d5fab973d0af95c433c5f6a9492014f7db642489
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-08-24_00:37:02
Locale: nl-NL (nl_NL.UTF-8); Calc: group

@justin: something of your interest?
Comment 8 Justin L 2016-08-27 08:28:09 UTC
Too difficult for me - requires good understanding of unotext and may require writing a different function than SwXText::copyText() to copy the header between styles.
The first thing to accomplish is to keep the header's table while round-tripping.  Currently the table is lost, which means it never really is saved in the style properties.  Thus, it isn't being copied into a subsequent page styles either.
Comment 9 Telesto 2016-11-27 09:47:28 UTC
Created attachment 129047 [details]
File in MS Word Viewer
Comment 10 QA Administrators 2018-03-12 03:35:46 UTC Comment hidden (obsolete, spam)
Comment 11 Xisco Faulí 2019-11-29 12:53:15 UTC
Changing priority to 'high' since the number of duplicates is 5 or higher
Comment 12 NISZ LibreOffice Team 2019-12-16 09:07:30 UTC
(In reply to Xisco Faulí from comment #11)
> Changing priority to 'high' since the number of duplicates is 5 or higher

The root cause of this bug is the Word HF option called "Link to Previous", which is set in this bugdoc, but since Writer does not have a similar feature, we don't handle it at all.

Also this option is behind bug #57155 and bug #124524 (ours is explicitly about the option lacking).
Comment 13 Samuel Mehrbrodt (CIB) 2019-12-19 17:08:03 UTC
This looks correct in

Version: 6.5.0.0.alpha0+
Build ID: 6015634de5ada0f9dda9bb4354b2939d8f015a27
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded
Comment 14 Aron Budea 2019-12-19 19:09:41 UTC
The following is the fixing commit, thanks Michael!

https://cgit.freedesktop.org/libreoffice/core/commit/?id=08f13ab85b5c65b5dc8adfa15918fb3e426fcc3c
author		Michael Stahl <Michael.Stahl@cib.de>	2019-12-16 12:58:46 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2019-12-17 10:16:36 +0100

tdf#112202 writerfilter,sw: fix loss of headers

Backport to 6.4 was:
https://git.libreoffice.org/core/commit/eeb0630b81866edc166f5ee83392b3f885fddc70
Comment 15 Xisco Faulí 2019-12-20 10:31:25 UTC
Setting to VERIFIED

Version: 6.5.0.0.alpha0+
Build ID: dee81fb2e1df5091702b3c8b0e4a3f2b58e89291
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded