Bug 112202 - FILEOPEN: DOCX thesis template with empty header
Summary: FILEOPEN: DOCX thesis template with empty header
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.5.0 target:6.4.0.1
Keywords: filter:docx
: 81426 104237 124524 (view as bug list)
Depends on:
Blocks: DOCX-Header-Footer DOCX-Section
  Show dependency treegraph
 
Reported: 2017-09-04 05:30 UTC by Mike
Modified: 2020-03-19 14:48 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (123.18 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-09-04 05:31 UTC, Mike
Details
compared (216.20 KB, application/vnd.oasis.opendocument.graphics)
2017-09-04 05:31 UTC, Mike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2017-09-04 05:30:21 UTC
Description:
Writer shows two empty boxes as header. Correct would be "Titel des studentischen Arbeit". Writer starts showing the header on page 2 of the document, correct would be page 5.

Steps to Reproduce:
1. Open file


Actual Results:  
see description

Expected Results:
see description


Reproducible: Always

User Profile Reset: No

Additional Info:
I reported this bug in report 112172 with 3 other issues.
here https://bugs.documentfoundation.org/show_bug.cgi?id=112172
Xisco Fauli asked me to post the issues seperatly.

The template is here:
https://tu-dresden.de/ing/maschinenwesen/iet/ressourcen/dateien/kwt/beleg/090716_Studentische_Arbeit_VWS.docx?lang=de


Version: 6.0.0.0.alpha0+ (x64)
Build ID: 9600f5179795380749aa5a7c9fa0bf5387d2b95f
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-08-28_00:30:18
Locale: de-DE (de_DE); Calc: group



User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36
Comment 1 Mike 2017-09-04 05:31:06 UTC
Created attachment 135994 [details]
test case
Comment 2 Mike 2017-09-04 05:31:55 UTC
Created attachment 135995 [details]
compared
Comment 3 Buovjaga 2017-09-10 17:29:56 UTC
Let's set to NEW as krishna reproduced in the other report.
Comment 4 QA Administrators 2018-09-11 02:37:32 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2018-09-11 10:10:28 UTC
"test case" is very terrible and curve document...

bug still repro in 6.1.1.1 on Windows 7
Comment 6 QA Administrators 2019-09-12 02:51:26 UTC Comment hidden (obsolete, spam)
Comment 7 Samuel Mehrbrodt (CIB) 2019-10-07 12:55:08 UTC
Still reproducible on current master ( 2eb60e4b4fc45d904e04fd52d485923948c96898 ).

Although in Word 2013 the header starts already on page 4, not on page 5 as described in comment 0.
Comment 8 Michael Stahl (CIB) 2019-12-17 09:16:48 UTC
fixed the wrong headers on page 4, 5 until the end.

headers on page 2 and 3 are still wrong, the header for page 2 shows up on page 3 - there is already bug 112201 about the headers on page 2.

this can be set to fixed.
Comment 9 Commit Notification 2019-12-17 09:17:40 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/08f13ab85b5c65b5dc8adfa15918fb3e426fcc3c

tdf#112202 writerfilter,sw: fix loss of headers

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-12-17 11:02:28 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/eeb0630b81866edc166f5ee83392b3f885fddc70

tdf#112202 writerfilter,sw: fix loss of headers

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-12-17 16:59:24 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/91b2644f3955defc82279beff12d34c9133f57a2

tdf#112202,tdf#112201 sw: add test

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-12-18 08:44:45 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/afd7dbe634fc6a0d4b2d4860edda205a9b4ef4c7

tdf#112202,tdf#112201 sw: add test

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 NISZ LibreOffice Team 2020-01-02 11:07:28 UTC
*** Bug 124524 has been marked as a duplicate of this bug. ***
Comment 14 NISZ LibreOffice Team 2020-01-02 11:28:00 UTC
*** Bug 104237 has been marked as a duplicate of this bug. ***
Comment 15 Timur 2020-03-19 11:33:56 UTC
*** Bug 81426 has been marked as a duplicate of this bug. ***