Bug 104884 - When View-Sidebar is on, after Print Preview is shown and closed, key F11 has no effect
Summary: When View-Sidebar is on, after Print Preview is shown and closed, key F11 has...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.5.1 rc
Hardware: All All
: low minor
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.2.6 target:5.3.1
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-23 13:40 UTC by Zineta
Modified: 2017-02-06 11:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zineta 2016-12-23 13:40:49 UTC
In Calc document press F11 Sidebar Deck is open,click to expand Styles everything is as expected. Close Sidebar Deck , go to Print Preview, close and press F11: nothing happened.Open Sidebar Deck clicking on button Sidebar Settings,
choose Properties, then click Styles - result  LO crashes.Try in Writer too.
Comment 1 Zineta 2016-12-23 13:48:31 UTC
OS: Windows 7
LO 5.2.3, LO 5.2.4, 5.3.0
Comment 2 Xisco Faulí 2016-12-23 15:55:16 UTC Comment hidden (obsolete)
Comment 3 Timur 2016-12-23 16:32:52 UTC
There are 2 issues here: 
1. when View-Sidebar is on (regardless if previously expanded or shown as deck), after Print Preview is shown and closed (menu or toolbar), Styles and Formatting doesn't react (via F11 or menu View-Styles and Formatting) unless mouse is used or View-Sidebar clicked - reproduced with 5.4+
2. crash that I was not able to reproduce so far
Comment 4 Zineta 2016-12-27 13:49:12 UTC

  (In reply to Xisco Faulí from comment #2)
> I can't reproduce it in
> 
> Version: 5.4.0.0.alpha0+
> Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
> CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2016-12-18_06:57:59
> Locale: es-ES (es_ES); Calc: group
> 
> Do you have any specific file opened when the crash happens?
> 
> Could you please try to reproduce it with a master build from
> http://dev-builds.libreoffice.org/daily/master/ ?
> You can install it alongsidethe standard version.
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the bug is still present in the master build

With master build crash  is not reproducible any  more, in earlier versions
 crash report http://crashreport.libreoffice.org/stats/crash_details/5f27ecd8-805a-4e20-8f0a-03016a805f7b
Key F11 - Styles and Formatting doesn't react after Print Preview  - this problem still exist.
Comment 5 Timur 2016-12-27 14:19:48 UTC
In 5.1 we get crash immediately (with View-Sidebar is on) when Print Preview shown and closed is followed with F11.
 
In 5.1.5 it was changed, no crash, but F11 doesn't change Styles and Formatting. That's what bug is about. As written in Comment 3, this is reproduced up to master.
I checked https://wiki.documentfoundation.org/Releases/5.1.5/RC1 but I couldn't identify the bug. Caolan worked on some sidebar issues there so I cc him.

I also reproduced the crash when previous is followed with a click on Sidebar Settings, Properties, Styles with 5.2, but as written in Comment 4 it's not reproducible with 5.3 beta 2 or master anymore.
Comment 6 Aron Budea 2017-01-05 07:40:58 UTC Comment hidden (bibisection)
Comment 7 Aron Budea 2017-01-05 07:43:55 UTC
The crash is resolved by the following commit:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5768416761756a386cba54314f783cb9c0d0d093
author	Caolán McNamara <caolanm@redhat.com>	2016-12-09 11:09:21 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2016-12-09 11:14:53 (GMT)

"Related: rhbz#1397939 crash with null pSidebarController"

Commit has been cherry-picked into 5.2 branch:
https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-2&id=3e60ccb74ac6589e14a479c6646c63a4e5ac4e35

It's not in 5.2.4 branch, though (branch-off: 2016-11-29).
=> crash should be gone in 5.2.5.
Comment 8 Caolán McNamara 2017-01-31 13:26:23 UTC
when we go to print preview mode we change the controller of the frame and on return we change it again, but the sidebar foo remains listening to the original controller. Currently it doesn't even have  way to know this happened because framework/source/services/ContextChangeEventMultiplexer.cxx::disposing won't tell it that the original controller is gone, see "Should we notify the remaining listeners"
Comment 9 Commit Notification 2017-01-31 16:39:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e27ba70ce212642026874ba73021930a06cdbbd

Resolves: tdf#104884 print preview replaces the frame controller

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2017-01-31 20:34:23 UTC
fixed in master now, backport for 5-3 and 5-2 in gerrit
Comment 11 Commit Notification 2017-02-01 14:42:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fe85d526323ef562504289c2a0d76a1af94e7a82&h=libreoffice-5-2

Resolves: tdf#104884 print preview replaces the frame controller

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2017-02-01 19:34:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f031721d7b281ef11c93da78d68f7899816094c&h=libreoffice-5-3

Resolves: tdf#104884 print preview replaces the frame controller

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Zineta 2017-02-06 11:20:00 UTC
It's all resolved now,no more crashes and  F11 active after PP.
Thank You. 

Version: 5.4.0.0.alpha0+
Build ID: a296a69c984b17cfbcd249cf6bdc191d08dff2a6
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_00:00:55
Locale: bs-BA (bs_BA); Calc: group