Bug Hunting Session
Bug 102045 - Crash in: sfx2::sidebar::Panel::SetExpanded(bool)
Summary: Crash in: sfx2::sidebar::Panel::SetExpanded(bool)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: All All
: high critical
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords: dataLoss
: 104535 105092 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-10 14:18 UTC by edward.guitaro
Modified: 2017-01-05 07:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["sfx2::sidebar::Panel::SetExpanded(bool)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description edward.guitaro 2016-09-10 14:18:54 UTC
This bug was filed from the crash reporting server and is br-a0087201-b35f-4cec-8728-07a9a9f09041.
=========================================
When using LibreOffice Writer, I clicked on the "More Options" icon button in the "Paragraph" section of the "Properties" section of the sidebar pane on the right side of the main window and the LibreOffice application just crashed instantly. See the relevant crash report with the above ID for more information.
Comment 1 edward.guitaro 2016-09-10 14:20:30 UTC
For quick access, here is the crash report U.R.L.: http://crashreport.libreoffice.org/stats/crash_details/a0087201-b35f-4cec-8728-07a9a9f09041.
Comment 2 V Stuart Foote 2016-09-10 14:42:17 UTC
Can not reproduce on Windows 10 Pro 64-bit en-US with
Version: 5.2.1.2 (x64)
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US); Calc: group


For the document you were working on--anything special about the Paragraph you were modifying?
Comment 3 edward.guitaro 2016-09-10 18:50:29 UTC
I don't think there was anything particularly special about the paragraph I wanted to modify but it was vertically aligned to the top which I wanted to change and I remember the vertical alignment buttons weren't available in the Sidebar>"Properties">"Paragraph" section for some reason so I clicked "More options".
Comment 4 V Stuart Foote 2016-09-10 19:13:40 UTC
OK, just to confirm you are on a Windows 10 32-bit (ver 1607/ build 10.0.14393)?
Comment 5 edward.guitaro 2016-09-10 19:56:25 UTC
No, this occurred on Windows 10 Home 64-bit version 1607 build 14393.105.
Comment 6 V Stuart Foote 2016-09-10 21:00:18 UTC
OK, so you were using the 32-bit build of LibreOffice...

Helpful to copy/paste details from the Help -> About LibreOffice dialog.

Do you happen to have the document (or an extract that consistently crashes) that you can post up?
Comment 7 edward.guitaro 2016-09-11 09:05:55 UTC
LibreOffice toolbar>"Help">"About LibreOffice" information about version:
"Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: en-GB (en_GB); Calc: group"

I have not recently been able to reproduce the bug with my document so I won't post it or part of it but based on my descriptions of how it happened it may be possible to create it. The comments describe what made the crash happen including an official detailed error report.
Comment 8 Aron Budea 2016-09-12 01:03:13 UTC
Upping importance, since it's a crash, and there are lots of crash reports: http://crashreport.libreoffice.org/stats/signature/sfx2::sidebar::Panel::SetExpanded(bool)

I couldn't reproduce it myself, either, with the given steps (v5.2.1.2 / Windows 7), unfortunately.
Comment 9 Caolán McNamara 2016-09-22 08:38:55 UTC
exact how-to-reproduce of this in 5-1 series is currently avoided because of...

commit e1e61bf5e5f368fc1ea579f8ae5eec9faafbd599
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Fri Jun 3 11:06:22 2016 +0100

    Resolves: tdf#88396 switching to sidebar panel will toggle it *off*...

    if its already visible.

the crashing code was truly fixed by...

commit e964c55f463c5b9daeb41dbed6c330b40911c313
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Fri Jan 29 18:52:34 2016 +0000

    implement missing FID_FUNCTION_BOX GetState

    since it was turned into a sidebar thing

this is fixed in master and 5-2, so setting as fixed. 5-1 backport of crash fix as https://gerrit.libreoffice.org/#/c/29170/
Comment 10 Caolán McNamara 2016-09-22 08:43:01 UTC
Sorry, that was for bug 100670, though it might be related
Comment 11 Timur 2016-12-27 14:31:14 UTC
*** Bug 104535 has been marked as a duplicate of this bug. ***
Comment 12 Timur 2016-12-27 15:18:33 UTC
This crash signature was consistently reproducible per steps in https://bugs.documentfoundation.org/show_bug.cgi?id=104884#c0
Not anymore with 5.3 beta 2 or master. So I close as WFM.
This is a duplicate of some other bug but https://wiki.documentfoundation.org/Releases/5.3.0/Beta2 is empty to spot of what.
Comment 13 V Stuart Foote 2017-01-05 03:21:00 UTC
*** Bug 105092 has been marked as a duplicate of this bug. ***
Comment 14 Aron Budea 2017-01-05 07:47:52 UTC
This will supposedly be fixed in 5.2.5, see my comment:
https://bugs.documentfoundation.org/show_bug.cgi?id=104884#c7

Commit: https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-2&id=3e60ccb74ac6589e14a479c6646c63a4e5ac4e35

Someone should verify with a 5.2 daily build, though.