Bug 105579 - After certain actions comments in Calc point to the wrong cell
Summary: After certain actions comments in Calc point to the wrong cell
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
: 111449 116580 (view as bug list)
Depends on:
Blocks: Calc-Comments
  Show dependency treegraph
Reported: 2017-01-28 04:59 UTC by Aron Budea
Modified: 2023-07-19 03:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

Spreadsheet with steps 1-4 (7.51 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-01-28 04:59 UTC, Aron Budea
Screenshot after moving comment (51.32 KB, image/png)
2017-02-03 20:33 UTC, Aron Budea
Screencast (187.37 KB, video/x-msvideo)
2017-02-05 05:23 UTC, Aron Budea
Bug about to occur (72.29 KB, image/png)
2017-02-12 22:39 UTC, Aron Budea

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-01-28 04:59:11 UTC
Created attachment 130732 [details]
Spreadsheet with steps 1-4

1. Start a new Calc spreadsheet.
2. Resize a row, let's say row 9.
3. Insert a comment for a cell below that row, let's say D10.
4. Right click cell, select Show Comment.

Attaching a spreasheet with the steps so far.

5. Resize the same row as before (row 9) to around its original size.
6. Move the comment a large distance, quickly. Or move it to the right, and with another move, move it back to left.

=> The comment's arrow now points to top left corner of the sheet. Or maybe just somewhere else in the sheet, like around its original place, but not the cell it's supposed to. What happens is not entirely consistent for me...

If it can't be confirmed easily, I'll try to create a screencast.

Observed with,, 3.3.0 / Ubuntu 16.04.
Comment 1 Buovjaga 2017-02-03 10:08:29 UTC
Unable to repro from scratch of with file. Have to test on Linux l8r.

Win 7 Pro 64-bit Version:
Build ID: c6dd735afb2e1b3837c4f8c5659f52fafab4c56f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-30_01:52:54
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Aron Budea 2017-02-03 20:33:19 UTC
Created attachment 130894 [details]
Screenshot after moving comment

I think I moved it twice here using / Windows 7.

There are no accurate steps, I kind of did it trial by error. Should I create a screencast to illustrate?
Comment 3 Buovjaga 2017-02-04 08:22:13 UTC
(In reply to Aron Budea from comment #2)
> There are no accurate steps, I kind of did it trial by error. Should I
> create a screencast to illustrate?

You totally should.
Comment 4 Aron Budea 2017-02-05 05:23:03 UTC
Created attachment 130911 [details]

I totally have, then.
Seems like the arrow ends up pointing to the place where it originally was before resizing the cell. Or sometimes it points to the top left corner instead.
Comment 5 Buovjaga 2017-02-06 15:29:55 UTC
Tried on Ubuntu 16.10, but could not repro.
I tried to follow the screencast closely, including having the row have a height where the comment height is smaller (so it goes "inside" the row).

Build ID: a296a69c984b17cfbcd249cf6bdc191d08dff2a6
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2017-02-06_01:05:34
Locale: en-US (en_US.UTF-8); Calc: group
Comment 6 Aron Budea 2017-02-12 22:39:38 UTC
Created attachment 131158 [details]
Bug about to occur

I only managed to get this on the 4-5th try myself. Also, if it doesn't occur, just undo until after the row resizing after adding the comment, and try again.
A telltale sign of the bug if the arrow stops pointing to the cell during dragging. Sometimes it happens easier after undoing and giving it another go.
Comment 7 raal 2017-07-03 18:27:17 UTC
repro. Version:
Build ID: 77f77c57d336ba041faf51e2168372d1e0962a19
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-06-29_23:40:47
Comment 8 Telesto 2017-08-07 17:27:47 UTC
*** Bug 111449 has been marked as a duplicate of this bug. ***
Comment 9 Telesto 2017-08-07 17:28:31 UTC
Steps to Reproduce:
1. Open Calc
2. Select B6 and press CTRL+ALT+C (add comment) and enter XXX
3. Menu -> View -> Show comment (not needed; more for a visual)
4. Insert a new sheet -> Sheet insert -> Click OK 
5. Select F16 and press CTRL+ALT+C (add comment) and enter  ZZZ
6. Select C16
7. Menu -> View -> Show comment
8. Press CTRL+Z three times (3x)
9. Comment will appear at C11 on sheet 1
Comment 10 Aron Budea 2018-03-24 19:09:36 UTC
*** Bug 116580 has been marked as a duplicate of this bug. ***
Comment 11 Emil Tanev 2018-04-21 08:19:58 UTC
Another way
Insert comment on cell A1, B1, C1
Merge the cells
Show comment

Comment is displayed on cell A1 even though they are merged now (should be outside of the merged region)

Comment 12 Emil Tanev 2018-04-21 08:20:28 UTC
Version: (x64)
Build ID: d39a8e791618a40328c0f90bece3cc246dcf57f7
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-06_00:59:07
Locale: en-US (en_US); Calc: group
Comment 13 Telesto 2018-07-17 10:48:10 UTC
(In reply to Telesto from comment #9)
Another way to reproduce:
1. Open Calc
2. Insert a comment
3. Show comment
4. Sheet -> Move or copy sheet -> Press OK (copy)
5. Undo (CTRL+Z)
Comment 14 QA Administrators 2019-07-18 02:49:33 UTC Comment hidden (obsolete)
Comment 15 QA Administrators 2021-07-18 03:29:43 UTC Comment hidden (obsolete)
Comment 16 Aron Budea 2021-07-18 11:49:47 UTC
Still repro with steps from comment 13. Not sure about my original steps, but don't want to dig into that while it's reproducible with some steps.

LO (4450137924eb8626a57283e1ab4f4ad62dd2d595) / Windows.
Comment 17 QA Administrators 2023-07-19 03:15:28 UTC
Dear Aron Budea,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team