Bug 105866 - Libreoffice writer very slow if more than one picture on one page
Summary: Libreoffice writer very slow if more than one picture on one page
Status: RESOLVED DUPLICATE of bug 86798
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2017-02-08 21:49 UTC by a.winner100
Modified: 2017-10-04 15:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Confirm slow behaviour on Linux (5.31 MB, video/ogg)
2017-07-02 13:43 UTC, Pieter Wolters
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a.winner100 2017-02-08 21:49:25 UTC
Description:
If I put more than One picture on one page in LibreOffice Writer, I almost can't write because the software become extremely slow. It turn arround 1-2 fps with five pictures.
Config :
-windows 7 64 bits
-AMD FX-8350
-8 Go RAM DDR3 1866Mhz

Steps to Reproduce:
1.Create a new document
2.write something on five or six lines
3.import five pictures

Actual Results:  
Libreoffice Writer become extremely slow

Expected Results:
Libreoffice Writer keep a normal speed


Reproducible: Always

User Profile Reset: yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Comment 1 haevalencia 2017-02-08 22:11:05 UTC
(In reply to a.winner100 from comment #0)
> Description:
> If I put more than One picture on one page in LibreOffice Writer, I almost
> can't write because the software become extremely slow. It turn arround 1-2
> fps with five pictures.

Did you try to compress the images? 

You can do this by selecting the image and clicking it with the second mouse button. In the contextual menu you will see the option "compress".
You can also do this from the menu "Format | Image | Compress".

If you use high resolution image and you have not properly configured the memory in LibreOffice options you may have this kind of problems.

Anyway it should be more intuitive, as apparently other office suits do it automatically (perhaps with the consequence of using more resources)
Comment 2 Xisco Faulí 2017-02-08 22:19:46 UTC Comment hidden (obsolete)
Comment 3 Thomas Lendo 2017-04-26 13:02:40 UTC
You can test it with the attachment 131240 [details] of bug 83734. When scrolling through the pages fast (with mouse or keyboard), the canvas lags/hangs a bit which disrupts the user experience.

For me, the cause for this bug is the same as in bug 103873 and bug 104907 (one after another or behind one another should be all the same for the program).
Comment 4 Thomas Lendo 2017-04-26 18:29:18 UTC
And it must be w regression in the 3 or 4 series of LibO because 3.3.0 only hangs the first time and after that it works better than current versions.
Comment 5 Pieter Wolters 2017-07-02 13:43:34 UTC
Created attachment 134428 [details]
Confirm slow behaviour on Linux

I can confirm lagging behaviour with this file. See video I attached. 

When you scroll it is plain slow, when 'edit' mode is turned on you see blue lines appearing between the pages. Then it get's really slow!

These blue lines seem to indicate hard-returns, after removing them, the document is only plain slow.

this is filmed on Ubuntu 14.04 / LO 5.3.3.2 

Help>About
Version: 5.3.3.2
Build ID: 1:5.3.3~rc2-0ubuntu0.14.04.1~lo0
CPU Threads: 4; OS Version: Linux 3.13; 
UI Render: default; 
VCL: gtk2; 
Layout Engine: new; 
Locale: nl-NL (en_US.UTF-8); 
Calc: group
Comment 6 Xisco Faulí 2017-10-04 14:50:18 UTC
Regression introduced by 2e5167528f7566dd9b000e50fc1610b7bf99132a which is the same as in bug 86798

*** This bug has been marked as a duplicate of bug 86798 ***
Comment 7 Thomas Lendo 2017-10-04 15:10:37 UTC
(In reply to Xisco Faulí from comment #6)
Thank you very much, Xisco!