Bug 105884 - Make the tabs of tabbed Notebookbar follow KDE style
Summary: Make the tabs of tabbed Notebookbar follow KDE style
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.1
Keywords:
: 106061 (view as bug list)
Depends on:
Blocks: KDE Notebookbar-Theming
  Show dependency treegraph
 
Reported: 2017-02-09 14:58 UTC by pieter kristensen
Modified: 2019-06-29 16:12 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
muffin tabs in Windows 10, Ubuntu en kde (65.32 KB, image/jpeg)
2017-02-09 14:58 UTC, pieter kristensen
Details
Dolphin+plasma 5.9.1+breeze theme (135.90 KB, image/jpeg)
2017-02-12 17:32 UTC, pieter kristensen
Details
Libreoffice+libreoffice-kde theme+breeze theme (169.77 KB, image/jpeg)
2017-02-12 17:38 UTC, pieter kristensen
Details
LibreOffice with libreoffice-gtk installed. X and Wayland (148.02 KB, image/jpeg)
2017-02-12 17:54 UTC, pieter kristensen
Details
Tabs on LibreOffice vs. Calligra/Qt5 vs. Qt4_Config (95.37 KB, image/png)
2017-02-16 20:59 UTC, Heiko Tietze
Details
tabs on march 8th look better (39.89 KB, image/jpeg)
2017-03-08 19:49 UTC, pieter kristensen
Details
screenshot of LibO and Dolphin with tab layout (97.94 KB, image/png)
2019-03-29 12:15 UTC, andreas_k
Details
Qt5 tab theming (broken) (10.48 KB, patch)
2019-04-05 00:23 UTC, Jan-Marek Glogowski
Details
LO 6.4.0.0 with themed tabs in kde... (90.09 KB, image/jpeg)
2019-06-29 16:12 UTC, pieter kristensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pieter kristensen 2017-02-09 14:58:15 UTC
Created attachment 131043 [details]
muffin tabs in Windows 10, Ubuntu en kde

When I choose the tabbed version of the muffin bar it looks elegant in Windows 10 and Ubuntu (in my opinion). But it looks very ugly in kde.
Added attachment where you can compare the three.
Comment 1 pieter kristensen 2017-02-12 06:23:46 UTC
I un-installed libreoffice-kde and took libreoffice-gtk3 in its place. Now the tabs look completely different and ugly (and not so much as the breeze theme) but it functions better. 

Am I right to think that with libreoffice-gtk3 all problems would be over when kde's  breeze-gtk3 theme became mature. When there would be made an effort from the side of the document foundation to make the kde plasma 5 integration smoother then perhaps it is smarter to help the kde guys with the breeze-gtk3 theme and not put so much energy in the libreoffice-kde. 
 
That way perhaps you all benefit. 
- it's too bad that the breeze-gtk3 theme still is not mature and
- from the libreoffice side it would be unnecessary to maintain the libreoffice-kde package. 

These are just my thoughts. I could be totally wrong.
Comment 2 Buovjaga 2017-02-12 15:34:13 UTC
Ok, what exactly is ugly? No separator lines? Please explain.
Comment 3 pieter kristensen 2017-02-12 17:32:57 UTC
Created attachment 131151 [details]
Dolphin+plasma 5.9.1+breeze theme

This is how the Breeze theme should look I suppose. Watch the tabs
Comment 4 pieter kristensen 2017-02-12 17:38:33 UTC
Created attachment 131152 [details]
Libreoffice+libreoffice-kde theme+breeze theme

This doesn't look like the Dolphin at all (other screenshot). In my eyes it is rough and unfinished. The tabs look not at all like the breeze-tabs. Further all kind of things go wrong as you see.
But that is due to the fact that I have an older intel graphics card and they switched to the xserver-xorg-video-intel-native-modesetting driver.
Comment 5 pieter kristensen 2017-02-12 17:54:38 UTC
Created attachment 131153 [details]
LibreOffice with libreoffice-gtk installed. X and Wayland

The X one resembles Breeze the most. Especially the tabs. It doesn't look 100% like breeze (no system colors etc) but it is nice

The Wayland version is a surprise. Stange, it has no tabs but it looks nice. Not breeze-like
Comment 6 Jan-Marek Glogowski 2017-02-16 12:12:16 UTC
So I guess your real complain is about missing theming of LOs tabs in the KDE4 backend.

Yup - it's not (yet) implemented.

I have a preliminary patch for this, but Qt4 distinguishes between right, left and middle tabs, so I think I'll simply go with "everything middle", and there is some strange metric handling, which I have to figure out.

If you have a build, I can provide a branch for you to test, but generally it'll need some more time, as I'm currently overwhelmed by RL events.
Comment 7 pieter kristensen 2017-02-16 12:25:54 UTC
Thank you for your reply. You ask: "So I guess your real complain is about missing theming of LOs tabs in the KDE4 backend".

KDE4 backend? That could be, but shouldn't that be "KDE 5" backend?

The whole UI doesn't feel native at all if you use KDE.
Comment 8 Buovjaga 2017-02-16 12:31:12 UTC
(In reply to pieter kristensen from comment #7)
> KDE4 backend? That could be, but shouldn't that be "KDE 5" backend?

Could, should and would: https://wiki.documentfoundation.org/Development/GSoC/Ideas#KDE5:_port_KDE4_plugin_to_KF5
Comment 9 Heiko Tietze 2017-02-16 20:59:19 UTC
Created attachment 131285 [details]
Tabs on LibreOffice vs. Calligra/Qt5 vs. Qt4_Config

Themes are not respected today, and we are still on Qt4. My screenshot is made on LXQt/Kwin with Breeze Dark theme.
Comment 10 Buovjaga 2017-02-19 19:04:54 UTC
*** Bug 106061 has been marked as a duplicate of this bug. ***
Comment 11 pieter kristensen 2017-03-08 19:49:04 UTC
Created attachment 131763 [details]
tabs on march 8th look better

for unknown reason it looks nicer now on my system (neon user edition plasma 5.9.3 LO 5.3.0). 
When I start a wayland session it looks identical.
Very nice. Not 100% plasma 5 but even nicer.
Comment 12 QA Administrators 2018-04-16 02:28:29 UTC Comment hidden (obsolete)
Comment 13 Roman Kuznetsov 2018-10-26 21:16:48 UTC
bubli, may be you are interesting for this bug because now we have new KDE back-end?
Comment 14 andreas_k 2018-12-10 22:33:04 UTC
The QT5 backend is far away from a final design. sorry to say this.
Comment 15 andreas_k 2019-03-29 12:15:34 UTC
Created attachment 150391 [details]
screenshot of LibO and Dolphin with tab layout

It getting better and better.

Please remove the thick line on the right border to the tab and on bottom of the notebookbar.

In black mode it's better visible than on light color scheme.

Thanks
Comment 16 Jan-Marek Glogowski 2019-04-05 00:23:59 UTC
Created attachment 150541 [details]
Qt5 tab theming (broken)

Just FYI: the tabbing widget is currently not Qt themed at all and never has been. It's completely drawn by LO itself. Nothing has changed since my comment 6. Actually the patch from back then is lost; or more probably I couldn't get it working back then, just like I tried again a few days ago.

As for the current state: something is very broken with the way LO tries to draw various frames. The attached patch can theme the tabs, but I couldn't get it to draw the frame of the tab widget at all!

There is still the general frame painting problem. That's also the reason the Calc input bar has no frame, same for the Writer "character" format dialog, where the font preview at the end of the dialog has no frame.

I don't understand, why the edit lines are drawn correctly, as this code isn't really correct, but somehow works. Any change I made to this code broke it or crashed LO.

Same for the border of popup menus.
It looks even worse, if you start QT_STYLE_OVERRIDE=windows SAL_USE_VCLPLUGIN=qt5.

I've tried to fix this code multiple times now. I've read the Qt code, but even that didn't help me understand what's wrong.
All this may actually be a Qt bug - I don't know.
Comment 17 Commit Notification 2019-06-21 14:49:26 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/430b406e5e8249983fc030aa0f867372f5da74d2%5E%21

tdf#105884 Qt5 implement TabControl theming

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2019-06-22 18:54:48 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/466cc6c63c4020519d47ec442739f22d7779e901%5E%21

tdf#105884 Qt5 implement TabControl theming

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 pieter kristensen 2019-06-29 16:12:28 UTC
Created attachment 152468 [details]
LO 6.4.0.0 with themed tabs in kde...

Thank you for the themed tabs. It looks great!