Bug 105922 - Slide properties: selected colours not applied in gradient background
Summary: Slide properties: selected colours not applied in gradient background
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium minor
Assignee: Katarina Behrens (CIB)
URL:
Whiteboard: target:5.4.0
Keywords: implementationError
: 105718 (view as bug list)
Depends on:
Blocks: Area-Fill-Tab
  Show dependency treegraph
 
Reported: 2017-02-10 16:38 UTC by Xisco Faulí
Modified: 2017-04-13 11:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-02-10 16:38:16 UTC
Steps to reproduce:
1. New presentation
2. Right click - Slide properties - Background - Gradient
3. Choose any gradient in the left box
4. Choose two different colours in the 'from' and 'to' palettes -> Preview is correct
5. Click Ok
6. apply it to all the slide or just to the current.

Observed behaviour: Selected colours in 'from' and 'to' palettes aren't used in the background

the background dialog was implemented in 686349476e03f951f4a9ff9755b9f71951b64ea5
Comment 1 Buovjaga 2017-02-12 15:41:07 UTC
Repro.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: ac8197327d3ef4f3c94fb0746393863404df086b
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 11th 2016
Comment 2 Heiko Tietze 2017-02-12 20:27:21 UTC
Workaround is to add the gradient as a new preset.
Comment 3 Xisco Faulí 2017-02-13 15:35:57 UTC
patch submitted to gerrit: https://gerrit.libreoffice.org/#/c/34214/
Comment 4 Katarina Behrens (CIB) 2017-03-06 12:18:36 UTC
*** Bug 105718 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2017-03-31 10:56:16 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff1f83dd08b7b0169301ffe0a53499a27af613b9

tdf#105922: Apply custom gradient/hatch even if not saved as preset

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-04-13 10:00:54 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=93d58279cd56fd026db4dfb68d04fc22edba1abc

Related tdf#105922: step increment is a property of the shape

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Katarina Behrens (CIB) 2017-04-13 11:04:56 UTC
Even uitest is now happy => fixed