Bug 125449 - Changing percent gradient or color changes chart wall gradient color to black and white
Summary: Changing percent gradient or color changes chart wall gradient color to black...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium normal
Assignee: Gabor Kelemen
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6.3.4
Keywords: bibisected, bisected, needUITest, regression
: 114273 124402 127861 128597 128617 Danyan (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-23 01:42 UTC by Cathy Crumbley
Modified: 2019-11-26 11:49 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
data for testing chart wall gradient (132.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-05-23 01:42 UTC, Cathy Crumbley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cathy Crumbley 2019-05-23 01:42:53 UTC
Created attachment 151609 [details]
data for testing chart wall gradient

To reproduce:

    1. Select data range (test data attached)
    2. Click Chart Wizard in Standard toolbar
    3. Choose any chart type that has a chart wall
    4. Click Finish
    5. Select the chart wall
    6. Right-click and select Format Wall
    7. On the Area tab, click Gradient
    8. Select one of the preview images
    9. Change the percent in either the From color or To Color spin box OR select different colors for either From color or To Color

Expect to see: the selected gradient and color scheme appear in the chart wall
What happens:  the gradient is black and white, not color

This is similar to 114273, but that report was about changing the color itself, not the percent color and the result was not clear.  In this report, changing either the color or the percent causes the result to be black and white.

Version: 6.3.0.0.alpha1 (x64)
Build ID: 547edd20e527fb02900f6174973770d26306e2e7
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 1 Julien Nabet 2019-05-23 19:09:03 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 2 Julien Nabet 2019-05-23 19:29:13 UTC
I could reproduce this to on Debian testing with LO 6.1.5.2
Comment 3 Jacques Guilleron 2019-05-29 14:46:16 UTC
Hi Cathy, Julien,

I reproduce too with
LO 5.4.0.0.alpha1
Build ID: 0b9f9bef65bb21ebb6a64aafad448f7f62dc824a
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
and upper versions
but not with
LO  5.3.7.1
Build ID: 376eaac300a303c4ad2193fb7f6a7522caf550b9
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR); Calc: CL

Jacques
Comment 4 Xisco Faulí 2019-05-30 12:17:12 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ff1f83dd08b7b0169301ffe0a53499a27af613b9

author	Katarina Behrens <Katarina.Behrens@cib.de>	2017-03-31 10:00:40 +0200
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2017-03-31 10:54:34 +0000
commit	ff1f83dd08b7b0169301ffe0a53499a27af613b9 (patch)
tree	fa553938d3a2c30af42361156b9ce02967a06ec0
parent	541b377a94fb1247dbf4c39b5bcf55deb8e5ef60 (diff)
tdf#105922: Apply custom gradient/hatch even if not saved as preset

Bisected with: bibisect-linux-64-5.4

Adding Cc: to Katarina Behrens
Comment 5 Xisco Faulí 2019-06-05 18:18:00 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2019-06-05 19:20:46 UTC
If I remove the line 'aString = "gradient";' then it works, however, if we create a gradient in impress and save it, it will be gone after RT
Comment 7 Xisco Faulí 2019-06-05 19:32:49 UTC
OTOH, if the mentioned line is deleted the gradient is saved after RT in the chart. This is all a mystery to me...
Comment 8 Xisco Faulí 2019-06-06 07:12:33 UTC
(In reply to Xisco Faulí from comment #6)
> If I remove the line 'aString = "gradient";' then it works, however, if we
> create a gradient in impress and save it, it will be gone after RT

thus, putting back regression keyword
Comment 9 Julien Nabet 2019-06-06 08:05:44 UTC
Comparing gradient and hatch files (cui/source/tabpages/tpgradnt.cxx and cui/source/tabpages/tphatch.cxx), I noticed that hatch part contained these lines:
m_xMtrDistance->save_value();
m_xMtrAngle->save_value();
m_xLbLineType->save_value();
m_xLbLineColor->SaveValue();
m_xLbBackgroundColor->SaveValue();

in IMPL_LINK_NOARG(SvxHatchTabPage, ClickModifyHdl_Impl, weld::Button&, void)

There's no equivalent in gradient part.
Now perhaps it's normal.
Comment 10 Xisco Faulí 2019-09-26 10:23:44 UTC
Dear Katarina Behrens (CIB),
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 11 IM 2019-09-29 22:06:37 UTC
*** Bug 127861 has been marked as a duplicate of this bug. ***
Comment 12 Gabor Kelemen 2019-11-06 20:40:02 UTC
*** Bug 128617 has been marked as a duplicate of this bug. ***
Comment 13 NISZ LibreOffice Team 2019-11-07 10:44:20 UTC
*** Bug 114273 has been marked as a duplicate of this bug. ***
Comment 14 Gabor Kelemen 2019-11-10 18:05:49 UTC
Proposed patch: https://gerrit.libreoffice.org/82393
Comment 15 Commit Notification 2019-11-19 09:24:32 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/34a3afecaaab3dc4898b33e0981d8b231351fe37

tdf#125449 follow-up: unique gradient names in Impress area dlg

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-11-19 09:27:09 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/53c474633c4e658f096669fb0225d751a5701aaf

tdf#125449 Fix custom gradient fill settings being lost

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-11-19 16:47:53 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/5979fc4a3fa5713b8df49ba624445ce9ed4ccace

tdf#125449 Fix custom gradient fill settings being lost

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2019-11-19 16:48:09 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c00775925325b04b3d707df0d494464f864f6fc0

tdf#125449 follow-up: unique gradient names in Impress area dlg

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2019-11-20 10:20:26 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 5059984c44379d09eabf740c21db062b925394ad
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Gabor, @Bubli, thanks for fixing this issue!!
Comment 20 Commit Notification 2019-11-20 22:47:10 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/d7cf742cde9b174cf83c416fc1618da80a3a13f0

tdf#125449 Fix custom gradient fill settings being lost

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2019-11-20 22:47:19 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/308249b43f8d62967f7bfa974f3e4f3f6182a010

tdf#125449 follow-up: unique gradient names in Impress area dlg

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 NISZ LibreOffice Team 2019-11-26 09:59:48 UTC
*** Bug 124402 has been marked as a duplicate of this bug. ***
Comment 23 NISZ LibreOffice Team 2019-11-26 11:21:19 UTC
*** Bug 128967 has been marked as a duplicate of this bug. ***
Comment 24 NISZ LibreOffice Team 2019-11-26 11:49:50 UTC
*** Bug 128597 has been marked as a duplicate of this bug. ***