Download it now!
Bug 107360 - No Access connection for 64 bit LO (Windows) - see Comment 7
Summary: No Access connection for 64 bit LO (Windows) - see Comment 7
Status: CLOSED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: Database-MS_Access
  Show dependency treegraph
 
Reported: 2017-04-23 06:38 UTC by Leif Johansen
Modified: 2020-02-11 16:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screen dump of error in Base (6.47 KB, image/png)
2017-04-23 06:42 UTC, Leif Johansen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leif Johansen 2017-04-23 06:38:48 UTC

    
Comment 1 Leif Johansen 2017-04-23 06:42:58 UTC
Created attachment 132761 [details]
Screen dump of error in Base

For a year ago I have made a connection to a accdb or mdb file. To day it is not possible

I got the error you can see at the
Comment 2 Alex Thurgood 2017-04-24 08:32:51 UTC
@Leif : please provide the version of Windows and bit (32 or 64) version of LibreOffice that you are using.
Comment 3 Leif Johansen 2017-04-24 09:21:27 UTC
I use Windows 10 64 bit Home version. 
I have Libre Office  64 version

PC is old - very old but still going strong
Comment 4 he-lang 2017-07-21 16:00:26 UTC
I have the same problem.
After the update to 5.3, no MS Access database can be opened with LO.
Error message:
The connection could not be established. The required data provider may not be installed.
System Win 7 Pro 64Bit , Libre Office 5.3.4.2 64Bit
Comment 5 Timur 2017-07-21 16:17:16 UTC
Please also add which driver you're using. Like in 
https://bugs.documentfoundation.org/show_bug.cgi?id=43187#c14
Comment 6 Robert Großkopf 2017-07-23 06:49:26 UTC
Isn't MS-Access a 32bit Software? Could it be LO 32bit will solve this problem?
Comment 7 Thomas Krumbein 2017-10-11 07:32:09 UTC
Additional informations regarding this bug:

all Windows 64 bit versions of LO do not support access 2007 *.mdb databases any more. You will get every time the provided error-message.

Even it is not possible to create an ODBC access to those databases via MS Windows system in 64 bit environment. Only 32bit environment is supported. 

But when you have installt a 64 bit LO on a 64 bit Windows system (with makes sense;)) - you cannot access the 32 drivers. 

So: two suggestions:

1.) Remove the support for Access 2007 (*.mdb) from all 64 bit MS Windows compilations  - so no user will run in trouble.

2.) Rework the filter - but I guess, this is not an easy task;)


For all users:  Install LO 32 bit and you will have access to *.mdb databases. 

Create then a new base-document (tested with hsqldb) - drag&drop the tables from mdb-file to hsqldb file (you have to add typicly a unic-key field and you have to rearrange the columns data-width). This base document with all your datas will now work even in 64bit environment.
Comment 8 Alex Thurgood 2017-10-20 13:48:44 UTC
(In reply to Thomas Krumbein from comment #7)
> Additional informations regarding this bug:
> 
> all Windows 64 bit versions of LO do not support access 2007 *.mdb databases
> any more. You will get every time the provided error-message.


Indeed, this is also mentioned on the MSDN forums. According to the posts there, there is no Microsoft supported way to access a 32bit MDB file using a 64bit program. As LO relies on Microsofts own drivers to do this, Access97 and Access2003 files are no longer accessible with 64bit LO. 


> 
> Even it is not possible to create an ODBC access to those databases via MS
> Windows system in 64 bit environment. Only 32bit environment is supported. 
>

You can however use ODBC on 64bit Windows installations to 64bit accdb files, see comment 13 of bug 104757.
Comment 9 Alex Thurgood 2017-10-20 13:50:46 UTC
I suggest closing this, and other similar reports as either WONTFIX, or NOTOURBUG, or else WFM in 64bit everything and Access >= 2010.
Comment 10 eremmel 2017-10-21 07:30:23 UTC
Access to *.mdb files with LO x64 is possible via ODBC and installing Microsoft Access Database Engine 2016 Redistributable.
Verified against LO 5.4.2.2 (x64)
Comment 11 Chris Grove 2018-01-05 20:45:56 UTC
It has been suggested that the answer is to back-grade LO to a 32 bit version.  Fine, but my experience over the last few years is that, as soon as an upgrade is available, Base 'stops responding', so this seems unlikely to work.  I wish I knew why this happened as it seems illogical, but that has been what has happened to me.
The other suggestion is that to download 'Microsoft Access Database Engine 2016 Redistributable' will make access possible.  I have been unable to find any way of doing this.  Advice?
Chris
Comment 12 Alex Thurgood 2018-01-08 11:06:19 UTC Comment hidden (obsolete)
Comment 13 Alex Thurgood 2018-01-08 11:07:46 UTC
(In reply to Alex Thurgood from comment #12)
> (In reply to Chris Grove from comment #11)
> 
> 
> > The other suggestion is that to download 'Microsoft Access Database Engine
> > 2016 Redistributable' will make access possible.  I have been unable to find
> > any way of doing this.  Advice?
> > Chris
> 




https://www.microsoft.com/en-us/download/details.aspx?id=54920

Sorry, first post was an incorrect link (typed instead of pasted)
Comment 14 Zineta 2018-03-19 12:33:52 UTC
Tried in LO 5.3.4.2  "The connection could not be created"- error message appeared. In previous version LO 5.2.5.1 and next LO 5.3.7.2  connections was created, but not editable.
Comment 15 rajan 2018-10-06 05:36:13 UTC Comment hidden (spam)
Comment 16 ribotb 2018-10-29 10:18:47 UTC
I understood that the solution is:
- either use an ODBC connection after MDAC installation,
- or retrograde to LibreOffice.32-bit 

But I didn't understand where the problem is located: 
- MS-Access databases (*.mdb) are no longer supported by Windows 64-bit 
- or is it the LibreOffice 64-bit connection to these files that no longer works?

Thank you
Bernard
Comment 17 Alina Olive 2018-10-29 12:50:13 UTC Comment hidden (spam)
Comment 18 Timur 2018-10-29 14:20:08 UTC
https://bugs.documentfoundation.org/show_bug.cgi?id=97395#c35
https://bugs.documentfoundation.org/show_bug.cgi?id=97579#c20

I guess it's safe enough to close as NOtOurBug. 

From what I see, we don't have documentation on all this and should be there.
Comment 19 ribotb 2018-11-04 10:28:05 UTC
To connect to my Access database I tried to install MDAC 64-bit but:

You cannnot install the 64-bit version of Microsoft Access Database
Engine 2016 because you currently have 32-bit Office products
installed. If you want to install 64-bit Microsoft Access Database
Engine 2016, you will first need to remove the 32-bit installation of
Office products. After uninstalling the following product(s), rerun
setup in order to install 64-bit version of Microsoft Access Database
Engine 2016:
Module de compatibilité pour Microsoft Office System 2007, Microsoft
Office PowerPoint Viewer 2007 (French), Visionneuse Microsoft
PowerPoint

Not sure there is a 64-bit version of PowerPoint Viewer... :-)
Comment 20 happywheelsgame 2018-11-13 06:46:07 UTC Comment hidden (spam)
Comment 21 Irfan Tahir 2018-11-26 15:39:03 UTC Comment hidden (spam)
Comment 22 Alishia Sergi 2018-11-29 18:47:39 UTC Comment hidden (spam)
Comment 23 Amilaa Anderson 2018-12-05 13:18:58 UTC Comment hidden (spam)
Comment 24 Xisco Faulí 2018-12-05 15:12:33 UTC
I'm removing everyone from this bug as it's constantly under spam attack.
@Leif, if you still reproduce this issue in the latest version of LibreOffice, prease, create a new report. Sorry for the inconveniences...
Comment 26 lohudkumar 2019-05-09 04:20:01 UTC Comment hidden (spam)
Comment 27 hasibvai 2019-12-28 07:59:33 UTC Comment hidden (spam)