Bug 107569 - Missing tango icon
Summary: Missing tango icon
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Icon-Theme-Tango
  Show dependency treegraph
 
Reported: 2017-05-02 19:17 UTC by Julien Nabet
Modified: 2019-04-17 11:10 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2017-05-02 19:17:35 UTC
Description:
On pc Debian x86-64 with master sources updated yesterday, here are some Tango icons missing:
cmd/lc_setoutline.png
cmd/sc_orientation.png

(noticed with console message like:
warn:legacy.osl:5250:1:framework/source/uiconfiguration/ImageArrayData.cxx:85: ImageAryData::Load: failed to load image 'cmd/lc_setoutline.png' from icon theme 'tango')

Steps to Reproduce:
I don't remember how to reproduce this, sorry.

Actual Results:  
Console logs indicating missing icons

Expected Results:
None of these logs


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Julien Nabet 2017-05-13 22:58:53 UTC
Just noticed these too:
warn:fwk.uiconfiguration:5533:1:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_wordcountdialog.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5533:1:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_bibliographycomponent.png' from icon theme 'tango'
Comment 2 Adolfo Jayme 2017-05-27 05:43:13 UTC
Provided {l,s}c_bibliographycomponent.png and sc_orientation.png with patch e2e03ffc2637c9faea8a78f04232644e66ad60c4. Others still pending…
Comment 3 Julien Nabet 2017-06-01 19:37:02 UTC
I noticed a new missing icon today:
warn:fwk.uiconfiguration:18961:1:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_editstyle.png' from icon theme 'tango'
Comment 4 Julien Nabet 2017-06-03 23:16:04 UTC
warn:fwk.uiconfiguration:1774:1:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/lc_rotate180.png' from icon theme 'tango'

warn:fwk.uiconfiguration:1774:1:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_mergedocuments.png' from icon theme 'tango'
Comment 5 Julien Nabet 2017-06-27 20:30:26 UTC
I noticed lots of missing icons when trying to customize toolbar:
cmd/sc_insertframemenu.png
cmd/sc_formatimagemenu.png
cmd/sc_formatframemenu.png
cmd/sc_toolsmacroedit.png
cmd/sc_shapeslinemenu.png
cmd/sc_splithorizontal.png
cmd/sc_splitvertical.png
cmd/sc_changepicture.png
cmd/sc_compressgraphic.png
cmd/sc_filedocument.png
cmd/sc_editframeset.png
cmd/sc_splitparenthorizontal.png
cmd/sc_mergedocuments.png
cmd/sc_insertfootnotesmenu.png
cmd/sc_newwindow.png
cmd/sc_movingaveragedialog.png
cmd/sc_formattextmenu.png
cmd/sc_formatformmenu.png
cmd/sc_covariancedialog.png
cmd/sc_acceptchanges.png
cmd/sc_regressiondialog.png
cmd/sc_tracechangemode.png
cmd/sc_commentchange.png
cmd/sc_focustofindbar.png
cmd/sc_analysisofvariancedialog.png
cmd/sc_ztestdialog.png
cmd/sc_freezecellsmenu.png
cmd/sc_freezepanesfirstrow.png
cmd/sc_correlationdialog.png
cmd/sc_splitparentvertical.png
cmd/sc_numberformatmenu.png
cmd/sc_exponentialsmoothingdialog.png
cmd/sc_sheetinsertname.png
cmd/sc_shapesmenu.png
cmd/sc_freezepanesfirstcolumn.png
cmd/sc_descriptivestatisticsdialog.png
cmd/sc_helpmenu.png
cmd/sc_chisquaretestdialog.png
cmd/sc_showchanges.png
cmd/sc_ftestdialog.png
cmd/sc_samplingdialog.png
cmd/sc_ttestdialog.png
cmd/sc_convertformulatovalue.png
cmd/sc_insertpivottable.png
cmd/sc_formatspacingmenu.png
cmd/sc_formatbulletsmenu.png
cmd/sc_formatstylesmenu.png
cmd/sc_signature.png
cmd/sc_editstyle.png
Comment 6 Yousuf Philips (jay) (retired) 2017-10-03 15:47:40 UTC
(In reply to Julien Nabet from comment #0)
> (noticed with console message like:
> warn:legacy.osl:5250:1:framework/source/uiconfiguration/ImageArrayData.cxx:
> 85: ImageAryData::Load: failed to load image 'cmd/lc_setoutline.png' from
> icon theme 'tango')

this is currently done, but sc_setoutline.png isnt.

(In reply to Julien Nabet from comment #5)
> I noticed lots of missing icons when trying to customize toolbar:

where did you get this list?

> cmd/sc_insertframemenu.png
> cmd/sc_formatimagemenu.png
> cmd/sc_formatframemenu.png

menu submenus like these dont have icons in any theme so not sure about this

> cmd/sc_helpmenu.png

icons cant appear in the menu bar so not sure why this is in the list.

> cmd/sc_editstyle.png

i'll upload this, as i uploaded the lc_ version recently for the styles toolbar. https://gerrit.libreoffice.org/43087
Comment 7 Julien Nabet 2017-10-03 16:44:09 UTC
(In reply to Yousuf Philips (jay) from comment #6)
> ...
> > I noticed lots of missing icons when trying to customize toolbar:
> 
> where did you get this list?
> 
> > cmd/sc_insertframemenu.png
> > cmd/sc_formatimagemenu.png
> > cmd/sc_formatframemenu.png
>... 
I'm not sure but I think it's when playing with customize menus.
I just tested again and had only this:

warn:fwk.uiconfiguration:1828:1828:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_mergedocuments.png' from icon theme 'tango'
warn:fwk.uiconfiguration:1828:1828:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_mergedocuments.png' from icon theme 'tango'

but lots of this one:
warn:legacy.osl:1828:1828:sfx2/source/control/msgpool.cxx:208: GroupId-Name not defined in SFX!
Comment 8 Maxim Monastirsky 2017-10-03 19:57:08 UTC
(In reply to Yousuf Philips (jay) from comment #6)
> > cmd/sc_insertframemenu.png
> > cmd/sc_formatimagemenu.png
> > cmd/sc_formatframemenu.png
> 
> menu submenus like these dont have icons in any theme so not sure about this

This "Failed to load image" warning is caused by the "Properties" section of these commands in GenericCommands.xcu. They all have there the value "1", which indicates that they should have an icon, see [1]. If these commands aren't supposed to have any icons, then just removing this "Properties" section should silence the warning IIRC.

> > cmd/sc_helpmenu.png
> 
> icons cant appear in the menu bar so not sure why this is in the list.

This caused by the presence of .uno:HelpMenu in the available commands list of the customization dialog, although it's useless, as it isn't a command that can do anything other than show the "Help" label. This is caused by the backing SID_HELPMENU definition in [2], which have MenuConfig = TRUE.

So what we need here is:

1) Same as above wrt. the "Properties" section in GenericCommands.xcu.
2) Find any occurrence of SID_HELPMENU in the codebase and simply remove it.

[1] https://opengrok.libreoffice.org/xref/core/officecfg/registry/schema/org/openoffice/Office/UI/Commands.xcs#59
[2] https://opengrok.libreoffice.org/xref/core/sfx2/sdi/sfx.sdi#1837
Comment 9 Yousuf Philips (jay) (retired) 2017-10-04 08:05:08 UTC
(In reply to Maxim Monastirsky from comment #8)
> 1) Same as above wrt. the "Properties" section in GenericCommands.xcu.

Will look over these and see which ones in the menus deserve to have icons and will add links to them in links.txt, and remove the ones that dont.

> 2) Find any occurrence of SID_HELPMENU in the codebase and simply remove it.

Here are the occurences

https://opengrok.libreoffice.org/search?project=core&q=SID_HELPMENU&defs=&refs=&path=&hist=&type=
Comment 10 Yousuf Philips (jay) (retired) 2017-10-05 06:20:50 UTC
First round of fixes.
https://gerrit.libreoffice.org/#/c/43152/
Comment 11 Commit Notification 2017-10-05 07:17:27 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4fd81a26681063dcc0d8d2eae795d39c8d894cb8

tdf#107569 Add small edit style icon

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2017-10-06 10:09:55 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ecc3d43d2feb4ec09a3f797a4eb6d2eb25e5ee7f

Related: tdf#107569 Remove useless slots

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2017-10-22 01:10:44 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc2d133e7953f08f73ef9cd0b40786764b0e2035

tdf#107569 Tango: Fix missing icons in menu bar

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Telesto 2017-10-23 18:34:49 UTC
When hoovering over the menu items in Writer I still get these
/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_recentfilelist.png' from icon theme 'tango'
/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_focustofindbar.png' from icon theme 'tango'
/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_pagedialog.png' from icon theme 'tango'
/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_watermark.png' from icon theme 'tango'
/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_rotate180.png' from icon theme 'tango'
/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_rotatereset.png' from icon theme 'tango'
/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_newwindow.png' from icon theme 'tango'
/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_wordcountdialog.png' from icon theme 'tango'

Version: 6.0.0.0.alpha1+
Build ID: 380d6afe5fd691f6ad4b17fc38b79b9fca4ba906
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-10-22_09:58:27
Locale: nl-NL (nl_NL); Calc: CL
Comment 15 Yousuf Philips (jay) (retired) 2017-10-23 21:13:02 UTC
@Maxim: We need to have a means of setting that an icon does not appear in the menu, even if it is to be displayed in the toolbar, sidebar and notebookbar.

(In reply to Telesto from comment #14)
> When hoovering over the menu items in Writer I still get these
> /ImageArrayData.cxx:74: Failed to load image 'cmd/sc_recentfilelist.png'
> from icon theme 'tango'

Andreas set this so it appears in the notebookbar and preferable it shouldnt display in the menu

> /ImageArrayData.cxx:74: Failed to load image 'cmd/sc_focustofindbar.png'
> from icon theme 'tango'

the menu entry is vnd.sun.star.findbar:FocusToFindbar and this should be turned off from looking for an icon, as you cant add it to the toolbar and find & replace already has an icon

> /ImageArrayData.cxx:74: Failed to load image 'cmd/sc_pagedialog.png' from
> icon theme 'tango'

only available in breeze

> /ImageArrayData.cxx:74: Failed to load image 'cmd/sc_watermark.png' from
> icon theme 'tango'
> /ImageArrayData.cxx:74: Failed to load image 'cmd/sc_rotate180.png' from
> icon theme 'tango'
> /ImageArrayData.cxx:74: Failed to load image 'cmd/sc_rotatereset.png' from
> icon theme 'tango'

removed

> /ImageArrayData.cxx:74: Failed to load image 'cmd/sc_newwindow.png' from
> icon theme 'tango'

only available in breeze

> /ImageArrayData.cxx:74: Failed to load image 'cmd/sc_wordcountdialog.png'
> from icon theme 'tango'

removed

Patch - https://gerrit.libreoffice.org/43729
Comment 16 Maxim Monastirsky 2017-10-23 22:45:29 UTC
(In reply to Yousuf Philips (jay) from comment #15)
> @Maxim: We need to have a means of setting that an icon does not appear in
> the menu, even if it is to be displayed in the toolbar, sidebar and
> notebookbar.
Bug 98058, I'll add a comment there.

> the menu entry is vnd.sun.star.findbar:FocusToFindbar and this should be
> turned off from looking for an icon, as you cant add it to the toolbar
What do you mean by that? Did you add it to the toolbar xml and it didn't work there?
Comment 17 Telesto 2017-10-24 07:33:52 UTC
Argh, I missed a few:
warn:fwk.uiconfiguration:4832:4836:framework/source/uiconfiguration/ImageArrayta.cxx:74: Failed to load image 'cmd/lc_jumptospecificpage.png' from icon them'tango'
warn:fwk.uiconfiguration:4832:4836:framework/source/uiconfiguration/ImageArrayta.cxx:74: Failed to load image 'cmd/sc_signature.png' from icon theme 'tango'
warn:fwk.uiconfiguration:4832:4836:framework/source/uiconfiguration/ImageArrayta.cxx:74: Failed to load image 'cmd/sc_signpdf.png' from icon theme 'tango'
warn:fwk.uiconfiguration:4384:4916:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_mergedocuments.png' from icon theme 'tango'
warn:fwk.uiconfiguration:4384:4916:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_updateall.png' from icon theme 'tango'
warn:fwk.uiconfiguration:4384:4916:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_changepicture.png' from icon theme 'tango'
warn:fwk.uiconfiguration:4832:4836:framework/source/uiconfigurati             on/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_compressgraphic.png' from icon theme 'tango'

in 
Version: 6.0.0.0.alpha1+
Build ID: 380d6afe5fd691f6ad4b17fc38b79b9fca4ba906
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-10-22_09:58:27
Locale: nl-NL (nl_NL); Calc: CL
Comment 18 Yousuf Philips (jay) (retired) 2017-10-24 15:59:29 UTC
(In reply to Maxim Monastirsky from comment #16)
> Bug 98058, I'll add a comment there.

Thanks.

> What do you mean by that? Did you add it to the toolbar xml and it didn't
> work there?

I meant that as it isnt an uno command, you cant add it to the toolbar through the customization dialog (bug 80914). I havent tried adding it to the toolbar xml, as I assume it wouldnt work, and as there wasnt a need to.

(In reply to Telesto from comment #17)
> Argh, I missed a few:
> warn:fwk.uiconfiguration:4832:4836:framework/source/uiconfiguration/
> ImageArrayta.cxx:74: Failed to load image 'cmd/lc_jumptospecificpage.png'
> from icon them'tango'

fixed

> warn:fwk.uiconfiguration:4832:4836:framework/source/uiconfiguration/
> ImageArrayta.cxx:74: Failed to load image 'cmd/sc_signature.png' from icon
> theme 'tango'
> warn:fwk.uiconfiguration:4832:4836:framework/source/uiconfiguration/
> ImageArrayta.cxx:74: Failed to load image 'cmd/sc_signpdf.png' from icon
> theme 'tango'
> warn:fwk.uiconfiguration:4384:4916:framework/source/uiconfiguration/
> ImageArrayData.cxx:74: Failed to load image 'cmd/sc_mergedocuments.png' from
> icon theme 'tango'

icon is in breeze, hasnt been created in tango

> warn:fwk.uiconfiguration:4384:4916:framework/source/uiconfiguration/
> ImageArrayData.cxx:74: Failed to load image 'cmd/sc_updateall.png' from icon
> theme 'tango'
> warn:fwk.uiconfiguration:4384:4916:framework/source/uiconfiguration/
> ImageArrayData.cxx:74: Failed to load image 'cmd/sc_changepicture.png' from
> icon theme 'tango'
> warn:fwk.uiconfiguration:4832:4836:framework/source/uiconfigurati           
> on/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_compressgraphic.png'
> from icon theme 'tango'

fixed

Patch - https://gerrit.libreoffice.org/43785
Comment 19 Telesto 2017-10-24 19:43:32 UTC
Another one. Highlight color -> custom color

warn:vcl:2744:1544:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image res/colorslider.png via icon theme tango
warn:vcl:2744:1544:vcl/source/gdi/bmpacc.cxx:52: Forbidden Access to empty bitmap!
Comment 20 Telesto 2017-10-24 19:50:40 UTC
I should have been more systematic.. Didn't check Impress

warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_remote.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_importslidefromfile.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_slidechangewindow.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_normalmultipanegui.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_outlinemode.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_notesmode.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_diamode.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_notesmasterpage.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_handoutmode.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_slidechangewindow.png' from icon theme 'tango'
warn:fwk.uiconfiguration:5064:2684:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_photoalbumdialog.png' from icon theme 'tango'

warn:fwk.uiconfiguration:2952:4108:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_ruler.png' from icon theme 'tango'
warn:fwk.uiconfiguration:2952:4108:framework/source/uiconfiguration/ImageArrayData.cxx:74: Failed to load image 'cmd/sc_insertanchor.png' from icon theme 'tango'
Comment 21 Yousuf Philips (jay) (retired) 2017-10-24 21:52:53 UTC
(In reply to Telesto from comment #19)
> warn:vcl:2744:1544:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx():
> could not load image res/colorslider.png via icon theme tango
> warn:vcl:2744:1544:vcl/source/gdi/bmpacc.cxx:52: Forbidden Access to empty
> bitmap!

No idea about this as the icon is there.

https://cgit.freedesktop.org/libreoffice/core/tree/icon-themes/tango/res/colorslider.png

Its been requested here

https://opengrok.libreoffice.org/xref/core/cui/source/dialogs/colorpicker.cxx#909
Comment 22 Maxim Monastirsky 2017-10-24 22:38:20 UTC
(In reply to Yousuf Philips (jay) from comment #21)
> No idea about this as the icon is there.
> 
> https://cgit.freedesktop.org/libreoffice/core/tree/icon-themes/tango/res/
> colorslider.png
That icon was not packaged into images_tango.zip, fix is here: https://gerrit.libreoffice.org/43796/
Comment 23 Commit Notification 2017-10-25 06:15:42 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=48e64ea4a8201a43457e46422a07f14f697eb91e

tdf#107569 Fix missing res/colorslider.png

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2017-10-26 01:14:34 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c566b78de541645d81463b460d3332da5878020f

tdf#107569 Tango: Fix missing icons in Writer menu bar

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2017-10-26 01:14:45 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=51e2dc5139e0c34672eb433421cbe89e7854e6dd

tdf#107569 Tango: Fix missing icons in Writer menu bar (part 2)

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Xisco Faulí 2017-11-26 17:49:38 UTC
A polite ping to Yousuf Philips: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 27 Yousuf Philips (jay) (retired) 2017-12-02 19:07:30 UTC
(In reply to Xisco Faulí from comment #26)
> A polite ping to Yousuf Philips: is this bug fixed? if so, could you
> please close it as RESOLVED FIXED ? Thanks

Additional work is needed to fix all the problems, but i'll leave it up to others to do so.
Comment 28 QA Administrators 2018-12-03 03:59:43 UTC Comment hidden (obsolete)
Comment 29 andreas_k 2019-04-17 11:10:14 UTC
As tango is unmaintained and since the last update of tango there are a lot of new icons added, I think this bug can be closed and if someone will do tango work in the future the work can start with check the difference to other icon themes.