Bug Hunting Session
Bug 80914 - TOOLBAR: No means to add a 'Find' button to the toolbar to open Find toolbar
Summary: TOOLBAR: No means to add a 'Find' button to the toolbar to open Find toolbar
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 91898 (view as bug list)
Depends on:
Blocks: UNO-Command-New Find-Toolbar
  Show dependency treegraph
 
Reported: 2014-07-04 13:48 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-09-24 20:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
find-button (54.33 KB, image/png)
2014-07-04 14:29 UTC, Kevin Suo
Details
find toolbar (70.06 KB, image/png)
2014-07-04 14:56 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-07-04 13:48:06 UTC
I checked through the entire list of possible customization entries but wasnt able to find an option to add a 'Find' button to the toolbar. It should be in the view category along with 'Find & Replace' but it isnt.
Comment 1 Yousuf Philips (jay) (retired) 2014-07-04 14:20:53 UTC
Well checking 3.3.0, it doesnt have a Find menu item, but i see it in 3.6.7, so i'm assuming it was added within this release time frame.
Comment 2 Kevin Suo 2014-07-04 14:29:42 UTC
Created attachment 102273 [details]
find-button

Do you mean this one?
Comment 3 Jorendc 2014-07-04 14:49:12 UTC
This bug is not about making it a default button or so. So no input of UX-advice is needed as far I can see. Removing UX-advice.

There should be indeed a possibility to attach the 'find' command to the toolbar if you would like to (customization). Because there is currently not the possibility -> NEW.
Comment 4 Kevin Suo 2014-07-04 14:56:15 UTC
Created attachment 102274 [details]
find toolbar

I also find this one. see the right side.
Comment 5 V Stuart Foote 2014-07-04 15:02:19 UTC
@Jay,

That is correct. The FindText--.uno:FindText--is not directly called, rather it is an element of the "FindBar", which has accelerator <Ctrl>+F assigned. It is also exposed as a menu selection on the Edit drop down.

Not sure .uno:FindText would remain functional if moved outside the FindBar with a directly linking icon. It looks to be packed within the FindBar.

On the other hand, the Find & Replace button, which is directly linked to--.uno:SearchDialog--opens a dialog frame and can be called independently, and can currently be added to the Standard toolbar.

The "FindBar" was brought over at fork from OOo, but has been reworked several times. Including recent work to implement as GTK+ UI widgets. You'll find "findbar.xml" defined for each LO component. But the heavy lifting is done in
http://opengrok.libreoffice.org/xref/core/svx/source/tbxctrls/tbunosearchcontrollers.cxx and http://opengrok.libreoffice.org/xref/core/svx/inc/tbunosearchcontrollers.hxx  with the FindText module resident in http://opengrok.libreoffice.org/xref/core/sc/source/ui/app/inputhdl.cxx

Suppose we could add a Find button calling the FindBar, but seems redundant given existing menu and accelerator assignment to open the toolbar. Or do you think otherwise? 

Setting new, but suspect could equally be closed RESOLVED WONTFIX
Comment 6 Yousuf Philips (jay) (retired) 2014-07-04 17:09:56 UTC
@Stuart,

Well if possible, i would like the button to simply trigger the same action done by clicking Edit > Find or simply execute a Ctrl+F keyboard call. I was planning to use the 'Find & Replace' dialog to get the same functionality, but unfortunately it doesnt have a 'Find Previous' button. This was making me think that the find & replace dialog could be customized to provide both find and replace functionality.

I am currently customizing my standard toolbar with buttons that i am using regularly and wish it to have all of the basic functionality i need, so that i wont have to open a menu or run accelerators.
Comment 7 Yousuf Philips (jay) (retired) 2015-06-11 22:58:33 UTC
*** Bug 91898 has been marked as a duplicate of this bug. ***
Comment 8 Yousuf Philips (jay) (retired) 2017-10-22 19:25:27 UTC
Gulsah: is this something you'd be interested in taking on?
Comment 9 Gülşah Köse 2017-10-22 20:06:32 UTC
Yes, I'll take a look at this.
Comment 10 Thomas Lendo 2019-09-24 20:16:56 UTC
(In reply to Gülşah Köse from comment #9)
Gülşah, any chance for looking at this?