Bug 108031 - FILEOPEN XLSX: Area chart labels not rotated
Summary: FILEOPEN XLSX: Area chart labels not rotated
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: JoNi
URL:
Whiteboard: target:6.1.0 target:5.4.5 target:6.0.0.2
Keywords: bibisected, bisected, regression
: 114285 (view as bug list)
Depends on:
Blocks: OOXML-Chart Chart-Labels
  Show dependency treegraph
 
Reported: 2017-05-23 16:20 UTC by Gabor Kelemen
Modified: 2018-01-07 14:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file showing the problem (18.63 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-05-23 16:20 UTC, Gabor Kelemen
Details
The file opened in LO 5.2 with rotated labels (126.47 KB, image/png)
2017-05-23 16:26 UTC, Gabor Kelemen
Details
In Excel 2013 and LO 5.3 side by side (195.56 KB, image/png)
2017-05-23 16:32 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-05-23 16:20:36 UTC
Created attachment 133488 [details]
Example file showing the problem

Attached file was made eith Excel 2013 and includes an area chart. 

The row labels of the chart appear rotated in Excel and in LO 5.2 as well but not in 5.3.
Comment 1 Gabor Kelemen 2017-05-23 16:26:35 UTC
Created attachment 133489 [details]
The file opened in LO 5.2 with rotated labels

It's interesting that Text orientation is 0 degrees, yet the text appears rotated.
Comment 2 Gabor Kelemen 2017-05-23 16:32:50 UTC
Created attachment 133490 [details]
In Excel 2013 and LO 5.3 side by side
Comment 3 raal 2017-05-23 18:10:20 UTC
This seems to have begun at the below commit.
Adding Cc: to Jochen Nitschke ; Could you possibly take a look at this one?
Thanks

aff42b2b4d7417bf87e012f814f47496b18aad29 is the first bad commit
commit aff42b2b4d7417bf87e012f814f47496b18aad29
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Sep 27 16:42:52 2016 +0200

    source sha:99226f343e4ad9ebcbb4e31c17d3fb706153e18b

author	Jochen Nitschke <j.nitschke+logerrit@ok.de>	2016-06-05 20:45:43 (GMT)
committer	Jochen Nitschke <j.nitschke+logerrit@ok.de>	2016-06-11 10:24:57 (GMT)
commit	99226f343e4ad9ebcbb4e31c17d3fb706153e18b (patch)
tree	e54430f4e6525b12ae9a5d9fb251bebd495fb421
parent	ffac8e3a483c84de2961784fceac2b21aa39a18c (diff)
try auto rotate tick labels only when useful tdf#99883
Comment 4 JoNi 2017-06-02 11:01:25 UTC
oh this code is brittle, let's see if I can fix it without breaking other stuff.
currently the code doesn't recognize the x-Axis as an horizontal axis if I fix that some other stuff breaks that was relying on this behaviour.

relevant code for label placement in chart2/source/view/axes/VCartesianAxis.cxx: VCartesianAxis::createTextShapes  VCartesianAxis::createTextShapesSimple

check for hozizontal axis in chart2/source/view/axes/Tickmarks.cxx: TickFactory2D::isHorizontalAxis

stuff that breaks in chart2/source/view/axes/VCartesianAxis.cxx:
lcl_doesShapeOverlapWithTickmark

if I remove the checks for the bIsVerticalAxis / bIsHorizontalAxis case in lcl_doesShapeOverlapWithTickmark and keep the fallback it works, at least for this file.

need more test to see if nothing else breaks, which is hard because everything has to be compared with Excel.
Comment 5 JoNi 2017-06-08 18:19:06 UTC
work on this in https://gerrit.libreoffice.org/#/c/38355/

I'll need some time testing the fix.
Comment 6 Xisco Faulí 2017-09-14 09:30:41 UTC
Dear developer,
This bug has been in ASSIGNED status for more than 3 months without any activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 7 JoNi 2017-12-23 09:46:11 UTC
*** Bug 114285 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2017-12-23 11:08:13 UTC
Jochen Nitschke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=38bf5f69663f64434a3a0a74e02c1a23f876b677

tdf#108031 Area chart labels not rotated

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Jacques Guilleron 2017-12-24 10:04:50 UTC
Hi Jochen,

Fine. Works as expected with
LO 6.1.0.0.alpha0+ Build ID: c926a1e34672afaa5b7de0e3b08b1537e88fbb6f
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-23_23:59:27
Locale: fr-FR (fr_FR); Calc: CL

Merry Christmas
Comment 10 Commit Notification 2018-01-07 14:19:01 UTC
Jochen Nitschke committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5ecffcb48140eb055e71b0d8905d693036e61bc6&h=libreoffice-5-4

tdf#108031 Area chart labels not rotated

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-01-07 14:19:12 UTC
Jochen Nitschke committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e328b25e634035cf3810061579d33623846173c0&h=libreoffice-6-0

tdf#108031 Area chart labels not rotated

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.