Bug 108231 - CRASH: Writer crashes while closing after copy/pasting specific content (GTK3)
Summary: CRASH: Writer crashes while closing after copy/pasting specific content (GTK3)
Status: RESOLVED DUPLICATE of bug 108109
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Linux (All)
: highest critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.4.0.1 target:5.3.4
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2017-05-29 20:18 UTC by Xisco Faulí
Modified: 2017-05-30 15:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (37.59 KB, text/plain)
2017-05-30 10:06 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-05-29 20:18:46 UTC
this is a follow-up bug from bug 108109.

Steps to Reproduce:
1. Open attachment 133582 [details] (bug 108092)
2. Copy one of the vertical (text)boxes
3. Open a new document
4. Paste the textbox
5. Close the first opened document
6. Close the newly created document without saving (red cross or file -> exit)
7. LibreOffice will keep running in the background (blocking the clipboard).
Crash report popups after kill the process and restarting LibO

Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2016-06-24 14:06:36 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2016-06-24 14:21:26 (GMT)
commit	88cd9dd591d7921e5bce33c170b457ae5aa871bb (patch)
tree	97808bcd9c8183e8eba75b4b7f1c907b003951c6
parent	65a88b51b3df8e4c2756fde4058194d892c627f1 (diff)
Resolves: rhbz#1326304 cannot detect loss of wayland clipboard ownership
gtk_clipboard_get_owner always returns what you set with
gtk_clipboard_set_with_owner and that doesn't change if some other
application takes over the clipboard
Comment 1 Caolán McNamara 2017-05-30 09:22:49 UTC
not reproducible for me
Comment 2 Julien Nabet 2017-05-30 09:37:41 UTC
I'll try to reproduce this but meanwhile let's add "wantbacktrace"
Comment 3 Hussam Al-Tayeb 2017-05-30 09:48:16 UTC
I don't have a debug libreoffice build, but for what it is worth, this includes gtk+/glib debug symbols for this crash.
https://paste.gnome.org/pufkrgpbw
Comment 4 Aron Budea 2017-05-30 10:06:25 UTC
Created attachment 133721 [details]
backtrace

In a debug build an assert is triggered as well. Attaching backtrace.
Comment 5 Caolán McNamara 2017-05-30 10:26:29 UTC
I would assume that the gtk changes just made the gtk3 version work the same as some other backends and bring bug 108109 to the gtk3 platform
Comment 6 Commit Notification 2017-05-30 11:36:59 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db38e3f201517acf22c1773ae9fc4cb2514788b1

tdf#108231 tdf#108109 xmloff: SvxUnoDrawingModel doesn't implement...

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Stahl 2017-05-30 11:46:22 UTC
turned out to have the same cause as windows anyway

*** This bug has been marked as a duplicate of bug 108109 ***
Comment 8 Hussam Al-Tayeb 2017-05-30 11:50:44 UTC
Will the fix be backported to the 5-4 branch?
Comment 9 Julien Nabet 2017-05-30 12:14:15 UTC
(In reply to Hussam Al-Tayeb from comment #8)
> Will the fix be backported to the 5-4 branch?

It's on review.
5.4 branch: https://gerrit.libreoffice.org/#/c/38213/
5.3 branch: https://gerrit.libreoffice.org/#/c/38214/
Comment 10 Commit Notification 2017-05-30 14:31:56 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d9ae5391e72b91f80d6915d2ff420e191fdc892f&h=libreoffice-5-4

tdf#108231 tdf#108109 xmloff: SvxUnoDrawingModel doesn't implement...

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-05-30 15:59:54 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=024fa6b3915fd84586b348b5033dcc4312cd8926&h=libreoffice-5-3

tdf#108231 tdf#108109 xmloff: SvxUnoDrawingModel doesn't implement...

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.