Bug 108752 - non visible item in context submenu Styles for Writer
Summary: non visible item in context submenu Styles for Writer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.beta2
Hardware: All All
: medium normal
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard:
Keywords:
: 112396 (view as bug list)
Depends on:
Blocks: Context-Menu Writer-Styles-Character 85940
  Show dependency treegraph
 
Reported: 2017-06-25 07:42 UTC by Roman Kuznetsov
Modified: 2019-09-22 05:21 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
non visible item in submenu Styles (18.96 KB, image/png)
2017-06-25 07:43 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2017-06-25 07:42:15 UTC
Description:
non visible item in new context submenu Styles for Writer 5.4.0.1


Steps to Reproduce:
1. Open any writers doc
2. select text
3. click on it right mouse
4. select Styles -> in context menu
5. look on non visible item

Actual Results:  
there is non visible item

Expected Results:
this item must be visible or must be delete


Reproducible: Always

User Profile Reset: No

Additional Info:
this item make some formatting


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Roman Kuznetsov 2017-06-25 07:43:01 UTC
Created attachment 134258 [details]
non visible item in submenu Styles
Comment 2 Roman Kuznetsov 2017-06-25 07:44:43 UTC
Jay, did you implement this submenu?
Comment 3 Dieter 2017-06-25 09:02:32 UTC
I confirm this bug. Workaround with Tools => Customize is of course possible.
Comment 4 Yousuf Philips (jay) (retired) 2017-06-25 20:30:45 UTC
(In reply to kompilainenn from comment #2)
> Jay, did you implement this submenu?

Yes noticed this a few days back and thought it would resolve itself with future updates but it hasnt.

Maxim: Any idea why .uno:StyleApply?Style:string=Citation&FamilyName:string=CharacterStyles is working fine in the menu bar but not in the context menu.

Xisco: We may need to revert your patch for 5.4 if we cant find a quick fix. :(

https://cgit.freedesktop.org/libreoffice/core/commit/?id=60954fc67a022565741c4ccb4667581a5a790a10
Comment 5 Maxim Monastirsky 2017-07-13 12:58:09 UTC
(In reply to Yousuf Philips (jay) from comment #4)
> Maxim: Any idea why
> .uno:StyleApply?Style:string=Citation&FamilyName:string=CharacterStyles
> is working fine in the menu bar but not in the context menu.
Probably because the 5-4 branch is missing the fix of Bug 95489.
Comment 6 Yousuf Philips (jay) (retired) 2017-07-14 19:38:45 UTC
(In reply to Maxim Monastirsky from comment #5)
> Probably because the 5-4 branch is missing the fix of Bug 95489.

Could you backport it if it is the issue, as gerrit isnt allowing me to do it.
Comment 7 Roman Kuznetsov 2017-07-28 19:58:18 UTC
in release LO 5.4 this still repro =(
Comment 8 Yousuf Philips (jay) (retired) 2017-07-29 16:36:19 UTC
The patch has been submitted - https://gerrit.libreoffice.org/40552
Comment 9 Roman Kuznetsov 2017-08-31 11:05:13 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> The patch has been submitted - https://gerrit.libreoffice.org/40552

in 5.4.2 will be fixed?
Comment 10 Jean-Baptiste Faure 2017-08-31 11:07:33 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> The patch has been submitted - https://gerrit.libreoffice.org/40552

Still not fixed in LO 5.4.2.0.0+. Does this patch need review ? I can try it.

Best regards. JBF
Comment 11 Yousuf Philips (jay) (retired) 2017-08-31 11:43:28 UTC
(In reply to Jean-Baptiste Faure from comment #10)
> Still not fixed in LO 5.4.2.0.0+. Does this patch need review ? I can try it.

Patch was merged a month ago.
Comment 12 Jean-Baptiste Faure 2017-08-31 12:19:43 UTC
(In reply to Yousuf Philips (jay) from comment #11)
> (In reply to Jean-Baptiste Faure from comment #10)
> > Still not fixed in LO 5.4.2.0.0+. Does this patch need review ? I can try it.
> 
> Patch was merged a month ago.

Indeed. That's strange, the bug is fixed in my build of master but not in my build of LO 5.4, even with a clean profile. Will try a complete rebuild.

Best regards. JBF
Comment 13 Jean-Baptiste Faure 2017-08-31 19:20:25 UTC
I confirm that this bug is not fixed in LO 5.4.2.0.0+ although it has the patch from comment #8. Same problem in the Style menu : bug 112087.

Best regards. JBF
Comment 14 Xisco Faulí 2017-09-01 08:49:21 UTC
@Jay, Can you confirm the bug is not completely fixed based on comment 13?
Comment 15 Aron Budea 2017-09-06 04:31:18 UTC
Jay, the master and 5.4 commits aren't the same, one replaced the entry in CharacterStyles, the other in ParagraphStyles in officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=90b083bd8e922ec4adf245aedfff14c6c6c01bf6
<node oor:name=".uno:StyleApply?Style:string=Citation&amp;FamilyName:string=CharacterStyles" oor:op="replace">

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9ab228fdd6efe9a7873e3de1bb2357531a79feac&h=libreoffice-5-4
<node oor:name=".uno:StyleApply?Style:string=Citation&amp;FamilyName:string=ParagraphStyles" oor:op="replace">
Comment 16 Yousuf Philips (jay) (retired) 2017-09-06 10:53:04 UTC
(In reply to Aron Budea from comment #15)
> Jay, the master and 5.4 commits aren't the same, one replaced the entry in
> CharacterStyles, the other in ParagraphStyles in
> officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu:

thanks. patch is in https://gerrit.libreoffice.org/#/c/41986/
Comment 17 Yousuf Philips (jay) (retired) 2017-09-18 15:49:30 UTC
*** Bug 112396 has been marked as a duplicate of this bug. ***
Comment 18 Yousuf Philips (jay) (retired) 2017-09-18 15:54:47 UTC
verified its fixed now.

Version: 5.4.2.0.0+
Build ID: 61d85c4e7c30ea0f5242d927b7456190020b4fbe
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-4, Time: 2017-09-15_12:00:43
Locale: en-US (en_US.UTF-8); Calc: group
Comment 19 Dieter 2019-09-22 05:21:16 UTC
(In reply to Yousuf Philips (jay) (retired) from comment #18)
> verified its fixed now.

status VERIFIED FIXED