Download it now!
Bug 108942 - FILEOPEN: RTF: Last paragraph is displayed on second page
Summary: FILEOPEN: RTF: Last paragraph is displayed on second page
Status: RESOLVED DUPLICATE of bug 106354
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks:
 
Reported: 2017-07-04 10:50 UTC by Xisco Faulí
Modified: 2017-07-14 10:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-07-04 10:50:16 UTC
Steps:
1. Open attachment 64535 [details] from bug 52386
2. Last paragraph is displayed in the second page

[Bug found by office-interoperability-tools]

Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: cb37c5f0f3de7b545231a53d46a5271058af76ad
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-23_06:55:41
Locale: es-ES (es_ES); Calc: group
Comment 1 Xisco Faulí 2017-07-04 10:52:25 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2017-04-27 14:25:20 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2017-04-27 14:28:00 (GMT)
commit	3eda8234acf09cd5a31cdcde76f04631a51fcc37 (patch)
tree	f038f1554670fd2ca315c7213ae8d14e84bf5e85
parent	e31c535b574fc37e6961c5ce7bd507a30e6abff1 (diff)
Resolves: tdf#107411 LibreOffice hangs at RTF import time
regression from...

commit b993942622897fc64a1f7462189fa0463eb30e1c
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Sat Apr 1 16:43:04 2017 +0100

    ubsan: use WrapTextMode_MAKE_FIXED_SIZE instead of -1 as unset flag

cause WrapTextMode_MAKE_FIXED_SIZE is >= 0

Bisected with bibisect-linux-64-5.4

Adding Cc: to Caolán McNamara
Comment 2 Caolán McNamara 2017-07-13 13:50:52 UTC
It was like this in 5.3 already, I don't buy that its a regression. I think that it just a side effect of the import bug between b993942622897fc64a1f7462189fa0463eb30e1c and 3eda8234acf09cd5a31cdcde76f04631a51fcc37 that it fit on one page.
Comment 3 Xisco Faulí 2017-07-14 10:13:24 UTC
Hi Caolán,
I did some further investigation and it looks the problem was initially introduced by 0982572705644128fa20c4da464aa58d875612a7 which is already reported in bug 106354. Recently, the problem was fixed by your commit b993942622897fc64a1f7462189fa0463eb30e1c and lately reintroduced by 3eda8234acf09cd5a31cdcde76f04631a51fcc37.
I guess we can close this as a duplicate of bug 106354. Sorry for the noise.

*** This bug has been marked as a duplicate of bug 106354 ***
Comment 4 Xisco Faulí 2017-07-14 10:18:47 UTC
(In reply to Xisco Faulí from comment #3)
> Hi Caolán,
> I did some further investigation and it looks the problem was initially
> introduced by 0982572705644128fa20c4da464aa58d875612a7 which is already
> reported in bug 106354. Recently, the problem was fixed by your commit
> b993942622897fc64a1f7462189fa0463eb30e1c and lately reintroduced by
> 3eda8234acf09cd5a31cdcde76f04631a51fcc37.
> I guess we can close this as a duplicate of bug 106354. Sorry for the noise.
> 
> *** This bug has been marked as a duplicate of bug 106354 ***

ouch, I used the incorrect hash. Issue initially introduced by 75fc9e669f209472ec6a282848166d96d02d84d9