Bug 108944 - FILEOPEN: DOCX: footnote separators missing
Summary: FILEOPEN: DOCX: footnote separators missing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All All
: medium normal
Assignee: Justin L
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.3.6 target:5.4.1
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: Footnote-Endnote DOCX
  Show dependency treegraph
 
Reported: 2017-07-04 11:27 UTC by Xisco Faulí
Modified: 2017-08-02 16:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
missing footnote separators (12.93 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-07-04 11:27 UTC, Xisco Faulí
Details
Simple footnote.docx: just one footnote is not enough to show the problem. (13.55 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-07-04 18:33 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-07-04 11:27:42 UTC
Created attachment 134476 [details]
missing footnote separators

Steps:
1. Open attached document

Observed behaviour: footnote separator is missing in all the pages

[Bug found by office-interoperability-tools]

Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: cb37c5f0f3de7b545231a53d46a5271058af76ad
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-23_06:55:41
Locale: es-ES (es_ES); Calc: group
Comment 1 Xisco Faulí 2017-07-04 11:29:13 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2017-05-03 06:39:31 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-05-03 15:02:19 (GMT)
commit	e79ef12b7a904f17d4147fa409d055c12b70f952 (patch)
tree	183a50f46068c82349441b3ba3ee72847f20f8a6
parent	cc0ea8bb251c464d55e831ed7e11a2f3f7371d38 (diff)
tdf#107033 DOCX import: fix unexpected missing footnote separator
Regression from commit 330b860205c7ba69dd6603f65324d0f89ad9cd5f
(fdo#68787 DOCX import: handle when w:separator is missing for
footnotes, 2013-09-04), the problem was footnote settings were modified
also in case there were no footnotes at all in the document.

Make the bug scenario and the original one working at the same time by
touching footnote settings only in case there is at least one footnote
in the current section.

Bisected with bibisect-linux-64-5.4

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2017-07-04 11:37:37 UTC
attachment 41983 [details] from bug 33072 also misses the separator after e79ef12b7a904f17d4147fa409d055c12b70f952
Comment 3 Justin L 2017-07-04 18:33:29 UTC
Created attachment 134483 [details]
Simple footnote.docx: just one footnote is not enough to show the problem.
Comment 4 Justin L 2017-07-29 16:27:55 UTC
suggested bug fix at https://gerrit.libreoffice.org/40551

Note: The regression was backported to 5.3.4.
Comment 5 Commit Notification 2017-07-31 09:24:22 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f57c09aadd40009173f8ae3654004dd0cad9fb8

tdf#108944 writerfilter: fix missing footnote separator

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2017-08-01 22:52:15 UTC
Fixed verified in

Version: 6.0.0.0.alpha0+
Build ID: 50799a721c7ddcf9475a1b79984ed64ddd7cdf57
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 7 Commit Notification 2017-08-02 08:26:34 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=234df2fb5901588ccf20cb35cb4c5922aeb89817&h=libreoffice-5-3

tdf#108944 writerfilter: fix missing footnote separator

It will be available in 5.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-08-02 08:29:34 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6d77bfc9b2cf5a30a06a97c69ed814e3a97ed685&h=libreoffice-5-4

tdf#108944 writerfilter: fix missing footnote separator

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Timur 2017-08-02 10:20:09 UTC
(In reply to Xisco Faulí from comment #6)
> Fixed verified in
Then Fixed.