Bug 109042 - Add Calc extension with multivariate regression (more than 2 variable input)
Summary: Add Calc extension with multivariate regression (more than 2 variable input)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Dennis Francis
URL:
Whiteboard: target:6.2.0
Keywords:
: 114811 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-07-09 22:10 UTC by curtis martz
Modified: 2018-07-03 08:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (80.66 KB, image/png)
2017-07-10 01:44 UTC, m.a.riosv
Details
Comment 8: Confuse to know about the meaning of results of Linest and Logest Functions (47.71 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-01-03 16:32 UTC, jrodriguez1717
Details

Note You need to log in before you can comment on or make changes to this bug.
Description curtis martz 2017-07-09 22:10:57 UTC
Description:
Excel analysis pak allows multivariate regression and oo has an extension for multivariate regression. It is extremely useful for developing predictive models with more than one input variable and correction factors etc. If this function is in fact available already,  I can find no documentation of it. Thank you : ) 

Actual Results:  
only one input variable is allowed under data stats regression :(


Expected Results:
ability to select multiple columns as input variables


Reproducible: Always

User Profile Reset: No

Additional Info:
multivariate regression excel analysis pak


User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/537.36 (KHTML, like Gecko)  Chrome/30.0.1599.114 Safari/537.36 Puffin/5.2.0IP
Comment 1 m.a.riosv 2017-07-10 01:44:14 UTC
Created attachment 134567 [details]
Screenshot

Please what is your LibreOffice version?.

At least since 5.1 there are two variables allowed.

BTW usually OOo extensions works with LibreOffice.
Comment 2 curtis martz 2017-07-10 01:59:34 UTC
Thank you for your fast response! For my specific use I require more than 2 variable input as I'm sure most multivariable models do! It would be very cool and useful if Libre calc could do more than 2 input variables!
Comment 3 curtis martz 2017-07-10 02:00:45 UTC
Thank you. You are awesome : )
Comment 4 curtis martz 2017-07-10 02:03:57 UTC
I tried an oo statistics extension but it didn't seem to work in libre.
Comment 5 tommy27 2017-07-11 08:01:34 UTC
enhancement request. status NEW
Comment 6 Regina Henschel 2017-07-11 15:57:52 UTC
The function LINEST can work with multiple variables. The only constrain is, that they need to be in adjacent cells.

See the definition of LINEST in http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part2.html#__RefHeading__1018704_715980110 or better use the odt-document, where the formulas are better rendered http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part2.odt.

Some parts are cumbersome to read, because the data may be in columns or in rows, and because LINEST can handles multiple Y-variables too. You might need to extract your case to get a better readable document.

Only the wizard is limited. Calc has already all tools to calculate such regressions, but you have to use the functions manually. Therefore this enhancement request is essentially about extending the wizard.
Comment 7 m.a.riosv 2018-01-02 23:15:42 UTC
*** Bug 114811 has been marked as a duplicate of this bug. ***
Comment 8 jrodriguez1717 2018-01-03 16:26:52 UTC
In comment 6, Regina Henschel tells that we can use The Linest and Logest Function because both accept to use more than to variables in Calc 6.0.0.1. But the result that show after run them aren't clear with labels and it is to hard to start to guess what is what. And there aren't options to Power and Polynomial curves.

And it would be useful too, to have all of them in Statistical Menu into Regression Option with Multivariate Regression.
Comment 9 jrodriguez1717 2018-01-03 16:32:40 UTC
Created attachment 138856 [details]
Comment 8: Confuse to know about the meaning of results of Linest and Logest Functions

Please see comment 8
Comment 10 Commit Notification 2018-07-02 21:20:00 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b7a02f2bb66b990289eb7f4dc80069d1545179a4

tdf#109042 : Add support for multivariate regression...

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.