Download it now!
Bug 109272 - Wrong cursor position when deleting a selection in Show Changes mode
Summary: Wrong cursor position when deleting a selection in Show Changes mode
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2017-07-22 12:17 UTC by Rosemary Sebastian
Modified: 2017-09-26 14:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Left cursor (1.17 KB, image/png)
2017-08-09 05:00 UTC, halima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rosemary Sebastian 2017-07-22 12:17:18 UTC
Description:
In change-tracking, if Show Changes mode is set, the cursor is placed at the right end of a selection after it is deleted using Backspace.

Steps to Reproduce:
1. Open a writer document.
2. Insert a word.
3. Turn on Track Changes mode.
4. Select the whole word and delete it using Backspace.
5. The cursor is at the right end of the word.

Actual Results:  
The cursor is at the right end of the word.

Expected Results:
The cursor should be at the left end of the word.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Aron Budea 2017-08-09 04:21:54 UTC
Both in case of backspace/delete the cursor ends up on the side of the selection where it initially was (provided there's a selection), and I'm not sure that's an issue.
Comment 2 halima 2017-08-09 05:00:22 UTC
Created attachment 135331 [details]
Left cursor

I cannot reproduce it as you can see in the attached image 

Version: 5.1.4.2
Build ID: 1:5.1.4-0ubuntu1
CPU Threads: 1; OS Version: Linux 4.8; UI Render: default;
Locale: en-US (en_US.UTF-8)

Description:    Ubuntu 16.04.2 LTS
Comment 3 Aron Budea 2017-08-09 13:21:12 UTC
Halima, the behavior depends on the cursor position before hitting backspace/delete. If you selected the text from left to right, and the cursor is on the right side, then it'll stay there after hitting backspace/delete. On the other hand if you selected it from right to left, and the cursor is on the left side, it'll stay there.
Comment 4 Rosemary Sebastian 2017-08-10 05:45:10 UTC
(In reply to Aron Budea from comment #3)
> Halima, the behavior depends on the cursor position before hitting
> backspace/delete. If you selected the text from left to right, and the
> cursor is on the right side, then it'll stay there after hitting
> backspace/delete. On the other hand if you selected it from right to left,
> and the cursor is on the left side, it'll stay there.

That's interesting. There are other ways to make a selection. E.g., one can select a word by double-clicking on it. How is the cursor position after deletion defined in this case?
Comment 5 Aron Budea 2017-08-10 11:23:24 UTC
(In reply to Rosemary Sebastian from comment #4)
> That's interesting. There are other ways to make a selection. E.g., one can
> select a word by double-clicking on it. How is the cursor position after
> deletion defined in this case?

It is the same place where it was before the deletion, that seems to be universal. This, and my comments above are based on observation btw, so if anyone knows exactly how it's supposed to work, I'm curious about it as well.
Comment 6 Rosemary Sebastian 2017-08-14 09:47:08 UTC
Bug 103458 is related. You may have a look at it.
Comment 7 Rosemary Sebastian 2017-08-17 05:00:25 UTC
Bug 103458 covers two bugs actually - wrong cursor position and the fact that currently we can delete stuff multiple times in change-tracking mode. I pointed to the bug report because you didn't seem convinced.

The universal behaviour is that the cursor is at the start of a selection after deletion, taking into account how it works in LibreOffice without change-tracking enabled. That we have a cursor associated with a selection looks like another bug, but I am not sure.
Comment 8 Aron Budea 2017-08-21 00:49:58 UTC
To me where the cursor ends up after deletion with change tracking seems like a minor detail, as it doesn't affect the behavior, unlike when change tracking is disabled. I can accept either decision, but can't establish what would be the choice.

I checked Word for reference, there deleting selection with change tracking is according to your expectation: depends on whether the key was backspace/delete.
Do we want to behave the same way as Word?

There seems to be another interesting (unrelated) difference in how change tracking works in Word: if you have part of a word selected, and start typing (thus replace the selected part), then Word replaces the whole word with your typing and the unchanged part, not only the selection.
Comment 9 Rosemary Sebastian 2017-08-21 05:38:12 UTC
(In reply to Aron Budea from comment #8)
> To me where the cursor ends up after deletion with change tracking seems
> like a minor detail, as it doesn't affect the behavior, unlike when change
> tracking is disabled. I can accept either decision, but can't establish what
> would be the choice.

I am not claiming to be a LibreOffice UX expert. But I do think the current behaviour is unnecessarily complicated.
Comment 10 Rosemary Sebastian 2017-08-21 08:50:21 UTC
Edit:

Expected behaviour:

The cursor should always be at the start of a selection after deletion. It should not depend on how a selection is made or how the selection is deleted.
Comment 11 Heiko Tietze 2017-09-09 10:10:23 UTC
Unlike Microsoft Word where the final cursor position depends on the action we keep the position where it has started (Aron explains in detail at c3,c8). Kind of academic question to me voting for WONTFIX. Any other opinions?
Comment 12 Heiko Tietze 2017-09-26 14:57:28 UTC
No further opinion, so let's keep the LibreOffice way.