Bug 109851 - FILESAVE: ODT: image misplaced after roundtrip
Summary: FILESAVE: ODT: image misplaced after roundtrip
Status: RESOLVED DUPLICATE of bug 109137
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2017-07-28 14:45 UTC by Xisco Faulí
Modified: 2019-08-13 08:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-07-28 14:45:09 UTC
Steps to reproduce:
1. Open attachment 104565 [details] from bug 82564
2. Export to .ODT
3. Open the new file

Reproduced in


Version: 6.0.0.0.alpha0+
Build ID: e0b6a4a2d2dec4e9614f27fc03f84b1c578028ec
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group


[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2017-07-28 14:46:17 UTC
Observed behaviour: Image on the right is shifted down.

Regression introduced in range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=ff9b7d118b34b53ec947af881fccd822e2aeb1fd..6959ed39e4f6f4a71a860acbf734b19b14f9c604
Comment 2 Jacques Guilleron 2017-08-03 13:37:28 UTC
Hi Xisco,
I reproduce too with

LO 6.0.0.0.alpha0+ Build ID: 643da8ec4e721d33dfdf8d78bedd50a915f1188d
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-26_01:24:22
Locale: fr-FR (fr_FR); Calc: CL

Frame Anchored to Paragraph and Properties Size to Relative to Paragraph area seems to solve the problem.
Comment 3 Aron Budea 2017-08-04 04:14:11 UTC
Bibisected to the following commit using bibisect-win32-5.2. Adding Cc: to Miklos Vajna, please take a look sometimes.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=50223ea6e212b60b7d33839c2753c5601fb50f95
author		Miklos Vajna <vmiklos@collabora.co.uk>	2016-03-31 13:05:48 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-03-31 17:49:00 (GMT)

"tdf#98987 sw: add AddVerticalFrameOffsets compat mode"
Comment 4 Miklos Vajna 2019-08-13 08:09:44 UTC
As far as I see this is working correctly on master. I've reverse-bisected this using bibisect-linux-64-6.1, and commit 510f335621db11873499751d63be6f8460c38915 (tdf#109137 sw textbox: fix initial wrap type of a shape's textbox, 2018-08-06) is where this started working. So closing as a duplicate.

*** This bug has been marked as a duplicate of bug 109137 ***