Bug Hunting Session
Bug 110442 - EDITING: The image within the selection doesn't disappear after cutting
Summary: EDITING: The image within the selection doesn't disappear after cutting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.4.0 target:6.3.1
Keywords: needUITest
Depends on:
Blocks:
 
Reported: 2017-07-30 20:42 UTC by Telesto
Modified: 2019-08-05 20:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (61.37 KB, application/vnd.oasis.opendocument.text)
2017-07-30 20:42 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-07-30 20:42:17 UTC
Description:
The image within the selection doesn't disappear after cutting

Steps to Reproduce:
1. Open the attached file
2. CTRL+A (select ALL)
3. CTRL+X (cut)
--
4. Open a new document (CTRL+N)
5. Paste (CTRL+V) -> working correctly

Actual Results:  
The image stays behind after cutting

Expected Results:
The image should disappear in the source document


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 6.0.0.0.alpha0+
Found in
Build ID: 18f80da7a689ab962735c0f657497b8f1ed4d606
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-28_05:15:48
Locale: nl-NL (nl_NL); Calc: CL

and in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-07-30 20:42:29 UTC
Created attachment 135004 [details]
Example file
Comment 2 Jean-Baptiste Faure 2017-07-31 04:53:33 UTC
I reproduce the problem with LO 5.4.1.0.0+ built at home under Ubuntu 16.04 x86-64, but not with LO 5.3.4 provided by Ubuntu. Please, could you confirm that it works for you as expected with the 5.3 branch ?

Setting as NEW anyway.

Best regards. JBF
Comment 3 Telesto 2017-07-31 14:36:28 UTC
No repro with:
Versie: 5.3.3.1 
Build ID: 46360c72c4823cefeaa85af537fba22bd568da7e
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 raal 2017-08-05 17:28:24 UTC
 This seems to have begun at the below commit.
Adding Cc: to Michael Stahl ; Could you possibly take a look at this one?
Thanks

378a91b21c14eb52e54cd1eb0bf6e20cf55a0592 is the first bad commit
commit 378a91b21c14eb52e54cd1eb0bf6e20cf55a0592
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sun Jul 30 00:55:43 2017 -0700

    source sha:14d2255cbd254dea6e87a04f747e7d6d3d54ceb9

author	Michael Stahl <mstahl@redhat.com>	2017-07-19 14:52:46 (GMT)
committer	Michael Stahl <mstahl@redhat.com>	2017-07-19 15:35:06 (GMT)
commit	14d2255cbd254dea6e87a04f747e7d6d3d54ceb9 (patch)
tree	a61160c897c15e2489bb38dae48e91634c435a00
parent	45df9012d14450b71ea1619f2a627f7e43320fe1 (diff)
tdf#107975: Revert "fix deleting an image anchored to last paragraph
Comment 5 Telesto 2017-08-05 18:46:04 UTC
@Xisco 
As request, the follow-up issue caused by reverting 2903d85d6197829633d7f96c95cd55821c2c20ff
Comment 6 Michael Stahl (CIB) 2017-08-07 12:49:44 UTC
removing regression keyword because this never worked properly, see bug 107975
Comment 7 Xisco Faulí 2018-04-23 09:55:02 UTC
Actually, this error is reproducible in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 8 QA Administrators 2019-04-24 02:49:42 UTC Comment hidden (obsolete)
Comment 9 Jean-Baptiste Faure 2019-06-08 09:27:33 UTC
Still reproducible with LO 6.3.0 beta1 built at home under Ubuntu 18.04 

Version: 6.3.0.0.beta1+
Build ID: c744dac16ad808c73021cb2cecefe1d484934451
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); UI-Language: fr-FR
Calc: threaded

Best regards. JBF
Comment 10 Commit Notification 2019-07-22 06:33:31 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/28b77c89dfcafae82cf2a6d85731b643ff9290e5%5E%21

tdf#117185 tdf#110442 sw: bring harmony & peace to fly at-char selection

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-07-22 06:33:41 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/be55b1915fd0374f8f25c2c1be2b39744666d052%5E%21

(related: tdf#110442) sw: fix a11y/UI selection of at-char flys

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Michael Stahl (CIB) 2019-07-22 11:19:22 UTC
fixed on master: at-char fly deletion now also happens in start and end paragraph of selection.
Comment 13 Commit Notification 2019-07-22 12:03:37 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/74912b98a81efd41da7565bb508f364e58ac9a9f%5E%21

(related: tdf#110442) sw: fix a11y/UI selection of at-char flys

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-07-22 12:15:23 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/3345feb67f2c49a1b76639965b56968e1c5f03ee%5E%21

tdf#117185 tdf#110442 sw: bring harmony & peace to fly at-char selection

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2019-07-29 23:35:44 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 0d36b32755ac662299e6a8165e9fa57311b74a2f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!
Comment 16 Jean-Baptiste Faure 2019-08-05 20:28:29 UTC
Verified fixed on Version: 6.3.1.0.0+
Build ID: 77d065767aa7054b59fae99ff00ac37bf7ce33f3
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); UI-Language: fr-FR
Calc: threaded

Thank you very much.

Best regards. JBF