Bug Hunting Session
Bug 111705 - Allowing Arabic mathematical expressions
Summary: Allowing Arabic mathematical expressions
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2017-08-11 19:55 UTC by Volga
Modified: 2018-11-27 20:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-08-11 19:55:06 UTC
Description:
LO Math can be improved to allowing Arabic mathematical expressions. To make them presented as expected, we can allowing 𞻰, 𞻱 placed as the middle line of a stacked fraction and being extended, also add an option to allow RTL direction.

Steps to Reproduce:
-

Actual Results:  
-

Expected Results:
-


Reproducible: Always

User Profile Reset: No

Additional Info:
https://en.wikipedia.org/wiki/Modern_Arabic_mathematical_notation


User-Agent: Mozilla/5.0 (Android 4.3; Mobile; rv:55.0) Gecko/55.0 Firefox/55.0
Comment 1 Volga 2017-08-11 20:04:48 UTC
We can also allowing √ presented its mirror forms in RTL direction activated, otherwise (if a font does not support it) forced mirrored it on screen.
Comment 3 Volga 2017-09-10 15:58:13 UTC
(In reply to Regina Henschel from comment #2)
> Volga: Is that available in MathML 2.0? In ODF 1.2 it is specified, that
> this is used. See
> http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.
> html#__RefHeading__440362_826425813 and
> http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.
> html#__RefHeading__1416212_253892949
Sorry for late responce. W3C has a documentation for this.
https://www.w3.org/TR/arabic-math/
According to the date this is published in 3 years later after MathML 2.0 published, so I think this is available in MML 2.0 and we can try it.
Comment 4 Volga 2017-10-16 05:45:21 UTC
(In reply to Regina Henschel from comment #2)
> Volga: Is that available in MathML 2.0? In ODF 1.2 it is specified, that
> this is used. See
> http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.
> html#__RefHeading__440362_826425813 and
> http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.
> html#__RefHeading__1416212_253892949

Hi Regina, WDYT?
Comment 5 Volga 2018-05-16 06:06:46 UTC
I think this is unnecessary, since TexMaths extension added support for XeLaTeX, which is able to produce such formulas.
Comment 6 Xisco Faulí 2018-11-27 20:21:46 UTC
(In reply to Volga from comment #5)
> I think this is unnecessary, since TexMaths extension added support for
> XeLaTeX, which is able to produce such formulas.

Closing as RESOLVED WONTFIX