Bug 111909 - PRINTING: Brochure mode preview sometimes wrong
Summary: PRINTING: Brochure mode preview sometimes wrong
Status: RESOLVED DUPLICATE of bug 110461
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-19 11:37 UTC by Claudio Nieder
Modified: 2017-10-17 08:09 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Print dialog on first opening when brochure mode was already set from an earlier print. What is shown in the little preview window on the left is wrong. (220.02 KB, image/png)
2017-08-19 11:40 UTC, Claudio Nieder
Details
After disabling and enabling brochure mode again the little preview window shows the correct layout. (233.39 KB, image/png)
2017-08-19 11:40 UTC, Claudio Nieder
Details
The document with which I observed the behaviour (115.25 KB, application/vnd.oasis.opendocument.text)
2017-08-21 11:11 UTC, Claudio Nieder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio Nieder 2017-08-19 11:37:25 UTC
Description:
The printing dialog preview of the page shows wrong content when opened a second time with brochure mode on.

Steps to Reproduce:
1. Open printing dialog
2. Enable brochure mode
3. E.g. save as PDF
4. Open printing dialog again
5. Observe, that the preview looks wrong.
6. Disable brochure mode
7. Enable brochure mode again
8. Observe, that the preview now looks correct.

Actual Results:  
When opening print dialog when brochure mode is already enabled, the content in the preview window is wrong. Only after disabling and reenabling brochure mode it is shown correctly.

Expected Results:
It should show a correct preview right away.


Reproducible: Always

User Profile Reset: Yes and the buggy behaviour still showed.

Additional Info:
See attached screenshot for how the preview appeared.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.1.2 Safari/603.3.8
Comment 1 Claudio Nieder 2017-08-19 11:40:03 UTC
Created attachment 135656 [details]
Print dialog on first opening when brochure mode was already set from an earlier print. What is shown in the little preview window on the left is wrong.
Comment 2 Claudio Nieder 2017-08-19 11:40:51 UTC
Created attachment 135657 [details]
After disabling and enabling brochure mode again the little preview window shows the correct layout.
Comment 3 Alex Thurgood 2017-08-21 07:26:10 UTC
@Claudio : In what way is the preview display "wrong" ? If I open both images, I don't see a huge difference, certainly nothing that strikes me as wrong, but perhaps I am missing something.

Please provide a document with which we can test, or does the problem occur with any document ?

Additionally, does the problem occur with a different printer ?
Comment 4 Alex Thurgood 2017-08-21 07:33:28 UTC
I don't seem to be able to reproduce this with a multipage Writer document and testing against 2 printers :

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

- networked Kyocera FS-C5150CDN
- networked HP OfficeJet Pro X576dw

but again, perhaps I am missing some crucial detail ?
Comment 5 Claudio Nieder 2017-08-21 11:08:10 UTC
(In reply to Alex Thurgood from comment #3)
> @Claudio : In what way is the preview display "wrong" ? If I open both
> images, I don't see a huge difference, certainly nothing that strikes me as
> wrong, but perhaps I am missing something.

The margins shown are totally wrong on the first time. 

> Please provide a document with which we can test, or does the problem occur
> with any document ?

I originally reported the issue as part of bug 111766 and was asked to report this issue separately. I will attach here the same document I used there, as soon as possible.
Comment 6 Claudio Nieder 2017-08-21 11:11:06 UTC
Created attachment 135694 [details]
The document with which I observed the behaviour
Comment 7 Alex Thurgood 2017-10-17 08:09:35 UTC

*** This bug has been marked as a duplicate of bug 110461 ***